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Introduction

When you complete this lesson, you will be able to do the following:
 Understand the basic capabilities of DraftSight.
 Start a DraftSight session.
 Identify the principal components of the DraftSight user interface.
 Identify the Graphics Area, Layout Tabs, Command Window, Command Prompt, and 

Status Bar.
 Identify the default toolbars in the user interface: Main Menu, Standard, Draw, 

Modify, Layer, Properties and EntitySnap.
 Understand the Coordinate System.
 Utilize the Draw commands.
 Utilize the Modify commands.
 Utilize the Properties and Layer functions.
 Understand DraftSight File Management.
 Understand the Pan and Zoom capabilities in DraftSight.
 Utilize the Text and Dimension functionality.
 Utilize the Print function.
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2 About This Course

About This Course
The goal of this course is to teach you how to use DraftSight. This course is designed to 
follow a sequential logical order. The focus of this course is on the fundamental skills 
and concepts central to the successful use of DraftSight. You should view the training 
course manual as a supplement to, not a replacement for, the system documentation and 
online help. Once you have developed a good foundation in the basic skills, you can refer 
to the online help for information on less frequently used command options.

What is DraftSight?
DraftSight is a drafting automation software tool. A coordinate system determines each 
point of a drawing surface or entity unambiguously. DraftSight uses the Cartesian 
coordinate system consisting of three coordinate axes. Axes are arranged orthogonally, 
crossing at the origin. All axes use the same unit of measurements.

Prerequisites
Students attending the course are expected to have the following:
 Drafting experience.
 Experience with the Windows® operating system.

Course Length
The recommended minimum length of this course is two days.

Using This Book
This training manual is intended to be used in a classroom environment under the 
guidance of an experienced DraftSight instructor. It is not intended to be a self-paced 
tutorial. The examples are designed to be demonstrated "live" by an instructor.

About the Training Files
A complete set of the various training files used throughout this course can be 
downloaded from the DraftSight website, www.DraftSight.com/files/Section (#)/
(filename.dwg).

Example: www.DraftSight.com/files/Section 2/arc 1.dwg.

The files are supplied in signed, self-extracting executable packages.
The files are organized by lesson number.
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Conventions Used in This Book
This manual uses the following typographical conventions:

Convention Meaning

Bold DraftSight commands and tools appear in this style. For 

example, Clicking the Line icon  means choose the 
Line tool on the Draw toolbar.

 The  symbol means press the Enter key on the keyboard.

Command 
prompt

Prompts and information in the command window and 
Command prompt are displayed in this font. For example: 
Specify next point» 

17 Click Line. The steps in the lessons are numbered in SansSerif bold.
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Section1
User Interface

Estimated Class Time: 1.5 hours

Objectives
This section introduces the interface available within DraftSight starting with the 
pointing device. The DraftSight window includes the Pull-Down Menu, Toolbars, the 
Graphics Window, the Command Line and the Status Bar. In addition you will learn 
special keyboard options and shortcut menus, how to use the dialog box, and how to 
access DraftSight's online help.

Pointing Device
 Use the mouse for selecting options in the DraftSight window.

DraftSight Window

The DraftSight window consists of the following areas:
 Title Bar

Minimize and maximize the DraftSight window from the Title Bar.
 Pull-Down Menu

Select commands from the pull-down menu headings.
 Toolbars

Use DraftSight toolbars as another method for selecting commands.
 Graphics Window

Create your drawing and drawing sheets in this area.
 Command Line

The command line will prompt you for the next step.
 Status Bar
This area contains handy toggle switches and displays the x, y and z coordinates.
 Shortcut Menus

Right-click your pointing device to display context-sensitive shortcut menus.
 Dialog Boxes
Input critical data for certain functions while creating your design.
 Keyboard Options
Use the keyboard to type options, text, or press Esc to cancel commands.
 Help Menu
Use the DraftSight Help menu to learn more about the program.
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Overview
Use the pointing device to select entities and options. This tutorial reviews the functions 
of a two- or three-button mouse. The pointing device is configured in the User 
Preference tab of the Options menu under Mouse Options. The Left Mouse Button is 
typically the pick button, and the Right Mouse Button is the <Enter> button. Pressing 
the <Enter> button, when the cursor is in the graphics area, activates a shortcut menu 
with the option to repeat the last command. This feature can be disabled in the User 
Preference tab of the Options dialog, under Mouse Options, by expanding right-clicking 
when a command is in progress; and selecting is the same as pressing <Enter>. 
Holding the right mouse button and dragging accesses the mouse-gesture widget. Use 
the mouse-gesture widget to quickly invoke commonly used commands while using 
DraftSight. To customize the mouse-gesture widget; click Tools>Mouse Gestures from the 
Pull-Down Menu.

Two-Button Mouse

Microsoft IntelliMouse®

Button Action

Left Mouse Button Use to pick entities or options.

Right Mouse Button Use <Enter> to complete the command, repeat the last command 
or access a context-sensitive menu. 

Right Mouse Button 
(press + drag)

Accesses the mouse gesture widget.

Shift + Right Mouse 
Button

Brings up the EntitySnap menu.

Button Action

Left Mouse Button Use to pick entities or options.

Right Mouse Button Use <Enter> to complete the command, repeat the last command, 
access a context-sensitive menu, or access the mouse-gesture 
widget.

Right Mouse Button 
(press + drag)

Accesses the mouse-gesture widget.

Shift + Right Mouse 
Button

Brings up the EntitySnap menu.

Middle Button (press + 
drag)

Use to pan the drawing.

Middle Button (roll) Use to zoom the drawing.
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General Procedure

1 Pick an icon from a toolbar using the left mouse button on the mouse.
2 Follow the command prompts.
3 Press <Enter> to complete the command or to continue to the next step. Press <Enter> 

again to repeat the command, or select a choice from the shortcut menu.

･ Clicking in a blank area of the graphics window will create a selection window. 
Press Esc to cancel this selection window, or simply make the other corner.

･ Making a selection window from right to left will select all entities the window 
crosses. Making a selection window from left to right will only select the 
entities that are completely within the selection window.

･ Picking entities in the graphics window when the command line is blank will 
highlight the entities and display the EntityGrips.  Press Esc to cancel this 
selection.

･ The left and right buttons can be reversed from the Windows Setting Menu 
(from the Start Menu). Select Control Panel, then select Printers and Other 
Hardware, then choose Mouse.
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Command Exercise ­ Pointing Device
Estimated time to completion: 5 minutes

Drawing Name: None (start from scratch)

Scope:

Practice left and right mouse button functions.
1 Draw line segments.
2 Press the right mouse button on the mouse to repeat the command.
3 Press ESC to exit the command.
4 Practice selecting a single entity.
5 Practice making a selection window.
6 Activate the EntitySnap menu.
7 Activate the Toolbar shortcut menu
8 Activate the command line shortcut menu.

Solution:

1 Click the Line icon on the Draw toolbar and draw some line segments.  Click the right 
mouse button.  This will bring up the Context menu.  Select Enter to complete the Line 
command. The command line is now blank.

2 Press the right mouse button on the mouse again.  This will bring up the Context menu.  
Select Repeat LINE option.  Complete the Line command so the command line is blank.

3 Click one of the line segments.  Notice that it becomes highlighted and the EntityGrips 
are active (the blue boxes on the line).  Press Esc to cancel and clear the EntityGrips.

4 Click a blank area in the graphics window.  Notice this will create a rectangular selection 
window.  You will be prompted to select the other corner.  Making the selection window 
from left to right results in only entities completely within the window being selected.  
Press Esc to cancel this selection.  Now, make the window from right to left. The entities 
that are crossed by the selection box are now highlighted.  Press Esc again to exit.

5 Activate the EntitySnap shortcut menu using the mouse function according to your 
pointing device. Press Esc to cancel.

6 Press the right mouse button in the command window to view this menu.  Press Esc to 
cancel.
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DraftSight Window

Overview
The DraftSight window consists of a Title Bar, Pull-Down Menus, Toolbars, a Graphics 
Window, the Command Line and the Status Bar.

DraftSight
W i n d o w
Detail

Location Function Overview

Title Bar

Top Lists the name of the current drawing.
Contains buttons to minimize, maximize or exit 
DraftSight.
Contains buttons to minimize, maximize or close the 
current drawing.

Pull-Down 
Menu

Beneath the Title Bar Lists DraftSight commands by category.
Words followed by a black arrow will display an 
additional list of related options.
Words followed by an ellipsis (...) will open a dialog 
box.

Toolbars

Docked at sides or 
floating in the 
graphics area

Displays commands as icons (buttons) in related 
toolbar categories.
The toolbar pictured in the top row is the Standard 
Toolbar.
The toolbar beneath it is the Object Properties toolbar.
Accessing a command from a toolbar is usually a faster, 
more direct approach.
The toolbars contain most of the commands, but not all 
of them.

Graphics 
Window

Middle area Area where the drawing is created.
The Model tab is for creating the drawing.
The Sheet tabs are for creating the finished layout for 
printing.

Command 
Line

Bottom Area where DraftSight prompts the user for the next 
step.
The user must press <Enter> after typing the 
command or command line options.
The Esc key will cancel any command, leaving the 
command line blank and ready for the next command.

Status Bar
Beneath the 
Command Line

Displays the coordinates of the cursor location.
Displays the O/Off status of special toggle switches.
Single-click to toggle these options On or Off.
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Title Bar

Command Access

Command Overview
The Title Bar will display the name of the drawing. Buttons are displayed in the upper 
right corner to minimize, maximize, resize or close the DraftSight window or an 
individual drawing file. Remember that when any program is minimized, it will remain 
listed in the Windows Start bar.

General Procedure
1 To maximize the DraftSight window, select the following icon.
2 To maximize the graphics window, select the following icon.
3 To minimize the DraftSight window, select the following icon.
4 To minimize the Drawing window, select the following icon.
5 To bring the DraftSight window back to active, select the following icon.

･ Keep the DraftSight and graphics window maximized for optimum drawing 
space.

･ Use the ALT+Tab keys to alternate between programs, or select the program 
from the Windows Start bar.

･ Practice minimizing and maximizing the DraftSight and Drawing windows.
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Pull­Down Menu

Command Access

Command Overview 
The pull-down menu is one way to access commands and command options. This menu 
appears at the top of the DraftSight window, beneath the Title Bar. The commands are 
arranged into categories similar to most Windows programs. Select the category name 
to view the options.

General Procedure

1 Select the heading of the desired pull-down menu category.
2 Select the desired option from the list.

 Words followed by a black arrow will display an additional list of related commands.
 Words followed by an ellipsis (...) will open a dialog box.

Pull-Down
M e n u
Heading

Overview

File Contains commands to manage the drawing files (Open, Save, Close, Export), 
print files, clean and recover files.

Edit Contains the Windows Cut, Copy and Paste commands as well as Undo and 
Redo.

View Contains commands that have to do with viewing a drawing.

Insert Contains commands that permit the insertion of graphic data, such as blocks 
and reference drawings.

Format List options that pertain to the drawing format, including units, drawing limits, 
layers, LineStyle and LineWeights.

Dimension Dimension commands can be accessed from the pull-down menu.

Draw Draw commands can be accessed from the pull-down menu.

Modify Make changes to the objects in the drawing with options found in the pull-down 
menu

Tools Tools in this Pull-Down menu include Properties and Options.

Window Manage multiple drawing documents in the pull-down menu.

Help DraftSight on-line help can be accessed from this menu.
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Toolbars

Command Access

Command Overview

Selecting a toolbar button icon is generally a faster and more efficient way to initiate a 
command. Toolbars can be floating or docked. 
The default toolbars are Standard, Properties, Layers, Draw and Modify.

General Procedure
To open or close a toolbar using the shortcut menu:

1 RightcClick on any toolbar and select Toolbars from the shortcut menu.
2 Select the desired toolbar from the list.
3 Click OK.

To open or close a toolbar from the command prompt:
1 Type toolbar at the command prompt and press the <Enter> key.
2 Click the desired toolbar from the list.
3 Click OK.

To dock or undock a toolbar:
1 To undock a toolbar, move your cursor to the beginning of the toolbar (where there is a 

series of dots) and look for the cursor display to change to four arrows.  Click and hold 
the button.  Drag the toolbar to a new location and release.

2 To dock the toolbar, drag it to a new location and look for it to snap into a new location.  
When you have found the proper spot, release.

Toolbar Menu
Pull-Down Menu
Command Toolbars (right mouse click on any visible toolbar, select Toolbars...)
Alias TBCONFIG
Dialog Box Specify Toolbars

･Selecting a toolbar button or icon is generally a faster and morthe efficient way 
to initiate a command.

･ When you point to a toolbar button, a label will appear with the command 
name, and a tooltip will appear at the bottom of the screen.

･ The Standard Toolbar is normally docked at the top, and the Object Properties 
and Layers toolbar beneath it.
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Graphics Window

Command Access

Command Overview

When working in the graphics window, be sure that the Model tab is selected. Later this 
tutorial will cover how to create a drawing layout. The cursor must be in the graphics 
window in order to pick points for drawing entities, or select entities to modify. Right-
click in the graphics window to execute a command, proceed with the next step of the 
command line, of if the command line is blank, repeat the last command. Clicking in a 
blank area of the graphics window will initiate a selection window or box. You must pick 
the opposite corner whether you want to select an entity or not, or press Esc to cancel 
the window selection. Multiple drawings may be opened in one DraftSight session. 
Minimize a graphics window, or use the options from the Window pull-down menu to 
select the current drawing. Close drawings that are not being used.
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General Procedure
To minimize, maximize, resize or close a graphics window:

1 Click this button to minimize the graphics window 
2 Click this button to maximize the graphics window 
3 Click this button to resize the graphics window 
4 Click this button to close a drawing 

･ The Model tab should be selected when creating a drawing.
･ The cursor must be in the graphics window in order to pick points for drawing 
entities, or selecting entities to modify.

･ Right-click in the graphics window to execute a command, proceed with the 
next step of the command, or if the command line is blank, repeat the last 
command.

･ Picking in a blank area of the drawing window will initiate a selection window 
or box.  You must pick the opposite corner whether you want to select an entity 
or not, or press Esc to cancel the selection window.

･ Close drawings that are not being used.
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Command Line

Command Access

Command Overview 
The command line at the bottom of the DraftSight window will prompt the user for the 
next step. It is important to read the command line. A blank command line means that 
DraftSight is waiting for the user to begin a command. Remember to press <Enter>, 
after typing a command, a command alias, a command line option, or after selecting 
entities. Generally it is best to view three lines of text at the command line. The scroll bar 
to the right of the command line window can be used to view previous command lines. 
The F2 function key will display the entire text window. The up and down arrows on the 
keyboard will carry the last option typed to the bottom command line. If a default value 
is shown, it is not necessary to type that number in the command line. To accept the 
default value, just press <Enter>.

General Procedure
How to follow the command line prompts:

1 Type the command, the command alias, or the command line option and press <Enter>.
2 Follow the command line prompts:

 When prompted to select entities, pick the entities and then press <Enter> to 
continue.

 When presented with command line options, type the underlined characters of the 
option and press <Enter> to continue.

 When presented with a default choice, press <Enter> to accept the default, or type 
the preferred options and press <Enter>.

･ It is important to remember to read the command line, as this is your line of 
communication with DraftSight.

･ Use the keyboard <Enter> key or the right mouse button on the mouse.
･ When using the right mouse button, be sure that the cursor is in the Graphics 
window.

･ To disable the command options cursor menu, select Tools>Option>User 
Preferences>Mouse Options>Options and make sure you uncheck Display 
shortcut menu by right-clicking.
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Status Bar

Command Access

Command Overview
The Status Bar is at the bottom of the DraftSight window. Select the buttons to turn the 
options On or Off. Right-click to access the settings dialog box for the corresponding 
Status Bar options, or other options that apply.

S t a t u s B a r
Option

Overview Function Key

Tool Tip 
Display

Displays a Tool Tip, and the Command name when the 
pointing device 'hovers' over an icon.

Snap Snap On will restrict the cursor to select points at 
designated X and Y increments. Snap spacing may or may 
not be equal to the Grid spacing. However, if the Grid 
spacing is set to equal 0, it will equal the Snap spacing.

F9

Grid This switch turns the Grid On and Off. The Grid is a visual 
tool, and does not restrict cursor selection. Grid spacing 
may or may not be equal to Snap spacing. However, if the 
Grid spacing is set to equal 0, it will equal the Snap spacing.

F7

Ortho Use Ortho (for orthogonal) On when dragging the mouse 
to:
Draw straight lines.
Move, copy or mirror entities along a linear plane.
Rotate entities in 90-degree increments.
Ortho is either On or Off and does not have a settings 
option.

F8

Polar Turns Polar Snap On and Off. When Polar Snap is On, the 
angular direction and distance from the last point selected 
will be tracked and displayed according to the Polar 
tracking settings.

F10

ESnap When EntitySnap is On, the cursor will always gravitate to 
specified points on an entity in the drawing. Unlike Snap, 
which follows a grid pattern, ESnap refers to an entity in 
the drawing and will display EntitySnap markers.

F3
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General Procedure

1 Select the Status Bar option to turn it On or Off.
2 Right mouse click on a Status Bar option to access the corresponding settings dialog box.

ETrack Entity Tracking, when On, will combine with ESnap (Which 
also must be On) to allow the cursor to track along 
alignment paths based on the other EntitySnap points in 
the drawing. To use entity tracking, you must turn on one 
or more EntitySnaps.

F11

Coordinates 
Display

Displays the x, y, z, coordinates of the cursor location. The 
options are Relative, Absolute and Off. The Absolute option 
is the default, and the Relative option will only display 
when a command is initiated and a point is selected.

S t a t u s B a r
Option

Overview Function Key

･ Select either the Status Bar button, or select the corresponding function key 
from the keyboard.

･ A Status Bar option can be turned On or Off while using a Draw or Modify 
command.  Therefore, beginning a Line command, and deciding to turn Ortho 
On or Off while in the middle of the command is acceptable.
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Shortcut Menus

Command Access
Right mouse click to access a Shortcut menu.

Command Overview
DraftSight, like most Windows programs, has numerous shortcut menus which are 
initiated by selecting the <Enter> button (RMB) on the mouse. The specific shortcut 
menu that will appear depends on where the cursor is in relation to the DraftSight 
screen, and what command has been initiated.

General Procedure
1 Place the cursor over a specific part of the DraftSight window, or button.
2 Right-click to access the corresponding shortcut menu.
3 Select a Shortcut menu option.

･This tutorial will cover the details of the Shortcut menus within the appropriate 
chapter topic.

･Press the Esc key to cancel a Shortcut menu, or select Cancel, or press <Enter> 
from the menu when that option appears in the menu.

･ To disable the command options cursor menu, select Tools>Option>User 
Preferences>Mouse Options>Options and make sure you uncheck Display 
shortcut menu by right clicking.
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Dialog Boxes

Command Access

Command Overview
Certain commands and options will launch dialog boxes. Commands from the pull-down 
menus followed by an ellipsis (...) will open a dialog box. When opened, it is not possible 
to type at the command line, or use any of the commands other than those listed in the 
dialog box. Use the text boxes to type information, select the appropriate tab, buttons or 
check boxes, and select OK to exit. It is also possible to press the Esc key, select the 
cancel button or the X (close icon) in the upper right-hand corner of the dialog box.

General Procedure
1 When a dialog box is open, select or typed the desired options.
2 Click OK to exit the dialog box.

Toolbar Menu Certain command buttons will activate a dialog box
Pull-Down Menu Commands or options followed by an ellipsis (...) will open a dialog box.
Command Certain typed commands will activate a dialog box.
Alias Certain commands and aliases will activate a dialog box.
Dialog Box The name or title will be listed at the top of the dialog box.

･ To move the dialog box, select the Title Bar, press and drag.
･ To type over text in the text areas, click and drag the cursor over selected text, 
or double-click to select the entire text and then type over it.

･ Select the Help button in the dialog box for more information.
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Keyboard Options

Command Overview
Commands, command aliases, or system variables can be typed at the keyboard. It is 
important to remember to press <Enter> to execute the command, and follow the 
command line prompts. When choosing a command line option, type the Underlined 
character(s) of the desired option. Pressing <Enter> or the spacebar will execute the 
command. When typing text, however, the <Enter> key is the same as a carriage return 
on a typewriter, and a spacebar will type a space. Function keys are used to toggle some 
option On and Off.

General Procedure
Type the command, command alias, or system variable at the command line.
Press <Enter> to execute the command, or follow the command line prompts.

Keyboard
Option

Overview

Esc Escape. Cancels all commands.

Enter Executes a command.

Spacebar Works like the <Enter> key except when typing in the text editor.

Arrows Moves the cursor position. In the case of the command line, arrow keys will 
bring back previously typed information to the last command line.

Ctrl Use the Control + single keys to begin selected commands as indicated in the 
pull-down menus (i.e. Ctrl + S, will Save).

･Remember to press the <Enter> key after typing a command, a command alias, 
or a system variable.

･ Commands, aliases, or system variables are not case sensitive.
･ A default is the most common or last option selected and will be shown above 
the command prompt.  Press <Enter> to accept the default.  It is not necessary 
to type the default over again.

･ When in doubt about a command location, type it (and remember to press 
<Enter>).  This will usually begin the desired command.

･ System variable settings will be covered in the tutorial at the appropriate topic.
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Help Menu

Command Access

Command Overview
DraftSight Help can be invoked at any time. If the command line is blank, the Help menu 
will open at one of the options, depending on which option was selected the last time 
Help was used. If Helps invoked while in the middle of a command, the Help menu will 
open to the page covering that command. There are four tabs to the Help menu: 
Contents, Index, Find and Favorites. This Help menu follows a format typical among 
Windows programs.

General Procedure
To access Help when in the middle of a command:

1 Select the F1 function key.

To use the Help Contents tab:
1 Click the Help Contents tab.
2 Open a topic by double-clicking on it, or single clicking and selecting Open.

To use the Help menu Index tab:
1 Click the Help Index tab.
2 Begin to type the word.
3 Double-click the index entry or single-click and select Open.

To use the Help menu Find tab:
1 Click the Help Find tab.
2 Begin to type the word.
3 Double-click the index entry or single click and select Open.

Toolbar Menu
Pull-Down Menu Help>Help
Command Help
Alias
Dialog Box ? DraftSight

･ Press the F1 function key while in the middle of a command to open the Help 
menu pertaining to that command.
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Section 1 Review Questions

1 Which is the Pick button and which is the <Enter> key on the mouse?

2 Name the areas of the DraftSight screen:

3 How do you move a floating toolbar?

4 How do you dock a floating toolbar?

5 How do you make a docked toolbar float again?

6 What happens if you press the <Enter> button on the mouse when the cursor is:
Over a toolbar?

Over the command line?

7 What does the Escape key do?

8 How can a dialog box be closed?
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Section 2
Creating a Simple Drawing

Estimated Class Time: 2 hours

Objectives
This section introduces DraftSight commands for creating a simple drawing. Starting 
with a new drawing, the user will learn to draw Lines, Rectangles, Circles and Arcs, 
Delete and use Object Snaps.
 New
Use the New command to begin a new drawing from scratch.
 Line
Draw line segments.
 Delete
Delete selected objects in the drawing.
 Rectangle
Draw rectangular polylines.
 Circle
Draw circles using six different methods.
 Undo and Redo
Undo previous commands and redo the undo.
 Drafting Settings
Specify drafting settings to use as drawing aids.
 Object Snap
Select specific parts of draw objects.
 Arc
Draw arcs several different ways.
 Polygon
Draw multi sided polylines.
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New

Command Access

 Command Overview

To create a new drawing, choose the appropriate template from the Specify Template 
dialog box and select Open. Every time a the new drawing command is invoked, a new 
drawing is created with the title NONAME_1.dwg, NONAME_2.dwg, etc.

General Procedure

1 Click the New icon  on the Standard Toolbar.
2 Choose the appropriate template from the list.
3 Click Open.

Toolbar Menu Standard>New
Pull-Down Menu File>New

Command New

Alias Ctrl+N

Dialog Box Specify Template
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Line

Command Access

 Command Overview

A line is defined by two endpoints. A line has 0 Width and 0 Thickness. When drawing a 
line, specify the first point, then specify the next point. Press the right mouse button with 
the cursor in the graphics window to access the Line shortcut menu. Type C to close two 
or more line segments.

General Procedure

1 Click the Line icon  on the Draw toolbar, or by typing L at the blank command 
prompt.

2 Select the first point, select the next point, and continue selecting the endpoints of each 
successive line segment.

3 Click the RMB with the cursor in the graphics window to access the context specific 
menu.

4 Press  to end the Line command.
5 Press  after ending the Line command to repeat the Line command.

Toolbar Menu Draw / Line
Pull-Down Menu Draw>Line

Command Line

Alias L

Dialog Box

･ Move the mouse after selecting each endpoint of the line.  This will make it 
easier to see the last line segment created.

･ Click on Ortho on the Status bar, or press the F8 key to alternate between 
drawing straight or angled line segments.

･ Typing U in the middle of the Line command will undo the last line segment. 
Typing U after completing the line segments (at a blank command prompt), will 
UNDO the entire line operation.
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Line Shortcut
Menu Option

Overview

Enter Select to exit the Line command.

Cancel Cancels the command.

ESnap 
Override

Allows you to force the next point to a specified ESnap location.

Pan Begins real-time pan.

Zoom Begins real-time zoom.

Segments Creates line segments (no rubberbanding between lines.)

Undo Undoes the last segment of the line.
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Command Exercise ­ Line
Estimated time to completion: 10 minutes.

Drawing Name: None (start from scratch)

Scope:

With ORTHO On, draw the object below. Drag the line in the desired direction and type 
the distance. DO NOT ADD THE DIMENSIONS.

･ If your lines look crooked, then ORTHO is not on, and you must begin again. 
･ Try to draw the entire object without starting or stopping the line segment.
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Command Exercise ­ Line
Estimated time to completion: 5 minutes

Drawing Name: line 2.dwg

Scope:

Open line 2.dwg and draw the object shown by adding the missing lines and turning 
ORTHO Off. When you are finished, press <Enter> (with a blank command line to 
repeat the Line command). Press <Enter> again to see that the new segment will start 
from the end of the last segment drawn.

･ After completing the first line segment, you must end the Line command by 
pressing <Enter> and repeat the Line command to draw the second line 
segment.
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Delete Command 

Command Access

Command Overview
Delete removes selected entities. Press <Enter> after selecting the objects to delete to 
execute the command. Type UNDELETE to bring back the last set of deleted entities, even 
if other entities were created since the last delete.

General Procedure

1 Select the Delete icon  on the Modify toolbar, or type DEL at the command prompt.
2 Select the entities to remove.
3 Press the <Enter> key.

Toolbar Menu Modify / Delete
Pull-Down Menu Modify>Delete

Command Delete

Alias Del

Dialog Box

･ If the cursor is not on an entity when you select it, the selection window will 
appear.  Mark the opposite corner of the selection window to make the 
selection.

･ A selection window made from the left to the right will select only the objects 
completely in the window.

･ A selection window made from the right to the left will select all entities that 
the window crosses.

･ Typing All (and pressing <Enter>) will select all of the objects in the drawing 
to delete.  Press <Enter> again to execute the command.

･ With a blank command prompt you can select the entities you wish to delete 
(the EntityGrips will display) and pressing the Delete key on the keyboard will 
also delete your entities.
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Command Exercise ­ Delete
Estimated time to completion: 5 minutes

Drawing Name: delete1.dwg

Scope:

Delete the entities in the drawing. Draw more lines. Type UNDELETE to bring back the 
last set of erased entities.

･Select all of the entities to delete, then press <Enter> to execute the command. 
To remove an entity from the selection set, hold down the Shift key and select 
the entity. The entity will be removed from the selection set.
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Command Exercise ­ Delete
Estimated time to completion: 5 minutes.

Drawing Name: Delete 2.dwg

Scope:

Delete the entities in the drawing. Draw more lines. Type UNDELETE to bring back the 
last set of erased entities.

･ Be sure to turn SNAP Off in order to select the entities.
･ The UNDELETE command will bring back the last set of deleted entities.  Undo 
and Redo can also be used.
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Rectangle

Command Access

Command Overview
Rectangles are polylines. All of the line segments are connected. Draw rectangles by 
specifying opposite corners.

General Procedure
Draw rectangles by picking opposite corners:

1 Click the rectangle icon on the Draw toolbar.
2 Pick the first corner.
3 Drag the mouse and pick the opposite corner.

To draw rectangles using coordinates:

1 Click the rectangle icon on the Draw toolbar
2 Select a start position.
3 Specify the relative coordinates of the rectangle.  Type the @ symbol followed by 

the x value and y value separated by a comma (@20,30).

Toolbar Menu Draw / Rectangle
Pull-Down Menu Draw>Rectangle

Command Line Rectangle

Alias REC

Dialog Box

･ Use the Rectangle command rather than drawing four separate line segments.  
This is quicker and more efficient since a rectangle is a polyline.
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Command Exercise ­ Rectangle
Estimated time to completion: 5 minutes.

Drawing Name: None (start from scratch)

Scope:

Draw rectangles as they are shown in this example. DO NOT INCLUDE DIMENSIONS. 
(Note the inner rectangles are random sizes).

You can toggle Snap On and Off during the command.  Try it.
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Circle

Command Access

Command Overview
There are several ways to draw a Circle. The most common way is to pick the center 
point, then designate a radius. Right-click to view the shortcut menu for options. If a 
center point is selected first, the Short cut menu option for Circle is Diameter. If no 
center point is selected, the Short-cut menu will display other options.

General Procedure

1 Click the Circle icon on the Draw toolbar.
2 Pick a center point.
3 Type the radius or type D to specify a diameter.

Toolbar Menu Draw / Circle
Pull-Down Menu Draw>Circle>Options

Command Circle

Alias C

Dialog Box

Circle Options Overview

Radius / 
Diameter

If a center point is selected, type or pick the radius.  Right-click to select 
the Diameter option or type D and <Enter>.

3P Draws a circle by selecting three points on the circumference of circle.

2P Draws a circle by selecting two points to define a diameter.

TTR Draws a circle by selecting two tangent entities and a specified radius.

Tan, Tan, Tan Draws a circle by selecting three tangent entities.

･ To make a circle the same size as the previous circle, press <Enter> to accept 
the default value for the radius.

･ When selecting a circle entity to delete, you must select the circumference.
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Command Exercise ­ Circle
Estimated time to completion: 10 minutes

Drawing Name: circle 1.dwg

Scope:

Draw the large circle using the TTT option. The three inner circles are random size. Use 
the center point function to create the 80 mm diameter circle using the Diameter option 
of the Circle command.

･ DraftSight remembers the value of the radius for the last circle drawn.  If you 
start the Circle command by typing Circle, you can enter the radius by default.

･ If you want to specify the diameter, you need to use the D option and press 
<Enter> after you have selected the center of the circle.
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Drafting Settings

Command Access

Command Overview
The following options are covered in the Drafting Settings:
 Snap and Grid
 Polar Tracking
 ESnap Settings
 ETracking
Click the icon on the Status Bar to turn these functions On and Off. Use the Right Mouse 
button on top of the icon to change the setting.

Snap

When Snap is On, selecting points in the drawing window will be restricted to the snap 
increments. Typically the X and Y spacing is the same, and the snap angle is 0.

Grid

The Grid is a lattice-point pattern that is visual in the file. The grid is not printed.

General Procedure

1 Open the User Preferences tab in the Options dialog box and expand Drafting Options.
2 Under Pointer Control expand the Snap Settings options and set the Snap Spacing.
3 Under Display expand Grid Settings and set the Grid Options.

Toolbar Menu

Pull-Down Menu Tools>Options>User Preferences>Drafting Options>...

Command Options

Alias OP

Dialog Box Options - User Preferences

･ Working with Snap On is handy when laying out a drawing, drawing a title 
block or creating a table, such as a bill of materials.

･ Working with Snap On is not handy in most other instances.
･ It is more convenient to use toggle switches on the Status Bar to turn Snap and 
Grid On or Off rather than from the dialog box.

･ The function key for Grid is F7 and for Snap is F9.
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Polar Snap

Polar Snap works independently from Snap. With Polar Snap turned On, incremental 
angle will be displayed as the line being dragged approaches that angle. Set the 
incremental angle in the User Preferences tab of the Options dialog box.

General Procedure
1 Right-click on Polar in the Status Bar and select Settings to open the User Preference tab 

of the Options dialog box, with Drafting Options>Display>Polar Guides expanded.
2 Choose the desired Incremental Angle for Polar display from the drop-down box, or 

specify a value that is not listed in the Display Polar Guides at specific angle(s) option.
3 Enable Polar guides and Display Polar guides should be selected.
4 Use the Line command, pick the first point, and then drag the line to see the Polar Guide 

displayed.

Object Snap

When Object Snap mode is selected, and a (Draw or Modify) command has been 
invoked, the Esnap will be displayed as the cursor moves over an entity. The cursor will 
want to snap to that point. If the cursor is held over that snap point, the label will display 
the snap mode. Once the cursor is moved away from that point, the Entity Snap will no 
longer be displayed or selected. Toggle the ESnap settings On or Off from the Status Bar.

General Procedure
1 Right-click on the ESnap button from the Status Bar and select Settings... to open the 

User Preferences tab of the Options dialog box and expand the Pointer 
Control>EntitySnaps section.

2 Choose the desired EntitySnap Settings.
3 Click OK from the dialog box.

･With the desired polar angle displayed, type the length of the line and press the 
<Enter> key.

･ ESnap settings, when selected, will remain consistant, or running, if ESnap is 
On.  Entity Snap options can be selected individually using the EntitySnap 
toolbar, or by using the Shift+Right Mouse Button Shortcut menu.

･ Do not check all of the EntitySnap modes in the dialog box.  This will make 
selecting entities tedious and no longer a handy tool. 

･ When no EntitySnap modes have been selected (clear all), clicking the ESnap 
button on the Status bar will open the EntitySnaps settings dialog box.
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Entity Track

Entity Tracking will display orthogonal (horizontal and vertical) tracking guides when 
the cursor moves over an Entity Snap point (ESnap must be enabled).

General Procedure
1 Right-click on the ETrack button from the Status Bar and select Settings... to open the 

User Preferences tab of the Options dialog box and expand Drafting 
Options>Display>ETrack.

2 Choose Display ETrack across Screen and Enable Shift to acquire reference points.
3 Select OK from the dialog box.

･ Use ETracking for quick geometry construction using ESnap points.
･ Be sure to verify the dimensions used with this method.
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Command Exercise ­ Entity Tracking
Estimated time to completion: 15 minutes

Drawing Name: None (start from scratch)

Scope:

Set up ESnap points. Set Polar Guides to 45 degrees and turn ETrack On. Create the 
shape below. DO NOT ADD DIMENSIONS.

･ Use the right side of the top 60 mm horizontal line as the start point.
･ Use the C option of the Line command to finish the outline shape.
･ Using ETrack, the center of the left circle is the midpoint of the 60 mm 
horizontal line and the midpoint of the 125 mm vertical line.

･ Using ETrack, the center of the right circle is the midpoint of the 65 mm 
horizontal line and the midpoint of the 90 mm diagonal line.

･ Hold the Shift key down and move the cursor over the ETrack points to wake 
up the points that you wish to use for the construction of the circle.



Creating a Simple Drawing DraftSight

40 Drafting Settings

Command Exercise ­ Entity Snap
Estimated time to completion: 10 minutes

Drawing Name: esnap 1.dwg

Scope:

Set ESnap points for End Point, Quadrant Point, Intersection Point and Mid Point. Using 
the geometry in the file, construct the following drawing. For the circles in the corners, 
use a diameter of 20.

･ The Entity Snap symbols help to indicate where the selection point will be 
placed. 

･ Try creating this with ESnap Off and use the Shift+Right Mouse Button option.
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Command Exercise ­ Entity Snap
Estimated time to completion: 5 minutes

Drawing Name: esnap 2.dwg

Scope:

Using the current ESnap settings, open the file and complete the geometry. Be sure to 
use the Shift+Right Mouse Button in order to complete the exercise.

･ When selecting a center point, be sure to select the circumference of the circle.
･ Make sure to observe the ESnap cue when using the Tangent Point option to 
ensure that you choose the proper point.
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Command Exercise ­ Entity Snap
Estimated time for completion: 5 minutes.

Drawing Name: esnap 3.dwg

Scope:

Using the current ESnap settings, open the file and complete the geometry. Be sure to 
use the Shift+Right Mouse Button option (Use Intersection) in order to complete the 
exercise.

･ To use the Intersection option, after selecting the Circle icon , choose 
Shift+Right Mouse Button and select Intersection.  Select the first line, and 
then select the second line.  This will start your circle at the point where the 
two lines would intersect if the extended.
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Arc

Command Access

Command Overview
Though there are many Arc options available, we will look at the following Arc options: 3 
Points, Start, Center, End and Start, Radius, End. These Arc options will work in most 
instances.

Click the Arc icon  on the Draw toolbar or by typing Arc at the command line. This 
will draw a three-point arc through three consecutive points. Other Arc options can be 
selected through the pull-down menu. Arcs are constructed in a counter clockwise 
direction, except when constructing a three-point arc.

General Procedure

1 Select the Arc icon  on the Draw toolbar to draw a three-point arc or select one of the 
options from the Draw pull-down menu.

2 Follow the command prompts.
3 Use the right mouse button with the cursor in the graphics area to repeat the Arc 

command.

Toolbar Menu Draw / Arc
Pull-Down Menu Draw>Arc>Options...

Command Arc

Alias A

Dialog Box

･Arcs are constructed in a counter clockwise direction, except when drawing a 
three-point arc.

･ Pressing the right mouse button will repeat the Arc command, but instead of 
the same command, it will be the generic three-point arc.
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Command Exercise ­ Arc
Estimated time to completion: 10 minutes

Drawing Name: arc 1.dwg

Scope:

Draw the object shown using the appropriate Arc and Entity Snap options.

･ Notice how the arcs were created in a counter clockwise direction.  What 
happens if they are created in a clockwise fashion? Try it.
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Undo and Redo

Command Access

Command Overview

Type U or select the Undo icon  on the Standard Toolbar. This feature will reverse the 
previous command. You can use undo to remove all of the actions performed in the 
current drawing file from the time it was opened.

General Procedure

1 Select the Undo icon , or type U and  at the command prompt.
2 Press  to repeat the Undo command until satisfied.

Toolbar Menu Standard / Undo - Standard / Redo
Pull-Down Menu Edit>Undo - Edit>Redo

Command Undo - Redo

Alias U (none for Redo)

Dialog Box

Be careful not to press  too many times.
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Command Exercise ­ Undo / Redo
Estimated time to completion: 5 minutes

Drawing Name: None (start from scratch)

Scope:

Draw several Lines, Circles and Rectangles. Undo your drawing several steps back. Use 
the Redo command and try to redo several steps. 
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Polygon 

Command Access

Command Overview
Polygons are polylines with equal line segments. First determine the number of sides for 
the polygon, and then select a center point. A polygon may be constructed with either 
the Corner or Side option. Typing or selecting the radius will determine the size of the 
polygon. If you choose the Corner option, the polygon will fit inside the specified radius. 
If you choose the Side option, the specified radius will fit inside the polygon. It is also 
possible to construct a polygon with a given Side Length.

General Procedure

1 Select the Polygon icon  on the Draw toolbar.  
2 Type the number of sides and press .
3 Select the center point of the polygon.
4 Determine whether to use the Corner or Side option.
5 Specify the radius.

Toolbar Menu Draw / Polygon
Pull-Down Menu Draw>Polygon

Command Polygon

Alias PGON

Dialog Box

･ After specifying the number of sides to the polygon, type S for Side Length, to 
specify the length and direction of the polygon's edge.

･ There is no Polygon Center Entity Snap point. Use ETrack, or create 
construction lines to locate the center of a polygon one it has been created.
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Command Exercise ­ Polygon
Estimated time to completion: 5 minutes

Drawing Name: None (start from scratch)

Scope:

Practice the options for drawing a polygon:
1 Draw a six-sided polygon making the overall radius 50, using the Side option.
2 Draw a six-sided polygon making the overall radius 50, using the Corner option.
3 Draw a six-sided polygon using the Side length option, with a length of 25.  Notice that 

the angle of the polygon is determined by the cursor as it is dragged from the first pick 
point.
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Drawing Setup

Command Overview
Creating Lines, Circles and Arcs is only one feature of the drawing in DraftSight. This 
tutorial will cover other topics related to the drawing setup. The following steps can be 
used as a guide for beginning a drawing. Once the settings have been established, the 
drawing can be used as a template for other drawings.

General Procedure

1 Begin a new drawing.  Select the New icon  on the Standard Toolbar.
2 Choose the appropriate template.
3 Choose the drawing units.  Specify the units and the precision of these units. Set the 

angle of measurement, and the precision of the angles in the Drawing Settings tab of the 
Options dialog box under Unit System.

4 Specify the Drawing Boundary.  Specify how large the drawing area should be based on 
the actual size of the objects being drawn in the Drawing Settings tab of the Options 
dialog under Behavior>Drawing Boundary.  The drawing boundary should always be a 
little bigger then all of the entities.

5 Zoom Bounds. Always perform the Zoom Bounds command after changing the Drawing 
Boundary setting, so the entire work area is visible.

6 Set Snap and Grid spacing.  Set the X and Y spacing for Snap and Grid according to the 
Drawing Boundary.  For larger drawings, space the snap and grid accordingly.  If the grid 
is too dense, it will not display.  When the Grid is On and the spacing is correct, it will 
display within the drawing boundary.

7 Create Layers. Create a system of layers to organize your drawing.  Assign a Name, Color 
and LineStyle to each layer.

8 Specify Line Scale.  This is a global setting that determines the scale of the LineStyles in 
the drawing.  If the drawing is to be printed full scale, then a factor of 1 is appropriate.  If 
the file is to be plotted at 1/10th, then 10 is appropriate.

9 Create Text Styles.   Create a few Text Styles for your drawing.  Each style can be 
assigned a Name, a Font and a predetermined Height.

10 Create Dimension Styles.  Create multiple Dimension Styles based on the Standard Style.  
Choose the arrowhead type, the dimension units, precision and dual dimension style.

11 Save this as a drawing template. Save as (.dwt)
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Section 2 Exercise ­ Standard Bracket
Estimated Time to Completion: 15 Minutes

Drawing name: None (start from scratch)

Scope:

Use the commands you learned in the last section to create the three-view orthographic 
drawing of the bracket in the figure below. Do not worry about the title block, drawing 
dimensions or hidden lines. Try to place the polygon and circle in the middle of the 
upper and lower plates. Remember to use the most efficient commands.

･ Start by setting the Endpoint, Midpoint, Intersection and Quadrant Entity 
Snaps.  Turn ETrack On.

･ Try to use the Line and Rectangle commands to create the overall geometry.  
Try the Polygon command to create the triangle, and the Circle command to 
make the hole.

･ Use the Ortho mode to create the vertical and horizontal lines.
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Section 2 Exercise ­ Simple House
Estimated time to completion: 15 minutes

Drawing name: None (start from scratch)

Scope:

Using the commands learned in this section, draw this simplified house.

Use the Rectangle command for basic shapes.
Use Lines with Midpoint EntitySnaps for the window frames.
Draw extra shapes with the Polygon command and then delete them.
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Section 2 Review Questions
1 Identify the following icons by writing the command and the toolbars where they can be 

found:.

2 Identify the following EntitySnap options.

3 How can you access an EntitySnap option for a single selection (Not ESnap)?

Icon Command Toolbar

a.

b.

c.

d.

e.

f.

g.

h.

Icon Option

a.

b.

c.

d.

e.

f.

g.
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4 What control in the Status Bar turns the EntitySnap On and Off?

5 What does the DraftingOptions command do?

___Invokes the EntitySnap dialog box
___Allows you to adjust the ETrack settings
___Toggles the ESnap command ON and OFF
___Nothing

6 How would you select the exact center of a circle? How would you select the exact 
center of a six or four or three sided polygon?  Try it.
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Section 3
Coordinates

Estimated Class Time: 2 hours

Objectives
DraftSight uses the Cartesian Coordinate System for drawing models. The world 
orientation means positive X progresses to the right and positive Y moves up. 
The user is also looking down the Z axis. The view plane is the same as the work plane. 
Since we will focus only on the two-dimensional capabilities of DraftSight, it will not be 
necessary to use the Z coordinates.
After selecting the Drawing Units, it is good practice to establish the Drawing 
Boundaries, or work area. Adjusting the Drafting Settings will also make it easier to work 
on the drawing.
There are four ways to specify coordinates:
 Absolute Coordinates
 Relative Coordinates
 Polar Coordinates 
 Direct Distance.
Although the Direct Distance method of drawing will be used most of the time, it is 
equally valuable to learn the other methods to input coordinates.
 Coordinate System
The working environment for DraftSight is the Cartesian Coordinate System.
 Units
The user determines the type of drawing units.
 CCS
The Custom Coordinate System icon shows the orientation of the X and Y axis.
 Inquiry
Find the Get Distance, Get Area, Get Coordinates and Properties of selected entities.
 Coordinate Entry
There are several methods for entering coordinates when drawing.
 Snap from EntitySnap
The Snap From option with EntitySnap references a selected point.
 Drawing Boundaries
Drawing Boundaries put a boundary on an otherwise limitless workspace.
 Drawing Boundaries and Scale for Architectural Drawing
Use this handy chart for setting up an architectural drawing in model space.
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Coordinate System

Command Overview
DraftSight uses the Cartesian coordinate system for drawing models. The world 
orientation means positive X progresses to the right and positive Y moves up. 
The user is also looking down the Z axis. The view plane is the same as the work plane. 
Since we will focus only on the two-dimensional capabilities of DraftSight, it will not be 
necessary to use the Z coordinates.

General Procedure
1 Type CCS at the command prompt and press .
2 Press  to accept the default World.

･ Positive X moves from left to right and positive Y moves up.
･ This orientation is sometimes referred to as the right-hand rule.
･ When coordinates are displayed or typed, the X coordinate comes first 
(separated by a comma), then the Y.
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CCS Icon

Command Access

Command Overview

The CCS icon  displays the orientation of the X and Y coordinates of the User 
Coordinate System, or work plane. The icon signifies the default work plane, with an 
origin of 0,0, known as the World. The default location of the CCS icon is at the origin.

General Procedure
1 Select View>Display>CCS Icon from the pull-down menu.
2 There should be a checkmark before On and Origin.

Toolbar Menu CCS
Pull-Down Menu Tools>New CCS

Command CCS

Alias

Dialog Box

･ For all practical purposes, it is best to leave the CCS icon on, but not at the 
origin.

･Keeping the CCS icon not at the origin will keep it in the lower left-hand corner 
and usually out of the way.  It will also be a reminder that the orientation is 
correct.

･ In the event the CCS icon should be changed to something other than World, 
Type CCS and press , then press  to accept the default World.
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Inquiry

Command Access

Command Overview
Information can be obtained by using a specific Inquiry tool.

General Procedure
To obtain a Distance:

1 Click Tools>Inquiry>Get Distance from the pull-down menu.
2 Using Entity Snap, select two specific points in the drawing.

To obtain an Area:
1 Click Tools>Inquiry>Get Area from the pull-down menu.
2 Using Entity Snap, select the points defining the object, or if the object is a closed 

polyline with all of the entities connected, type E for Entity and select the polyline.

To get the Properties of an entity:
3 Click Tools>Inquiry>Get Properties from the pull-down menu.
4 Select the entity for Properties.

To get the coordinates of a selected point:
1 Click Tools>Inquiry>Get Coordinates from the pull-down menu.
2 Using Entity Snap, select the point in the drawing.

Toolbar Menu Inquiry
Pull-Down Menu Tools>Inquiry>Option

Command GetDistance - GetArea - GetProperties - GetXY

Alias

Dialog Box

･ Always use Entity Snap for selecting specific points in the drawing.
･ Converting lines and arcs to closed polylines will make it easier to obtain Area.
･ You can select multiple entities at the same time to obtain the properties.
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Units

Command Access

Command Overview
Set the Drawing Units, the Angle of Measurement, and the Precision in the Units dialog 
box. This setting is saved with the drawing. Changing the units will not affect the 
geometry in the drawing.

General Procedure
1 Click Format>Units System... from the pull-down menu.
2 Select the Type of Drawing Units for Length and Precision.
3 Select the Type of Drawing Units for Angles and Precision.

Toolbar Menu
Pull-Down Menu Format>Unit System...

Command UnitSystem

Alias UNITS

Dialog Box Options - Drawing Settings>Unit System

･ DraftSight is accurate to at least 14 significant decimal places 
(0.00000000000001). Units precision will be rounded up according to the 
specified precision.

･ Angles are typically measured counter-clockwise.  To reverse this, place a 
checkmark before Clockwise.

･ Angle 0 is typically East.  To change this, select the Direction button in the 
dialog box.

･ Drawing Units and Dimension Units are specified separately. (See Dimension 
Style.)
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Coordinate Entry

Command Overview
Once the Units have been established, coordinates can be typed to specify points or 
distances. Always draw full scale. There are four ways to specify coordinates: Absolute, 
Relative, Polar and Direct Distance.

General Procedure
Using Absolute Coordinates:

1 When prompted to specify a point, type the Absolute Coordinates for X and Y (x,y).
2 Type the Absolute Coordinates for each successive point  (x,y).

Using Relative Coordinates:
1 When prompted to specify a point, select a point in the drawing.
2 Type the Relative Coordinate for each successive point (@x,y).

Using Polar Coordinates:
1 When prompted to specify a point, select a point in the drawing.
2 Type the Polar Coordinates for each successive point (@distance<angle).

Using Direct Distance:
1 When prompted to specify a point, select the point in the drawing.
2 Turn Ortho On, and drag the cursor in the desired direction.
3 Type the distance and press 

･ Always use Entity Snap for selecting specific points in the drawing.
･ Remember to separate the X and the Y coordinates with a comma. Example: 
1,5 means the absolute coordinates are x=1, y=5

･ Angles are typically measured counter clockwise.  Angle 0 is typically East.
･ Precede Relative and Polar coordinate information with an @ sign.
･ Ortho should be On when using the Direct Distance method.
･ When drawing lines, or moving objects at specific angles (other than with 
Ortho On), type the polar coordinate (example: @10<45) or use the Polar 
Tracking settings.

･ Typing the minimum number of keystrokes is important for drawing 
efficiency.  DraftSight will fill in leading and trailing zeros and the appropriate 
unit ending.

･ DraftSight will convert decimal equivalents to feet and inches.
･ DraftSight will assume inches unless the foot mark ' is typed.
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Command Exercise ­ Absolute Coordinates
Estimated time to completion: 5 minutes

Drawing Name: None (start from scratch)

Scope:

Using the Line command, draw the object using the Absolute Coordinates.
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Command Exercise ­ Relative Coordinates
Estimated time to completion: 5 minutes

Drawing name: None (start from scratch)

Scope:

Using the Line command, draw the object using Relative Coordinates. Connect the points 
using only keyboard input.
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Command Exercise ­ Polar Coordinates
Estimated time to completion: 5 minutes

Drawing Name: None (start from scratch)

Scope:

Using the Line command, draw the object using the Polar Coordinates. Connect the 
points using only keyboard input.



Coordinates DraftSight

64 Coordinate Entry

Command Exercise ­ Direct Distance Method
Estimated time to completion: 5 minutes

Drawing Name: None (start from scratch)

Scope:

Using the Line command, draw the object using the Direct Distance method. Connect the 
points using onlykeyboard input.
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Snap from Entity Snap

Command Access

Command Overview
Snap From is an Entity Snap option that should be used in combination with another 
Entity Snap. The point selected becomes a reference to the next point that is designated 
by typing a Relative or Polar Coordinate.

General Procedure
1 When prompted to Specify point>>, select Snap from Entity Snap.  Then select another 

Entity Snap (i.e., Endpoint or Midpoint).
2 Type a Relative or Polar Coordinate.

Toolbar Menu
Pull-Down Menu

Command Shift + Right Mouse Button

Alias

Dialog Box

･The Snap From option will eliminate the need to draw extra construction lines.  
Using ESnap and ETrack in combination will eliminate the need to use Snap 
From.

･ Typically two Entity Snap options in a row will cancel both options (i.e., 
DraftSight does not understand the Endpoint of a Midpoint). However, this is 
not the case with Snap From.
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Drawing Boundary

Command Access

Command Overview
The Drawing Bounds command establishes the limits of an otherwise limitless 
workspace. The lower left corner is typically 0,0. The upper right corner of the drawing 
area should be large enough to contain the entire drawing. After changing the Drawing 
Bounds, use Zoom Bounds to see the entire drawing area. The Grid represents the 
Drawing Boundary. If the Grid spacing is too dense, then the boundary will not be visible.

General Procedure
1 Click Format>Drawing Boundary from the pull-down menu.
2 For the lower left corner, type 0,0 or press  to accept the default.
3 At the command prompt, for the upper right corner, press  to accept the default, type 

the x, y value or pick a point in the drawing to establish the x ,y coordinates of the upper 
right corner.

4 Zoom Bounds to view the entire work area.
5 Right-click on Grid in the Status Bar and select Settings.  Set the grid spacing according 

to the drawing area.

Toolbar Menu
Pull-Down Menu Format>Drawing Boundary

Command DrawingBounds

Alias BOUNDS

Dialog Box

･ The Drawing Boundary may be changed at any time, without affecting the 
drawing geometry.

･ Remember to Zoom Bounds after changing the Drawing Boundary to view the 
entire work area.

･ The On option will restrict drawing outside the Drawing Boundary. This is 
typically set to Off.

･ Commands that are affected by the Drawing Boundary are Zoom Bounds, Grid 
and Print>Drawing boundary.

･ If the Grid spacing is set to 0,0, it will be equal to the Snap spacing.
･ Use the following chart as a guideline for setting Drawing Boundary for 
Architectural Drawings.



DraftSight Coordinates

Drawing Boundary 67

Drawing Boundary for Architectural Drawings

When printing a drawing in Model Space, it is a good idea to make the Drawing 
Boundary proportionate to the paper size. Always draw full scale, then plot the drawing 
to scale or use the Sheet Tabs and zoom the drawing views to scale. Use this chart to 
determine the Drawing Boundary when using Architectural Units (English System). For 
instance, a drawing on D size paper or 48 x 36, with a scale of 1/8 inch = 1 foot, has a 
scale factor of 96. To make the drawing boundary proportionate to the paper size, the 
lower left corner should be 0,0 and the upper right corner should be 384',288'.

Paper Size Drawing Scale Scale Factor Drawing Boundary

8 ½ x 11 inch 1/16 inch = 1 ft. 192 0,0/136’,176’

1/8 inch = 1 ft. 96 0,0/68’,88’

3/16 inch = 1 ft. 64 0,0/45’4,58’8

¼ inch = 1 ft. 48 0,0/34’4,44’

3/8 inch = 1 ft. 32 0,0/22’8,29’4

½ inch = 1 ft. 24 0,0/27’,22’

¾ inch = 1 ft. 16 0,0/11’4,14’8

1 inch = 1 ft. 12 0,0/8’6,11’

1 ½ inch = 1 ft. 8 0,0/5’8,7’4

1 inch = 20 ft. 240 0,0/170’,220’

1 inch = 30 ft. 360 0,0/255’,330’

1 inch = 40 ft. 480 0,0/340’,440’

1 inch = 50 ft. 600 0,0/425’,550’

1 inch = 60 ft. 720 0,0/510’,660’

11 x 17 inch 1/16 inch = 1 ft. 192 0,0/ 272’,176’

1/8 inch = 1 ft. 96 0,0/136’,88’

3/16 inch = 1 ft. 64 0,0/90’8,58’8

¼ inch = 1 ft. 48 0,0/68’,44’

3/8 inch = 1 ft. 32 0,0/45’4,29’4

34 x 22 inch 1/16 inch = 1 ft. 192 0,0/544’,352’
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34 x 22 inch 1/8 inch = 1 ft. 96 0,0/272’,176’

3/16 inch = 1 ft. 64 0,0/181’4,117’4

¼ inch = 1 ft. 48 0,0/136’,88’

3/8 inch = 1 ft. 32 0,0/90’8,58’8

½ inch = 1 ft. 24 0,0/68’,44’

¾ inch = 1 ft. 16 0,0/45’4,29’4

1 inch = 1 ft. 12 0,0/34’22’

1 ½ inch = 1 ft. 8 0,0/22’8,14’8

1 inch = 20 ft. 240 0,0/680’,440’

1 inch = 30 ft. 360 0,0/1020’,660’

1 inch = 40 ft. 480 0,0/1360’,880’

1 inch = 50 ft. 600 0,0/1700’,1100’

1 inch = 60 ft. 720 0,0/2040’,1320’

36 x 24 inch 1/16 inch = 1 ft. 192 0,0/576’,384’

1/8 inch = 1 ft. 96 0,0/288’,192’

3/16 inch = 1 ft. 64 0,0/192’,128’

¼ inch = 1 ft. 48 0,0/144’96’

3/8 inch = 1 ft. 32 0,0/96’,64’

½ inch = 1 ft. 24 0,0/72’,48’

¾ inch = 1 ft. 16 0,0/48’,32’

1 inch = 1 ft. 12 0,0/36’,24’

1 ½ inch = 1 ft. 8 0,0/24’,16’

1 inch = 20 ft. 240 0,0/720’,480’

1 inch = 30 ft. 360 0,0/1080’,720’

1 inch = 40 ft. 480 0,0/1440’,960’

36 x 24 inch 1 inch = 50 ft. 600 0,0/1800’,1200’

Paper Size Drawing Scale Scale Factor Drawing Boundary
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1 inch = 60 ft. 720 0,0/2160’,1440’

½ inch = 1 ft. 24 0,0/34’,22’

¾ inch = 1 ft. 16 0,0/22’8,14’8

1 inch = 1 ft. 12 0,0/17’,11’

1 ½ inch = 1 ft. 8 0,0/11’4,7’4

1 inch = 20 ft. 240 0,0/340’,220’

1 inch = 30 ft. 360 0,0/510’,330’

1 inch = 40 ft. 480 0,0/680’,440

1 inch = 50 ft. 600 0,0/850’,550’

1 inch = 60 ft. 720 0,0/1020’,660’

42 x 30 inch 1/16 inch = 1 ft. 192 0,0/642’,480’

1/8 inch = 1 ft. 96 0,0/336’,240’

3/16 inch = 1 ft. 64 0,0/224’,160’

¼ inch = 1 ft. 48 0,0/168’,120’

3/8 inch = 1 ft. 32 0,0/112’,80’

½ inch = 1 ft. 24 0,0/84’,60’

¾ inch = 1 ft. 16 0,0/56’,40’

1 inch = 1 ft. 12 0,0/42’,30’

1 ½ inch = 1 ft. 8 0,0/28’,20’

1 inch = 20 ft. 240 0,0/840’,600’

1 inch = 30 ft. 360 0,0/1260’,900’

1 inch = 40 ft. 480 0,0/1680’,1200’

1 inch = 50 ft. 600 0,0/2100’,1500’

1 inch = 60 ft. 720 0,0/2520’,1800’

48 x 36 inch 1/16 inch = 1 ft. 192 0,0/768’,576’

1/8 inch = 1 ft. 96 0,0/384’,288’

Paper Size Drawing Scale Scale Factor Drawing Boundary
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3/16 inch = 1 ft. 64 0,0/256’,192’

¼ inch = 1 ft. 48 0,0/192’,144’

3/8 inch = 1 ft. 32 0,0/128’,96’

½ inch = 1 ft. 24 0,0/96’,72’

¾ inch = 1 ft. 16 0,0/64’,48’

1 inch = 1 ft. 12 0,0/48’,36’

1 ½ inch = 1 ft. 8 0,0/32’,24’

1 inch = 20 ft. 240 0,0/960’,720’

1 inch = 30 ft. 360 0,0/1440’,1080’

1 inch = 40 ft. 480 0,0/1920’,1440’

1 inch = 50 ft. 600 0,0/2400’,1800’

1 inch = 60 ft. 720 0,0/2880’,2160’

Paper Size Drawing Scale Scale Factor Drawing Boundary
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Command Exercise ­ Drawing Boundary
Estimated time to completion: 5 minutes

Drawing Name: bounds1.dwg

Scope:

Zoom Bounds to view the current Drawing Boundary, then change the Drawing Bounds. 
Use 0,0 for the lower left corner and use 22,17 for the upper right corner. Zoom Bounds 
again. Notice the Grid is displayed in a larger area.
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Section 3 Exercise ­ Base Plate
Estimated time to completion: 15 minutes

Drawing Name: None (start from scratch)

Scope:

Use the commands you have learned in the past section to create the drawing. Use 
dimensions as guidelines (you do not have to add them). Use the Get Distance command 
to make sure the drawing is correct. Try creating the outline with coordinate entry.

･ Start by setting the Snap and Grid to 10.  Set the Drawing Bounds to 420,297.
･ Set the Decimal Units with 0.00 precision.
･ Use the Tracking or Snap From option to locate the circle in the correct area.
･ Use temporary lines or Tracking and the Tangent Entity Snap to create the 
hidden lines that represent the circle in the side view.

･ The drawing shown is drawn in third-angle projection.
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Section 3 Exercise ­ Architectural Coordinates
Estimated time to completion: 20 minutes

Drawing Name: None (start from scratch)

Scope:

Using the figure below as a guideline, draw the layout shown. Set the Units to 
Architectural, 0'-0" Precision. Do not worry about drawing the dimensions, use only them 
as a reference.

･ Set the units to Architectural first.
･ Draw the walls using different types of coordinate entry.
･ Use the Get Distance command to check your distances.
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Section 3 Review Questions

1 Identify the following icons by writing the command and the toolbars where they can be 
found.

2 From what pull-down menu can you access the Units dialog box and Drawing Boundary 
command?
__ Tools
__ View
__ Format
__ Dimension

3 From what pull-down menu can you access the Drawing Setting dialog box?
__ Tools
__ Format

4 If you are drawing a building 100' x 50', what would seem reasonable limits?
Lower Left Corner __________
Upper Right Corner _________

5 What happens to the grid spacing if you set it to 0?
__ The grid is never displayed if you set it to 0
__ Snap setting goes polar
__ Grid defaults to the Snap spacing
__ DraftSight reverts to Grid Off mode

6 Can you draw with Absolute Polar coordinates?

Icon Command Toolbar

a.

b.

c.

d.
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7 How is Snap On and Off different from Entity Snap?

8 Give an example for the following methods to type coordinates:
Absolute: __________________Relative: _____________________
Polar: _____________________Direct Distance: _______________

9 If drawing in Architectural Units, and you simply type 6, does DraftSight assume this to 
be six feet, or six inches?

10 Do you need to type leading and trailing zeros?
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Section 4
Modify Commands

Estimated Class Time: 2.5 hours

Objectives
This section will cover simple Modify commands and methods for selecting entities to 
modify. Most of these commands will be located in the Modify toolbar. Begin with a 
Modify command, and then select the objects to modify. Press <Enter> to continue. 
Remember to read the command line and follow the DraftSight prompts.
 Entity Selection Options
Learn the various methods for selecting entities.
 Move
Move selected entities to a new location.
 Copy
Copy selected entities to a new location.
 Mirror
Mirror selected entities about a mirror line.
 Rotate
Rotate selected entities to make a new angle.
 Scale
Scale entities to make them larger or smaller.
 Trim
Trim entities to a cutting edge.
 Extend
Extend entities to a boundary.
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Selecting Entities

Command Overview
Knowing how to select objects is an important aspect of all of the Modify commands. 
Typically one begins with a specific Modify command and then selects the objects to 
modify. When an object is selected, it will be highlighted. Continue to select (or de-
select) entities at the Specify entities>> prompt, and press  to continue. Entities can 
be selected individually, with a selection window or by invoking one of the options at the 
Select entities>> prompt.

Select Entity 
Option

Key Overview

Pick (select) Place the cursor over the object and select it using the left mouse 
button

Window (left to 
right)

Making a selection window from left to right will create a 
window in which only the entities that are completely within the 
window will be selected. Place the cursor in a blank area of the 
drawing to the left of the entities to select, and click the left 
mouse button. Drag the mouse to the right to display the 
selection window, and click the opposite corner.

Window (right to 
left)

Making a selection window from right to left will create a 
crossing window. All of the entities that are crossed by this 
window will be selected. Place the cursor in a blank area of the 
drawing to the right of the entities to select, and click the left 
mouse button. Drag the mouse to the left to display the selection 
window, and click the opposite corner.

Deselecting 
entities

To deselect a previously selected entity, press the Shift key and 
select it again using the left mouse button. (It may be necessary 
to select it twice.)

Last L At the Specify entities prompt, type L to select the Last entity 
drawn.

All ALL At the Specify entities prompt, type ALL to select all of the 
entities in the drawing.

Fence F At the Specify entities prompt, type F to initiate the Fence option. 
All entities crossed by the fence line will be selected.

Window Polygon WP At the select entities prompt, type WP to initiate a Window 
Polygon. Create the polygon by picking points around the entities 
to select. This will be easier if Ortho is Off. Only entities 
completely within the window polygon will be selected.
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General Procedure
1 Click a Modify command.
2 At the Specify entities>> prompt, initiate the selection option (remember to press ).
3 When all of the desired entities have been selected, press  to continue with the modify 

command.

Crossing Polygon CP At the Select entities prompt, type CP to initiate a Crossing 
Polygon. Create the polygon by picking points around the entities 
to select. This will be easier if Ortho is Off. All entities crossed by 
the polygon will be selected

Undo U At the Select entities prompt, type U to remove the previously 
selected entities.

Select Entity 
Option

Key Overview

･ After all entities have been selected, press  to continue, even if all entities 
have been selected.

･ If the selection window is accidentally selected, try to utilize the crossing 
window to select the entity.  If there is no way to properly cross the entity 
with a window to select it (right to left), make a window that selects nothing 
and try to select the entity again without exiting the Modify command.

･ It is very difficult to select entities if the Snap is On.
･ Entities can also be selected first, and then a Modify command can be 
selected. When entities are selected first, they will be highlighted and will 
display EntityGrips. 

･ At the Select entities>> prompt, type ? to view the list of command line 
options.  Type the letter that is capitalized for the option desired and press . 
It is not necessary to view this list in order to utilize one of the selection 
options.
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Command Exercise ­ Selecting Entities
Estimated time to completion: 5 minutes

Drawing Name: Select 1.dwg

Scope:

Using the Delete command, practice deleting objects using various selection methods.
1 Use the Window option (left to right) to select the red entities.
2 Use the Fence option to select the green entities.
3 Use the Window Polygon (WP) option to delete the blue entities.

･ Dashed lines displayed on the screen when using the selection methods 
indicates that entities have been selected.

Try using the Undo command and bring back the entities and try different 
selection methods.
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Move Command 

Command Access

Command Overview
To move an entity, pick a base point, drag and pick or use any of the methods previously 
discussed to input coordinates.

General Procedure

1 Click the Move  icon from the Modify toolbar.
2 Select the entities to move and press 
3 Pick a point to be used as a base (from) point.
4 Drag the mouse and pick the destination (to) point, or use the Absolute, Relative, Polar 

coordinates of direct distance method to relocate the entity.

Toolbar Menu Modify / Move
Pull-Down Menu Modify>Move
Command Line Specify entities
Alias M
Dialog Box

･ Use Entity Snaps for picking the base point and the point for the new location.
･ If using the direct distance method to relocate the entity, be sure that Ortho is 
On.

･ Remember to use the pick button (left mouse button) to select the base point 
and the new location for the entity.

･ Be sure Snap is Off when selecting entities.
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Command Exercise ­ Move
Estimated time tp completion: 5 minutes

Drawing Name: move 1.dwg

Scope:

Make sure Snap is Off and Move the blue entities into the red rectangle.
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Copy Command 

Command Access

Command Overview
To Copy an entity, pick a base point, drag and pick or use any of the methods previously 
discussed to input coordinates.

General Procedure
To create a single copy:

1 Click the Copy icon  from the Modify toolbar.
2 Select the entities to Copy and press .
3 Pick a point to be used as a base (from) point.
4 Drag the mouse and pick the destination (to) point, or use the Absolute, Relative, Polar 

coordinates of direct distance method to relocate the entity.
5 Press the  key to exit.

To create multiple copies:

1 Click the Copy icon  from the Modify Toolbar.
2 Select the entities to Copy and press 
3 Pick a point to be used as a base (from) point.
4 Drag the mouse and pick the destination (to) point, or use the Absolute, Relative, Polar 

coordinates of direct distance method to relocate the entity.
5 Drag the mouse to another new location and click.  Continue until all copies have been 

made.
6 Press the  key to exit.

Toolbar Menu Modify / Copy
Pull-Down Menu Modify>Copy
Command Line Specify entities
Alias CO or CP
Dialog Box

･ Use the Entity Snaps for picking the base point and the new location.
･ If using direct distance to relocate the entity, be sure Ortho is On.  
･ Remember to use the pick button (left Mouse Button) to pick the base point 
and the new location of the entity.

･ Be sure Snap is Off when selecting entities.
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Command Exercise ­ Copy
Estimated time to completion: 5 minutes.

Drawing Name: copy 1.dwg

Scope:

Copy the entities in the rectangle on the left into the rectangle on the right.

･Be sure ESnap is On and Copy the entities using the bottom left endpoint of the 
left rectangle to the bottom left endpoint of the right rectangle.
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Command Exercise ­ Copy
Estimated time to completion: 5 minutes

Drawing Name: copy 2.dwg

Scope:

Copy the Adjusting Arm in the drawing similar to the graphic shown.

What happens when you use the Undo command after making multiple copies?
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Offset Command 

Command Access

Command Overview
To offset a single entity, first set the offset distance by picking two points in the graphics 
window, or by typing the offset distance. Select the entities to offset and pick the side to 
offset.

General Procedure

1 Click the Offset icon  on the Modify toolbar.
2 Set the offset distance (pick or keyboard input).
3 Select the entity to offset and press .
4 Click the side of the entity where you want your new copy.

Toolbar Menu Modify / Offset
Pull-Down Menu Modify>Offset
Command Line Specify distance
Alias O
Dialog Box

･ You can offset lines, circles, arcs and PolyLines.
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Command Exercise ­ Offset
Estimated time to completion: 5 minutes

Drawing Name: offset 1.dwg

Scope:

Offset the entities in this file with a distance of 10 mm.
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Mirror Command 

Command Access

Command Overview
Mirror selected entities around a mirror line with Ortho On or Off. 

General Procedure

1 Click the Mirror icon  on the Modify toolbar.
2 Select the entities to mirror and press 
3 Pick the first point of the mirror line.
4 Drag the mouse and pick the second point of the mirror line.
5 At the command prompt Delete source entities?, press  to accept the default of 

No,  type Y to delete the source entities.

Toolbar Menu Modify / Mirror
Pull-Down Menu Modify>Mirror
Command Line Specify entities
Alias MI
Dialog Box

･ Turn Ortho On to mirror across a horizontal or vertical line.
･ The mirror line goes indefinitely through two points selected.
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Command Exercise ­ Mirror
Estimated time to completion: 5 minutes

Drawing Name: mirror 1.dwg

Scope:

Mirror the entities in this file using the endpoints of the upper and lower endpoints for 
the mirror line.
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Rotate Command 

Command Access

Command Overview
Rotate selected entities in a counterclockwise direction with a positive rotation angle. 
Rotate in a clockwise direction with a negative angle. The reference option permits the 
user to reference the angle of an existing line in the drawing and type a new angle.

General Procedure
To use the rotate command:

1 Click the Rotate icon  on the Modify toolbar.
2 Select the entities to rotate and press .
3 Pick a pivot point for the rotation.
4 Type in the rotation angle, or drag the mouse and pick a rotation angle.

To use the rotate command with reference option:

1 Click the Rotate icon  on the Modify toolbar.
2 Select the entities to rotate and press .
3 Pick a pivot point for the rotation.
4 Type R for Reference or select the right mouse button and select the Reference option 

from the Shortcut menu.
5 Using EntitySnaps, select the endpoints of the line to reference.  This will determine the 

precise reference angle.
6 Type the new angle.

Toolbar Menu Modify / Rotate
Pull-Down Menu Modify>Rotate
Command Line Specify entities
Alias RO
Dialog Box

･ Turn Ortho On to rotate in 90 degree increments, relative to the current 
rotation angle.

･ When rotating the entity with Ortho On, keep the cursor close to the base 
point to make it easier to rotate.

･ When using the Reference option to straighten entities, it is more accurate to 
reference the angle of a line in the drawing using the EntitySnap, than to try 
and find the angle of the line and rotate it in the negative direction.

･ Entities will be rotated around the rotation pivot point.
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Command Exercise ­ Rotate
Estimated time to completion: 5 minutes

Drawing Name: rotate 1.dwg

Scope:

Rotate the entities (text included) as listed in the drawing.
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Command Exercise ­ Rotate
Estimated time to completion: 5 minutes

Drawing Name: rotate 2.dwg

Scope:

Straighten the object using the Reference option with rotate. Use "A" as the pivot point.
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Scale Command 

Command Access

Command Overview
Scale entities up or down from a selected base point. Use the reference point option to 
reference a known length, then type the new length to scale the object proportionately.

General Procedure
To use the Scale command:

1 Click the Scale icon  on the Modify toolbar.
2 Select the entities to scale and press .
3 Pick a base point on or near the entity.
4 Type in the scale factor and press .

To use the Scale command with the reference option:

1 Click the Scale icon  on the Modify toolbar.
2 Select the entities to scale and press .
3 Pick a base point on or near the entity.
4 Type R for Reference (and press ), or press the Right Mouse Button and select Reference 

from the Shortcut menu.
5 Use EntitySnaps to specify the reference length, or type the reference length, if known.
6 Type the new length.

Toolbar Menu Modify / Scale
Pull-Down Menu Modify>Scale
Command Line Specify entities
Alias SC
Dialog Box

･ Entities will be scaled up or down proportionately.
･ When using Scale with the Reference option, it is more precise to use the 
EntitySnap to specify a reference length. 
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Command Exercise ­ Scale
Estimated time to completion: 5 minutes

Drawing Name: scale 1.dwg

Scope:

Scale the images as indicated in the drawing.

･ Remember that the base point represents the point about which objects are 
scaled.  If you select a base point that is away from the part, the object may 
move off the screen when scaled.  Use the Zoom Extents command to regain 
your view.
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Command Exercise ­ Scale
Estimated time to completion: 5 minutes

Drawing Name: scale 2.dwg

Scope:

Scale the image so that the outside diameter is 50.

･ For the reference point, use the Quadrant snap point and choose the diameter 
of the circle.
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Trim Command 

Command Access

Command Overview
Trim entities to a cutting edge. The cutting edge may or may not cross the entity to trim. 
If the entities do not cross or intersect, hold the Shift key when selecting the trim entity 
to extend the entity. Undo is an option that can be used within the Trim command, 
without completely exiting the command.

General Procedure
Regular Trim (no extend):

1 Click the Trim icon  on the Modify toolbar.
2 Specify cutting edges>> and press .
3 Specify segments to remove>>.
4 Press  to exit.

Trim Using the Extend Option:

1 Click the Trim icon  on the Modify toolbar.
2 Specify cutting edges>> and press .
3 Hold the Shift key and Specify segments to remove>> (extend).
4 Press  to exit.

Toolbar Menu Modify / Trim
Pull-Down Menu Modify>Trim
Command Line Specify entities
Alias TR
Dialog Box

･ Selecting multiple entities to trim is acceptable.
･ An entity must be crossed by the cutting edge to be trimmed (unless the 
Extend option is selected and the entity would cross the cutting edge if 
extended.)

･ The cutting edge must cross a circle in two places in order for the circle to be 
trimmed.
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Command Exercise ­ Trim
Estimated time to completion: 5 minutes

Drawing Name: trim 1.dwg

Scope:

Trim the lines outside the box. Select the lines individually. Use the Undo command to 
repeat the exercise using a selection window (right to left selection).
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Command Exercise ­ Trim
Estimated time to completion: 5 minutes

Drawing Name: trim 2.dwg

Scope:

Trim the lines inside the box. Select the lines individually. Use the Undo command to 
repeat the exercise using a selection window (right to left selection).
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Extend Command 

Command Access

Command Overview
Extend entities to a boundary, by selecting the entities towards the end to be extended. 
The boundary may or may not reach the entity being extended. 

General Procedure

1 Select the Extend icon  on the Modify toolbar.
2 Specify boundary edges>> and press 
3 Specify segments to extend>>.
4 Press  to exit.

Toolbar Menu Modify / Extend
Pull-Down Menu Modify>Extend
Command Line Specify entities
Alias EX
Dialog Box

･ The Undo option will undo one step at a time, without exiting the Extend 
command.

･ An entity must be able to meet the boundary edge to be extended.
･ Select the entity to extend anywhere on the half that is closest to the 
boundary.

･If an entity crosses the boundary line, hold the Shift key and select it to Trim it 
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Command Exercise ­ Extend
Estimated time to completion: 5 minutes

Drawing Name: extend 1.dwg

Scope:

Extend the horizontal lines to the side of the rectangle. Select the lines individually. Use 
the Undo command to repeat the exercise using a selection window (right to left 
selection).
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Section 4 Exercise ­ Subassembly
Estimated time to completion: 15 minutes

Drawing Name: section 4 mcad.dwg

Scope:

Use the commands you have learned in this past section to assemble the components so 
the drawing looks like the figure on the right. Clean the corners of the base plate with 
the Trim and Extend commands.
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Section 4 Exercise ­ Modify Commands
Estimated time to completion: 15 minutes

Drawing Name: section 4 aec.dwg

Scope:

Using the Modify commands, furnish the patient wards as shown.
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Section 4 Review Questions
1 At the Select entities prompt, what letter must you type to use the Fence option?

___FE
___FO
___F
___O

2 Write down the letter to type for each of the following Entity Selection options:

Last - _________________
Fence - ___________________
All - ____________________
Crossing Polygon - _____________________
Window Polygon - ______________________

3 Identify the following icons that can be found on the Modify toolbar:

4 Typing RO at the command line invokes which command?

___Scale
___Rotate
___Recover
___Redraw

Icon Command

a.

b.

c.

d.

e.

f.

g.

h
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5 What does the U option stand for in the Trim and Extend commands?

6 Can you trim a circle?  Try it.  If you are able to trim a circle, what type of entity does it 
become?

7 Explain the similarities between the Copy and Move commands.

8 Can you trim a line that is acting as a cutting edge? Try it.
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Section 5
Properties and Layers Toolbars

Estimated Class Time: 3 hours

Objectives
This section will focus on the Properties and Layers toolbars. Properties include Color, 
LineStyle and LineWeight and Layers. Layers will keep the drawing information 
organized. Use the drop-down layer control list to make a layer current or change a 
layer's state. Use the Layers manager dialog box to create new layers. These settings can 
be saved to a drawing that can be use for a prototype or template for other drawings.
 Layer Control
Control the layer's state from this drop-down list.
 Make an Entities Layer Current
Select an entity in the drawing and make its layer be the current layer.
 Color Control
Control the color of the objects being drawn.
 LineWeight Control
Control the LineWeight of the entities being drawn.
 Layers Manager
Use the Layers Manager dialog box to create a system of layers for the current drawing.

･ A layer that is current cannot be frozen, and vice versa.
･ Use the Freeze option instead of Off.  A frozen layer is completely ignored in a 
drawing regeneration and will therefore make a faster regeneration.
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Layer Control

Command Access

Command Overview
Layers may be conveniently selected from the Layer Control drop-down list. Layers may 
be made current, or the layer's state may be changed. The options include On or Off, 
Freeze or Thaw, Lock or Unlock and making a layer printable or not. A layer may be 
made current by selecting it from the list. When the command line is blank, the 
properties of a selected entity will be identified in the Properties Pallet, and can be 
placed on a different layer by selecting a different layer from the drop-down list. This 
feature applies to Color, LineType and LineWeight.

Toolbar Menu Layers
Pull-Down Menu Format>Layers
Command Layers
Alias LA
Dialog Box Layers Manager

Layer State Overview

Make Layer Current Select the name of the layer in the drop-down list to make it current. 
Objects drawn on the current layer will have the properties that are 
assigned to that layer.

Turn a Layer On or 
Off

Select the colored orb to turn that layer on (green). Select it again to 
turn it off (grey). A layer is not visible when it is turned off, however, 
it may still be the current layer. A layer that is turned Off and current 
at the same time would be odd, because the new entities drawn 
would be invisible until the layer is turned on again.

Freeze or Thaw in all 
Viewports

Select the blue pond symbol to freeze that layer (icicles). Select the 
icicles to thaw the layer. A layer is not visible when it is frozen. It is 
also completely ignored in a regeneration, which will make 
regeneration time faster. A layer that is made current cannot be 
frozen.

Lock or Unlock a 
layer

Entities on a locked layer cannot be changed. When a layer is locked 
current, entities may be drawn on that layer, but cannot be changed.

Make a Layer 
printable

This feature controls whether a layer is printed or not. This way a 
layer can be visible, but will not print.
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General Procedure
To make a layer current:

1 Click the down arrow in the layers list from the Layers 
toolbar.

2 Click the Layer (name) to make it current.

To change a layer's state:

1 Click the down arrow in the layers list from the Layers 
toolbar.

2 Select the desired option: On/Off, Freeze, Thaw, Lock/Unlock or Print/No Print.

To move entities from one layer to another:
1 With the command line blank, select the entities to change.

2 Click the down arrow in the layers list and select the 
desired layer.

3 Press ESC two times to deselect the entity and cancel the EntityGrip.
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Command Exercise ­ Layers
Estimated time for completion: 10 minutes.

Drawing Name: Layer 1.dwg

Scope:

Using the Layer Control drop-down list, draw the entities on the appropriate layers. 
Make the layer current before you draw the entities. Practice freeze and thaw options.
1 With the Line Layer current, draw a series of lines.
Notice the lines are cyan in color.
2 With the Circle Layer current, draw a series of circles.
Notice the circles are magenta in color.
3 With the Rectangle Layer current, draw a series of rectangles.
Notice the rectangles are red in color.
4 Lock the Lines layer.
5 Attempt to Delete a line.
Notice the lock icon appears when you select a line.
6 Turn the Circle layer off.
Notice that the circles disappear.
7 Freeze the Rectangle layer.
Notice that you cannot freeze the current layer.
8 Freeze the Lines layer.

Notice that the layer is invisible.

･ You can draw on a layer that is turned Off, but you can't draw on a layer that 
is frozen.  DraftSight will not regenerate objects on a frozen layer.  Locking a 
layer is a good way to use a window to select entities but not those on the 
locked layer.
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Activate Layer Command

Command Access

Command Overview
Make a layer current by selecting an entity in the drawing on that layer.

General Procedure
1 Click Format>Layer Tools>Activate Layer from the pull-down menu.
2 Select the desired entity.

Toolbar Menu Layer Tools> / Activate Layer
Pull-Down Menu Format>Layer Tools>Activate Layer
Command ActivateLayer
Alias ACTLAY
Dialog Box

･ An entities layer can be identified first by selecting it with the command line 
blank.
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Color Control Command

Command Access

Command Overview
This option controls the color of the entities currently being drawn. Typically, the colors 
of objects in the drawing should be determined by the ByLayer, and it is not advisable to 
mix colors in the same layer. This is because the user will usually want to know at a 
glance that all entities of a certain color are on a particular layer. Be sure that ByLayer 
appears in the color control box. When an entity is selected with the command line 
blank, selecting a color from the drop-down list will automatically apply the color 
selected to that entity.

General Procedure
1 Click the down arrow in the color control list.
2 Select ByLayer.

Toolbar Menu Properties / Color
Pull-Down Menu Format>LineColor
Command LineColor
Alias LC
Dialog Box Line Color

･ When drawing, make sure that the word ByLayer appears in the color control 
window.  This is a suggestion, but not a rule.

･ The color control list will appear grey when in the middle of a command.  
Press ESC to cancel the command and the color control list will be accessible.

･ Selecting Specify color from the color control-drop down list will display the 
Line Color dialog box and a full color spectrum.
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LineStyle Control Command

Command Access

Command Overview
This option controls the LineStyle of the entities currently being drawn. It is typical that 
a variety of LineStyles may be present on the same layer, such as continuous, Centerline 
and hidden. However, it is best to leave the LineStyle control setting to ByLayer. 
Selecting Other from the drop-down list will display the LineStyle manager dialog box. 
The user can load additional LineStyles into the drawing using either this dialog box or 
the Layer manager dialog box.

General Procedure

1 Click the down arrow in the LineStyle  control list.
2 Click Other.
3 From the LineStyle manager dialog box, click Load..., then scroll through the list to find 

and click the LineStyles to load into the drawing.  Hold down the CTRL key to select 
additional LineStyles.  Hold the Shift key to select a range of LineStyles.  Click OK (two 
times) to exit.

Toolbar Menu Properties / Line Style
Pull-Down Menu Format>LineStyle
Command LineStyle
Alias LSTYLE
Dialog Box Line Style

･ Be sure the word ByLayer appears in the LineStyle control window. If making 
another LinseStyle current for a specific reason, remember to change it back 
to ByLayer.

･ LineStyles can be assigned to a layer.
･The system variable LineScale will globally control the scale of the LineStyle in 
the drawing.
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LineWeight Control Command

Command Access

Command Overview
LineWeight of an entity can be controlled individually or by the layer when set to 
ByLayer. This section will determine LineStyles by the layer in the section that covers 
the Layers manager dialog box.

General Procedure
To make the LineWeight the current setting:

1 Click the down arrow in the LineWeight  control list.
2 Click the desired LineWeight.

To change the LineWeight of an existing entity:
1 With the command line blank, select the entity in the drawing to change.

2 Click the down arrow in the LineWeight  control list.
3 Select the desired LineWeight.  Once the LineWeights of the entities have changed, press 

ESC twice to cancel the selection.

Toolbar Menu Properties / Line Weight
Pull-Down Menu Format>Line Weight
Command LineWeight
Alias LW
Dialog Box Options>Drafting Styles>Line Font>Line Weight

･ Be sure that the word ByLayer appears in the LineWeight Control window.  If 
selecting another LineWeight current for a specific reason, remember to 
change it back to ByLayer.

･ LineWeights can be assigned to a layer. 
･ LineWeights are not visible unless Display weight in graphics area is selected 
in the LineWeight dialog box.
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Layers Manager Command

Command Access

Command Overview
Use the Layers Manager dialog box to create drawing layers with specific Names, Colors, 
LineStyles, LineWeights and PrintStyles (colors) and Print variables (print or no print). 
The layers list may be sorted in ascending or descending order. By clicking on the 
heading, such as Name. Layer 0 is a default layer and cannot be renamed or deleted. This 
makes it a good working layer. Other layers may only be deleted if there is no geometry 
on them and they are not the Current layer. Layers may be made Current, Frozen, 
Thawed, Locked, Unlocked, turned On or Off from this dialog box. Once objects are 
created, they may be moved to other layers using the change entity layer command, or 
by selecting the entity with the command line blank and selecting the layer to move it to 
from the drop-down list. Create a system of layers to save as a prototype or template 
drawing.

Toolbar Menu Layer Tools
Pull-Down Menu Format>Layer Tools
Command Line
Alias
Dialog Box

Feature Overview

New Select this button to create a new layer. The default name will be Layer1, 
Layer2, Layer3, etc. Type in a different layer name, or double-click on the 
Layer name to change it.

Delete This option allows the selected layers to be deleted, only if the layer 
contains no geometry or is not current.

Activate Select this option to make a highlighted layer active. A layer that is active 
cannot be frozen.

Status This gives you a visible notification on which layer is the active one. The 
active layer has the arrow in the box next to the name.

Name Lists the layer name. Double-click to rename a layer. Spaces and certain 
characters are not allowed. To select a layer in the dialog box, pick it with 
the Left Mouse button. To deselect it, pick it again, select another layer or 
click in the blank area of the dialog box. To select all layers, right-click in 
the blank area and choose Specify All.

Show / Hide Turns the selected layers On or Off. A layer that is turned off may still be 
active, but will not be visible. This is an odd state, because objects drawn 
on that layer will not be seen until the layer is turned back on.
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General Procedure

1 Click the Layers Manager icon  on the Layers toolbar.

2 In the Layers Manager dialog box, click the New icon  and name the New Layer.
3 Select the corresponding Color. To access the Select Color dialog box, click in the color 

box, and select the down arrow.  Choose the appropriate color.
4 Select the corresponding linestyle. To access the LineStyle dialog box, pick the box and 

select the down arrow.  Choose a liestyle from the list or click Load... and pick a linestyle 
from the list.  Click OK or Cancel to exit the LineStyle dialog box.

5 Select OK from the Layers Manager dialog box.

Frozen / Thaw Freezes or thaws selected layers in all viewports. A frozen layer is not 
visible and cannot be made current.

Lock / Unlock Locks or unlocks selected layers. It is possible to lock an active layer and 
draw on the locked layer, but not modify the entities on that layer until it is 
unlocked.

LineColor Pick the color for the corresponding layer(s) to access the Color Dialog 
box. Pick a color from the standard colors or the full color pallet to apply to 
a selected layer.

LineStyle Pick the LineStyle for the corresponding layer(s) to access the LineStyle 
dialog box. Pick a linestyle from the load linestyles list to apply to a 
selected layer. Select the load button to access and select from the 
available linestyles list.

LineWeight Pick the LineWeight for the corresponding layer(s) to access the 
LineWeight dialog box. Pick a line weight from the list to apply to a 
selected layer.

PrintStyle Displays the pen color for the selected layer. 

Print Makes the selected layer printable or not.

Filter This section controls which layer names are visible. For all practical 
purposes, the word All should be visible in the text window.

Feature Overview

･ Use the Freeze option instead of Off.  Layers that are frozen are completely 
ignored in a regeneration, and hence will speed up regeneration time.

･ Deleting a selected layer or linestyle is similar to the Clean command.
･A layer can be renamed at any time.  This will help to organize the information 
in the drawing.

･ The Color, LineStyle, and LineWeight control options in the Properties toolbar 
should be set to ByLayer.  In this way these options will be determined by the 
layer.

･ The system variable LineScale controls the global scale of the linestyles in the 
drawing.  The effects of LineScale apply to linestyles that contain spaces and 
dashes (i.e., the hidden or center lines.)
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Command Exercise ­ Layers
Estimated time to completion: 10 minutes

Drawing Name: None (start from scratch)

Scope:

Using the Layers Manager, create the designated layers and draw the object using the 
appropriate layers. 

1 Create a layer named Box, use Continuous LineStyle and Blue color.
2 Create a layer called Hidden, load LineStyle Hidden, and Red color.
3 Create a layer called Support, load LineStyle Phantom, and Green color.
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Command Exercise - Layers
Estimated time to completion: 5 minutes

Drawing Name:  layer2.dwg

Scope:

In the Layers Manager dialog box, rename Layer 1 to Window. Make the House layer 
current. Select all and freeze all.
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Property Painter

Command Access

Command Overview
Object properties of a selected entity can be matched to other entities in the drawing. 
Select the source entity first, and then select the destination entity(s). The Match 
Properties command will apply the Color, Layer, LineStyle, LineScale, LineWeight, and 
Dimension, Text and Hatch styles. Once you have selected the source entity, type S to 
invoke the Property Painter dialog box. Remove the checkmark from any items not to 
match.

General Procedure
1 Invoke the Property Painter command by clicking Modify>Property Painter from the 

pull-down menu.
2 Click the source entity.
3 Click the destination entity(s).
4 Press  to exit the command.

Toolbar Menu
Pull-Down Menu Modify>Property Painter
Command Line PropertyPainter
Alias PAINT
Dialog Box Property Painter

･ This option is similar to the Microsoft Word Property Painter.
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Command Exercise ­ Property Painter
Estimated time to completion: 5 minutes

Drawing Name:  painter1.dwg

Scope:

Using the Property Painter command, match the properties of the red object lines in the 
right side view to the object lines in the front view, so that all of the object entities are 
black.
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Properties Command

Command Access

Command Overview
Properties of selected entities can be changed using the Properties command. The list in 
the Properties Palette will correspond to the entities selected. Entities may be selected 
before or after the Properties command is invoked. The most common features to 
change are Layers and LineStyles. When one item is selected, the Properties palette will 
display options relevant to the features of that entity, such as the radius of a circle, or the 
contents of selected text. Press Esc to deselect entities, and pick new entities to modify.

General Procedure
1 To invoke the Properties command, with the command line blank, select the entities to 

change.
2 Select the options to change from the Properties Manager list, and select or type a new 

option.
3 Press Esc to deselect the entities or exit.

Toolbar Menu Standard
Pull-Down Menu Modify>Properties
Command Line Properties
Alias PR
Dialog Box Properties (Palette)

･ The beginners rule is that colors of entities should be set to ByLayer.
･ Only layers that are already created will be available in the Layers list.
･Only line styles that have already been loaded will be available in the LineStyle 
list.
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Command Exercise ­ Properties
Estimated time to completion: 10 minutes

Drawing Name:  change1.dwg

Scope:

Using the Properties command, move the objects to the Object layer, the balloons to the 
Balloons layer, the bill of materials to the Bill of Material layer, the isometric to the 
Isometric layer and the drawing format to the Title Block layer.
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Command Exercise ­ Change Properties
Estimated time to completion: 10 minutes

Drawing Name:  change2.dwg

Scope:

Using the Properties command, change the radius of the circle to 2, the layer to Circle, 
and the center point to the midpoint of the line. Perform all these changes in the 
Properties Palette.
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Section 5 Exercise ­ Organize Your Drawing
Estimated time to completion: 15 minutes

Drawing Name: Section 5 mcad.dwg

Scope:

Use the commands you have learned in the past section to organize the drawing into 
different layers. Create a layer for each part in the assembly. Use the Properties tools to 
place the corresponding part on the correct layer.

Layer Name Color

Base Green

Spacer Red

Shoulder 
Pin

Yellow

Hex Bolt Magenta

Nut Cyan

Flat Washer Blue
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Section 5 Exercise ­ Object Properties
Estimated time to completion: 15 minutes

Drawing Name: Section 5 aec.dwg

Scope:

Move the walls to a yellow layer called Walls, the doors to a cyan layer called doors, the 
text to a magenta layer called text, the dimensions to a blue layer called dimensions and 
the room contents into a white layer called room.
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Section 5 Review Questions

1 Identify the following icons and briefly describe each function:

2 What are the two options (what the image represents and its opposite) for the individual 
icons in the Layer Manager Dialog box?

3 What is the difference between Freeze and Off when controlling layers?

4 You can turn the current layer Off.  Can you freeze the current layer?  Can you draw on 
a layer that is Off? Try it.

5 What command will remove layers thus decreasing the file size of your drawing?
___ Clean
___ Error Check
___ Sweep
___ Recover

6 What does it mean to choose color ByLayer?
___Entities choose their own color randomly.
___Entities default to the 0 layer and are black or white depending on the graphics 
window background color.
___Entities take on the color of the current layer they are assigned to.
___Entities take on an assigned color no matter what layer they are on.

Icon Function

a.

b.

Icon Function

a.

b.

c.
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7 What does the LineScale command do?

8 How can you control the Property Painter command so only specific features are 
matched, like LineStyle? Try it.
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Section 6
Drawing Files

Estimated Class Time: 2 hours

Objectives
This section will review New, Save, Save As and Open commands. Files can be managed 
using Windows-compliant methods such as the cursor menus (RMB). File Utilities will 
Audit, Recover and Purge drawing files.
 New
Create a new drawing using DraftSight template settings.
 Save
Save the drawing files in drives and folders (directories).
 Open
Open an existing drawing.
 File Management
Use the standard Windows method of managing files from dialog boxes invoked with 
Open and Save As commands.
 File Utilities
Error-Check, Recover or Clean drawings using the options found in File Utilities.
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New

Command Access

Command Overview
The simplest method is to start a new drawing from scratch. Another option in the 
Startup dialog box is to use a drawing template. When launching DraftSight for the first 
time, it is also possible to open a drawing. DraftSight supports multiple drawing 
documents. Control which document to view from the Windows pull-down menu. Each 
new drawing will be named NONAME_1, NONAME_2, NONAME_3, etc. until it is saved, 
and a drawing name is requested.

General Procedure

1 Click the New icon  from the Standard Toolbar.
2 Select the appropriate template file and click OK.

Toolbar Menu Standard / New
Pull-Down Menu File>New
Command New
Alias Ctrl + N
Dialog Box Specify Template

･ The system setting DisplayDialogs must be set to YES to view the Create New 
Drawing dialog box.  

･ Pay attention to the drawing name in the DraftSight Title Bar.  If it reads 
NONNAME_5.dwg, then it might be that 5 unnamed drawing have been 
started.  Close drawings that are not being used.

･ Use the Windows pull-down menu and select the drawing to view when more 
than one document is open.
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Save

Command Access

Command Overview
The Save command will save recent changes to the current drawing. The first time the 
Save command is used with an unnamed drawing, the File Save dialog box will appear, 
which is basically the Save As command. Choose the drive, folder, file type and name the 
new drawing. The file extension for all DraftSight drawings is .dwg. Once a drawing file 
is named, every Save will be applied to the current drawing. Drawings will be 
automatically saved every 10 minutes. This can be changed in Options>System 
Options>Auto Save & Backup>Auto-save/backups. Drawings can be saved as far back as 
R12 (*.dwg), as well as Data Exchange Files (*.dxf) or as a template drawing (*.dwt).

General Procedure
To Save As a new drawing file:

1 Click Save As... from the File pull-down menu.
2 Click the drive, folder, file type and enter the Name of the drawing file.
3 Click the Save button  in the dialog box.

To Save a drawing file:

1 Click the Save icon  on the Standard Toolbar.

Toolbar Menu Standard / Save
Pull-Down Menu File>Save
Command Save
Alias Ctrl + S
Dialog Box Save file

･ Remember to Save changes frequently to the current drawing.
･ It is not necessary to type the file extension.  The file type will be determined 
by the option in the drop-down list.

･ The DisplayDialogs variable must be set to Yes to view the Save File Dialog 
box.

･ All DraftSight drawings will have a .dwg extension regardless of the version 
selected from the drop-down list (2010, 2004-2006, R12).
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Open

Command Access

Command Overview
With the Open command, files can be accessed from the Open dialog box. Choose the 
drive and folder to locate a drawing file and select the drawing file, which can be 
previewed before opening. Once a drawing file is selected, choose Open or double click 
to open the file.

General Procedure
To Open a drawing file:

1 Click the Open...  icon on the Standard Toolbar.
2 Locate the drive and folder and select the drawing file to preview.
3 Click Open in the dialog box, or double-click the file to Open.

Toolbar Menu Standard / Open
Pull-Down Menu File>Open
Command Open
Alias Ctrl + O
Dialog Box Open

･ Opened drawing files can be managed from the Windows pull-down menu.
･ The DisplayDialogs variable must be set to Yes to access the Open dialog box.
･Drawings can only be previewed if they have been opened in the latest version 
of DraftSight.
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File Management

Command Access

Command Overview
Drawing files can be managed from dialog boxes launched from the Open, Save, Save As 
or New commands. This is a Windows-compliant feature and works similar to most 
Windows programs. Select drives, folders, locate files and then right-click (RMB) to 
access the Shortcut menu.

General Procedure
1 Invoke the Open or Save As command.
2 Select a drawing file, then right click to access the options.

Toolbar Menu Standard / Open, Standard / New, Standard / Save
Pull-Down Menu File>Open, File>New, File>Save, File / Save As
Command Open, Save, New
Alias Ctrl + O, Ctrl + S, Ctrl + N
Dialog Box Open, Save file, Specify template

･ DraftSight drawing files have a .dwg extension.
･ Picking a drawing file twice will invoke the read-only dialog.
･ Typing *.* in the File Name text box will display all the file names with any 
extension (the asterisk is a wild card), however, it may not be possible to open 
all of these files.

•.dwt files are template files.
•.bak files are backup files.
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Command Exercise ­ File Management
Estimated time to completion: 5 minutes

Drawing Name: None (start from scratch)

Scope:

Start a new drawing. Use the Standard template. Choose Architectural Units; Precision 
1/16", Decimal Degrees; Precision 0, Angle 0 North and Direction Counterclockwise. Set 
Drawing Boundary to 100'x75'.  Save the drawing as NewArch.dwg. Draw some lines 
and save the changes. Use the Save As command and save the drawing as 
NewArch2.dwg.
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File Utilities

Command Access

Command Overview
Use the Error Check command to fix errors in the drawing. The Recover command will 
open damaged drawing files and check for errors.  Clean will delete unreferenced 
(unused) drawing information, such as Layers, LineStyles, Text Styles, Dimension Styles 
and Blocks.

General Procedure
To Error Check a Drawing File:

1 Click Error Check from the File Pull-down menu.
2 At the prompt Automatically fix drawing database errors?, type Y (for Yes) and 

press .

To Recover a Drawing File:
1 Click Recover... from the File pull-down menu.
2 Locate the file to recover and click Open.

To Clean a Drawing File:
1 Click Clean... from the File pull-down menu.
2 In the dialog box, select Show unreferenced entities. 
3 Set options: 

a. Delete dependent entities: Removes References and subordinate References that are 
not referenced by other entities.
b. Confirm before delete: Displays the Confirm Clean dialog box for each Reference to 
discard.

4 Click Delete to discard the selected References or Click Delete All to discard all unused 
References. 

Toolbar Menu
Pull-Down Menu File>Error Check, File>Clean, File>Recover
Command ErrorCheck, Clean, Recover
Alias CL (Clean)
Dialog Box

･ Unused layers, LineStyles, Text Styles and Dimension Styles can be deleted 
from the corresponding dialog boxes.  This is essentially the same as the Clean 
command.

･ Unreferenced Blocks must be cleaned in order to delete them.
･ Only unreferenced information can be cleaned or deleted.
･ Repeat the Clean command several times.  It is necessary to Clean a Block 
before a Layer, LineStyle or Text Style referencing the Block can be Cleaned, 
etc.
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Section 6 Review Questions

1 Identify the following icons by writing the name of the command and the toolbar where 
it is found.

2 From what pull-down menu can you access the Save As... command?

3 What is the difference between Save and Save As...?

4 How can you change the Automatic Save variable?

5 Write a brief description for the following file extensions:

Icon Command Toolbar

a.

b.

c.

Extension Description

.dwg

.dwt

.bak

.dxf
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Section 7
Advanced Commands

Estimated Class Time: 3.5 hours

Objectives
This section will cover advanced Draw and Modify commands. Most of these commands 
will be found in the Draw and Modify toolbars.
 Point - Points are entities.  Seeing them in the drawing depends on the Point Style.
 Point Format - The Point Format can be changed to make a point more visible.
 Mark Divisions - Mark Divisions along an entity at an equal distance with the 

MarkDivisions command.
 Mark Lengths - Place Points along an entity at a specific distance with the 

MarkLengths command.
 PolyLine- Line and Arc segments can be drawn as a single PolyLine.
 Explode - PolyLines can be exploded to create separate Line and Arc segments.
 Edit PolyLine - Line and Arc segments can be joined using the Edit PolyLine 

command.
 Make Block - Drawing details can be converted into a symbol, or block.
 Insert Block - Once a block is created, it can be inserted into a drawing.
 Purge - Use Purge to delete unreferenced Blocks from a drawing.
 Export Drawing - Use Export Drawing to create a block from a drawing file.
 Pattern - Entities can be made into rectangular or circular patterns.
 Stretch - Stretch entities to make them longer or shorter.
 Edit Length - Use the Edit Length command to make lines and arcs longer or 

shorter.
 Split - Break sections of an entity using the Split command.
 Fillet - Add a radius to the corner of an object.
 Chamfer - Add an angle to the corner of an object.
 Grips - Grips are editing tools at your fingertips.
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Point

Command Access

Command Overview
Points are entities. The Point Format determines how they look on-screen. Choose the 
Point Format from the dialog box accessed by selecting Format>Point Format from the 
Pull-down menu. The default Point Format is a single speck, which is hardly noticeable 
in the drawing. Once the Point Format is changed to something more apparently visible, 
use the Mark Divisions and Mark Lengths to place points at specified increments 
along a selected entity. Use the Node option to Snap to Points that are placed in the 
drawing.

General Procedure

1 Click the Point icon  on the Draw toolbar.
2 Pick the location of the point in the graphics window.

Toolbar Menu Draw>Point
Pull-Down Menu Draw>Point>Options
Command Point
Alias PT
Dialog Box

･ Use the Esc key to exit the Multiple Point command.
･ Use the Node Snap option to snap to points in the drawing.
･ Use Object Snap or coordinates to precisely place a point in the drawing.
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Command Exercise ­ Point
Estimated time to completion: 10 minutes

Drawing Name: point1.dwg

Scope:

Place Points using EntitySnaps as indicated in the drawing. Place the point in the middle 
of the rectangle using ESnap and ETrack.
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Point Format

Command Access

Command Overview
The Point Format may be changed at any time. The default Point Format is a single 
speck, which is hardly noticeable in the drawing. Changes made to the Point Format are 
retained in the drawing.

General Procedure
1 Click Format>Point Style from the pull-down menu.
2 Select a Point Type.  The Point Size should be set to 5.00 and 0% relative to display.
3 Click OK to exit.

Toolbar Menu
Pull-Down Menu Format>Point Style
Command PointFormat
Alias
Dialog Box Options>Drawing Settings>Points

･ Choosing a Point Format that appears to be blank will not get rid of the 
points in the drawing.  It is best to delete the points that are no longer needed.

･ Use the Node Entity Snap option to snap to points in the drawing.
･ When the Point Size is set relative to the size of the screen, a Rebuild after 
zooming in or out will display the point style at the designated percent size.
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Command Exercise ­ Point Format
Estimated time to completion: 10 minutes

Drawing Name: point2.dwg

Scope:

Practice changing the Point Format to something more visible.  Rebuild to see the 
change in your drawing. Set the EntitySnap settings to Node, draw a continuous line 
through the points.
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Mark Divisions

Command Access

Command Overview
The Mark Divisions command places points on an entity at equal increments, but does 
not break the entity. If the Point Format is set to the default single speck, the Point will 
not be visible, but will still be there. It is better to change the Point Format to something 
you can see. Use the Node EntitySnap option to snap points along the divided entity.

General Procedure
1 Click Draw>Points>By Segments from the pull-down menu.
2 Select the entity to divide.
3 Type the number of segments and press .

Toolbar Menu
Pull-Down Menu Draw>Points>By Segments
Command MarkDivisions
Alias MDIV
Dialog Box

･ Change the Point Format to something more visible.
･ Use the Node EntitySnap option to snap the points placed along the divided 
entity.

･ Delete unwanted points.  Use the window selection method (left to right) to 
select the points without selecting other entities.

･ Use the Mark Divisions command on Lines, Circles, Arcs, PolyLines 
(rectangles) and Splines.

･ A circle will be divided from 0 degrees, and move counterclockwise, 
depending on the Units setting.
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Command Exercise ­ Measure and Divide
Estimated time to completion: 5 minutes

Drawing Name: point3.dwg

Scope:

Measure the top line using one-unit segments. Divide the bottom line into five equal 
segments.



Advanced Commands DraftSight

142 PolyLine

PolyLine

Command Access

Command Overview
PolyLines are essential to drawing in DraftSight. PolyLines are line and arc segments 
with common endpoints that are joined to make one entity. A Rectangle is an example 
of a polyline. Polylines can be more efficient because selecting one polyline segment will 
automatically select the entire polyline, and offsetting a polyline will Offset all of the 
segments equally. Sometimes it is necessary to Explode a polyline, then use the 
EditPolyLine command to join all the entities. When drawing a polyline, the user will be 
presented with many command line options, However, for all practical purposes, 
drawing a polyline is much like drawing a line segment.

General Procedure

1 Click the PolyLine icon  on the Draw toolbar.
2 Specify a start point.
3 Type W and  in order to add Width to the line segment.
4 Specify a starting Width>> (and ) and an ending Width (and ).  The default 

ending Width is usually equal to the starting Width, unless drawing an object such as an 
arrowhead.

5 Specify the next point>>, using methods learned in drawing line segments.
6 Optional: Type U (and ) to Undo the last polyline segment without exiting the PolyLine 

command.
7 Optional: Type A (and ) to invoke the Arc option without exiting the PolyLine 

command.  Type L (and ) to return to the Line command.
8 Optional: Type C (and ) to Close the PolyLine.

Toolbar Menu Draw / PolyLine
Pull-Down Menu Draw>PolyLine
Command PolyLine
Alias PL
Dialog Box

･ It is more typical and usually more practical to draw regular Line and Arc 
segments, then use the EditPolyLine command to join them.

･ When drawing a PolyLine, the most common options used are Width and 
Specify next vertex.

･ The default PolyLine width is 0.  When the Width is changed, it will remain 
the latest width setting until changed again.

･PolyLine starting and ending Widths can be specified by picking points in the 
drawing window.

･ Draw PolyLines in continuous segments.  If the polylines are drawn as 
separate segements, the intersections will appear jagged.  If the polyline is not 
closed, there will be a jagged edge at that opened intersection.

･ Do not cross PolyLine segments.
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Command Exercise ­ PolyLine
Estimated time to completion: 10 minutes

Drawing Name: None (start from scratch)

Scope:

Using the PolyLine command with the Width, Line and Arc options, draw the object 
indicated with a polyline Width of 0.1. Ortho should be On.

･ Do not start and stop the PolyLine segments.  Use the PolyLine Undo option 
if an incorrect endpoint is selected.
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Explode

Command Access

Command Overview
Use the Explode command to break a complex object into its component entities. You 
can explode Blocks and other complex objects like PolyLines, Hatches and 
Dimensions. Initially, you cannot edit the individual entities that make up a Block or 
other complex object. If you need to edit one of the entities comprising a complex object, 
you must explode it into its individual entities.

General Procedure

1 Click the Explode icon  on the Modify toolbar.
2 Select the entity(s) to Explode and press .

Toolbar Menu Modify / Explode
Pull-Down Menu Modify>Explode
Command Explode
Alias X
Dialog Box

･ It is typical to Explode a PolyLine if for some reason it is not possible to 
modify it.  Then use the EditPolyLine command to Join the line and arc 
segments back to a polyline.
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Edit PolyLine

Command Access

Command Overview
Use the EditPolyLine command to Join line and arc segments with common endpoints 
to create a single polyline. When using the EditPolyLine command, the user will be 
presented with many command line options. However, the most common options to use 
are Join and Width.

General Procedure

1 Click the Edit PolyLine icon  on the Modify toolbar.
2 Select a line, arc or polyline.
3 Press  at the prompt Entity is not a PolyLine. Do you want to turn it into 

one?

4 Type J for Join (and press).
5 Specify entities to Join (and press ).
6 Optional: Type W for Width (and press ).
7 Type the new Width for the polyline segments.
8 To complete the command, press  or X for Exit.

Toolbar Menu Modify / Edit PolyLine
Pull-Down Menu Modify>Entity>PolyLine
Command EditPolyLine
Alias EDPL
Dialog Box

･ Avoid making separate PolyLine segments.  As a rule, polylines should be 
Joined.

･ Line and Arc segments will be joined to another PolyLine, Line or Arc 
segment and will automatically be placed on the same layer as the first entity 
selected.

･ Sometimes, because of the complexity of an entity, the polyline may have to 
be exploded to be modified, then edited back to a PolyLine again.

･ Trimming polylines will also break the polyline at its origin point.  Use the 
Edit PolyLine command to join the polyline segments.
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Command Exercise ­ Edit PolyLine
Estimated time for completion: 10 minutes

Drawing Name: edpl1.dwg

Scope:

Using the Edit PolyLine command, edit the object on the left: first make one line a 
PolyLine, then Join all of the other entities to it. Change the Width to 0.5 mm.  Explode 
the object on the right. Try to move it, and note how many lines and arcs are in the 
object.
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Blocks

Command Access

Command Overview
Use the Make Block command to make a symbol out of selected entities. From the Block 
Definition dialog box, specify a Name, Base Point and the Entities. The original entities 
may seem to disappear from the drawing, depending on the settings specified in the 
dialog box. However, once a Block is made, it can be inserted into a drawing at different 
Scales and Rotation Angles with the Insert Block command. The Clean command 
must be used to delete unused blocks in the drawing. The ExportDrawing command 
makes a separate .dwg file out of a Block or drawing detail which can be inserted into 
any other drawing.

General Procedure

1 Click the Make Block icon  on the Draw toolbar.
2 Type in the Name for the Block.
3 Select a Base Point on or near the object.
4 Select the Entities to convert to a block.
5 Select Convert to Block, then select OK to exit the Block Definition dialog box.

Toolbar Menu Draw>Make Block
Pull-Down Menu Draw>Block>Define
Command MakeBlock
Alias BLOCK
Dialog Box Block Definition

･ Block details cannot be modified other than copied, moved, rotated or scaled 
unless they are exploded.

･If the Remove from drawing option was selected, type Undelete to bring the 
original entities back into the drawing.

･ Use EntitySnap to pick a base point, or type coordinates.  The default base 
point is absolute 0,0.

･ A Block definition exists in the drawing database once it is inserted, even if it 
is deleted from the drawing.  Use the Clean command to delete unused Block 
definitions.

･Blocks containing other blocks are referred to as nested blocks and are a good 
way to manage drawing details.  When a block containing nested blocks is 
inserted into a drawing, the nested blocks automatically become part of the 
drawing database as individual blocks.

･ Redefine the Block by making it again using the same name.  Redefining a 
block will automatically update all blocks with the same name that have been 
inserted into the drawing file.

･ Blocks cannot have the same name as the current drawing.
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Command Exercise ­ Block
Estimated time for completion: 5 minutes

Drawing Name: block1.dwg

Scope:

Create a Block from the object. Name the block Bolt and use the intersection of the 

centerline and the far right vertical line as the insertion point.
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Insert Block

Command Access

Command Overview
Use the Insert Block command to select a block name from the list of available blocks in 
the drawing. Specify an insertion point, a scale and a rotation angle, either in the dialog 
box or in the drawing window. A block may be Exploded when it is inserted, or after it is 
placed in the drawing. Use the Clean command to delete unused blocks from the 
drawing. The ExportDrawing command makes a block definition variable to other 
drawings by converting the block into a drawing file. When using the ExportDrawing 
command, select the Browse button and locate the drive and folder where you want the 
file to be located. 

General Procedure
1 Click Insert>Block... from the pull-down menu.
2 Select the name of the Block from the drop-down list, or click the Browse button to 

insert a drawing file as a block.
3 Check Specify later in order to click a screen position for the location of the block.

Toolbar Menu
Pull-Down Menu Insert>Block
Command InsertBlock
Alias INSERT
Dialog Box Insert Block

･ Clean the drawing of unreferenced blocks, layers, linestyles and the like, as 
this takes up space in the drawing database.

･ Title blocks are typically inserted at the insertion point of 0,0 and a rotation 
angle of 0.  It is usually a quicker method to insert the title block.

･ When specifying the rotation angle of a block in the drawing window, pick an 
insertion point, then drag the cursor to view the rotation angle.  Keep the 
cursor close to the insertion point to make it easier to view the rotation angle.  
Pick the desired angle. Pressing  will accept the default rotation angle of 0.

･ Turn the coordinates display On (F6) to view the distance and angle option.  
This is a toggle that will display the polar coordinate when in the middle of a 
command.
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Command Exercise ­ Insert Block
Estimated time to completion: 5 minutes

Drawing Name: insert1.dwg

Scope:

Insert the Bolt block as indicated in the drawing. Select Specify later for Position, to 
pick the insertion point on the screen. The insertion point is the midpoint of the vertical 
lines of the drilled hole. Do not change the scale factor. Click Specify later for Rotation 
angle to be able to rotate the block during insertion.
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Command Exercise ­ Insert Block
Estimated time to completion: 5 minutes

Drawing Name: insert2.dwg

Scope:

Insert the drawing file, B_size_sht1.dwg. Specify the parameters in the dialog box, use an 
insertion point of 0,0, a scale factor of 1 and 0 rotation angle.
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Clean

Command Access

Command Overview
The Clean command removes unused references from the drawing. References that can 
be removed include block definitions, layers, defined drafting styles (such as LineStyles, 
TextStyles, DimensionStyles and RichLineStyles), and other references as long as they 
are not referenced by other definitions or entities in the drawing file. You can apply the 
command to all component types or to selected ones.
Discarding unused references can reduce a drawing's file size. This command is useful 
before archiving or backing up drawings.
The Clean command does not remove defined views or coordinate systems because they 
are never referenced by another component of the drawing. To remove defined views, 
use the Views command. To remove defined coordinate systems use the CCS or 
CCSstyle commands.
You cannot discard the following: 
 Layer 0 (there must be at least one layer in the drawing) 
 The active layer 
 Layers that contain drawing entities 
 The LineStyle "Continuous" 
 The TextStyle "Standard" 

General Procedure
To discard unused references: 

1 Click File>Clean from the pull-down menu.
2 In the dialog box, select Show unreferenced entities. 
3 Set options: 

 Delete dependent entities: Removes References and subordinate References that 
are not referenced by other entities 

 Confirm before delete: Displays the Confirm Clean dialog box for each Reference to 
discard 

4 Click Delete to discard the selected References, or click Delete All to discard all unused 
references. 

Toolbar Menu
Pull-Down Menu File>Clean
Command Clean
Alias CL
Dialog Box Clean
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ExportDrawing

Command Access

Command Overview
You can write entities, a block, or an entire drawing to a new drawing file. You can save 
a Block or entities as a separate drawing file that you can insert into other drawings.
The ExportDrawing command is similar to the MakeBlock command, but is mainly 
used to export blocks, not to define them in the drawing.

General Procedure
To Save Blocks to file: 

1 Click File>Export>ExportDrawing from the pull-down menu. 
2 In the dialog box, under Source, select a source to write to file: 

 Block: Lets you select an existing block in the drawing to write to file. 
 All entities: Writes the entire drawing to file. 
 Selected entities: Writes the entities you select to file. 

3 Under Block UnitSystem, in UnitSystem, select the units to use for automatic scaling 
when the file is inserted in a drawing that uses different units (see the UnitSystem 
command, block units format option). 

4 Under Entities: 
 Click Specify entities icon and select entities in the graphics area to make up the 

block. 
 Select an option: 

Convert to Block: Replaces the source entities with a Reference of the Block definition. 

Do not convert to Block: Leaves the source entities in the drawing as they are. 

Delete: Removes the source entities from the drawing. 

5 Under Insertion point, for X, Y, and Z, type coordinate values or click Specify in 
graphics area to specify an insertion base point in the graphics area. 
The insertion base point is also used as the base for changing the block's scale and 
rotation. 

6 Under Destination, select a file name and path where the block or entities are saved, or 
click Browse to locate a destination folder and type a File name. 

Toolbar Menu
Pull-Down Menu File>Export> Export DWG file
Command ExportDrawing
Alias EXPORTDWG
Dialog Box Save File
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Command Exercise ­ Export Block
Estimated time to completion: 5 minutes

Drawing Name: export1.dwg

Scope:

Using the ExportBlock command, export the detail that resembles the title block (red 
entities). Name the file C_size_sht1.dwg, and be sure to add it to your current folder. 
Select the lower left corner as the reference point, and select all of the entities needed.



DraftSight Advanced Commands

Hatch 155

Hatch

Command Access

Command Overview
Use the Hatch command to fill enclosed areas or specified entities with a hatch pattern. 
Hatching a drawing adds meaning and helps to differentiate the materials and areas. 
Some drawing applications such as construction drawings require hatch patterns which 
can increase the clarity and legibility of a drawing. Along with patterns, you can apply 
solid hatches to fill in a bounded area with the current color by selecting Solid from the 
Pattern list. 

General Procedure
To set a hatch pattern: 

1 Click the Hatch/Fill...  icon on the Draw toolbar.
2 In the Hatch/Fill dialog box, from the Type list, select a pattern type.

Predefined: Lets you select from predefined patterns, including ISO and ANSI 
conforming patterns, as well as patterns commonly used in specific industries.
User-defined: Lets you select a pattern you or your enterprise created.
Custom: Lets you specify a pattern determined by your Angle and Spacing 
specifications.

3 If you selected a Predefined type from the Pattern list, select a pattern.
The Preview pane beside the Pattern list displays the selected pattern. 
You can instead use the Select Pattern Style dialog box to select a type and a pattern.

To set the angle and scale the hatch pattern:
1 In the Angle list, specify an angle for the hatch pattern.

Standard hatch patterns are made up of horizontal or vertical lines or drawn at an angle. 
A hatch angle of 0 degrees defines a horizontal line. The Angle list contains angle values 
between 0 and 360 in 15 degree increments. A positive angle rotates the pattern 
counter-clockwise.

2 Use the Scale list to specify a value by which to scale the hatch pattern.
The Scale list contains values between .25 and 2 in .25 unit increments (default is 1). 
For example, 2 doubles the distances in the pattern and .25 reduces the original 
dimensions by 1/4.
Note: User-defined patterns cannot be scaled. To change distances in user-defined 
patterns, use the Spacing list.

Toolbar Menu Draw / Hatch/Fill...
Pull-Down Menu Draw>Hatch/Fill...
Command Hatch
Alias H
Dialog Box Hatch/Fill
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3 If you selected a User-defined type, in Spacing specify the distance between lines in the 
hatch pattern.
Specify the distance in drawing units (default is 1). Change the line spacing to customize 
the pattern proportions for specific graphics areas.

4 If you selected an ISO Pattern type, use the ISO pen width list to select a pen width. 
5 Click Scale based on the sheet's units to adapt the units to the sheet. 

To set the hatch pattern start point: 
6 Specify a pattern start point.

Current drawing origin: Keeps the current hatch origin (default).
User-defined location: Click the Specify coordinates icon to specify a point in the 
graphics area or select a location from the Use Boundary list. 
To save the specified location, click Set as default. 

To set boundaries for hatch patterns: 
1 Select a method to specify boundaries.

Specify entities: Lets you select the entities that form the boundary.
Specify points: Lets you click points in enclosed areas to define the boundaries.
Rebuild boundary: Replaces a boundary after removing (enabled only when using the 
EditHatch command).
Delete boundary entities: Removes boundaries from the set of entities that form the 
boundaries.
Highlight boundary entities: Displays the boundaries in the drawing. 

2 To further customize hatch pattern options:
 Select Keep hatch and boundary related to update hatch patterns automatically if 

the boundary of the hatch changes (default). 
 Select Create hatch for each boundary to generate distinct hatches with the same 

properties if you are adding boundaries of several areas at once. Do not enable this 
option if one connected hatch is required. 

 Use properties of a selected hatch by clicking the icon and specifying a hatch in the 
drawing. 

 Select a placement for hatches in relation to their boundaries. Select Bring to Front, 
Send to Back, Bring in Front of Boundary, Send Behind Boundary (default) or Do 
Not Assign.

3 Click Additional Options to apply any of the following: 
 Click Find internal regions to detect internal closed boundaries. 
 Click a hatch Display style.
Out: Creates hatch patterns only in the outermost areas.
In/Out: Creates hatch pattern between alternate areas, starting with the outermost area 
(default).
Ignore: Ignores the internal structure and hatches the entire area. Hatch lines pass 
through text, block attributes and 2D solids.
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The following diagram illustrates the In/Out, Out and Ignore styles.

 Select a default Origin setting.
Use current: Uses the origin point for the hatching specified with the current Hatch 
command.
Use source: Uses the origin of existing hatches. 
 Specify a maximum gap size. 
 Select from the boundary group list. 
 Click Keep boundaries to maintain the initial closed contour normally deleted when 

a hatch is created. From the Type list, select whether the boundary contour is 
created as PolyLine or Region.

･ Boundary hatch will fill only closed objects.
･ Use a hatch scale makes sense for the drawing.  If the drawing area is 12x9, 
then a hatch scale of 1 makes sense.  If the drawing area is 120 x 90, then a 
hatch scale of 10 might be more reasonable.

･ Do not explode hatch patterns.  This will produce hundreds, sometimes even 
thousands, of separate lines.

･ A hatch pattern that is moved from its boundary will no longer be associated 
with that boundary.

･ Hatch boundaries can be deleted.
･ Hatch patterns placed in several locations at once will be connected.  Deleting 
one hatch pattern will delete them all.
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Command Exercise ­ Hatch
Estimated time to completion: 5 minutes

Drawing Name: hatch1.dwg

Scope:

Place Hatch patterns in the object as indicated. Use the Specify points option for the 
boundary.
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Command Exercise ­ Hatch
Estimated time to completion: 5 minutes

Drawing Name: hatch2.dwg

Scope:

Place Hatch patterns in the objects. Use the properties from the existing Hatch pattern. 
Use the Specify entities option to select the boundary.
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Command Exercise ­ Edit Hatch
Estimated time to completion: 5 minutes

Drawing Name: ehatch1.dwg

Scope:

Edit the Hatch patterns as indicated.
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Pattern

Command Access

Command Overview
Use the Pattern command to create copies of specified entities in a linear matrix or 
circular pattern. The created entities inherit all properties of the original entities such as 
Layers, LineColors, LineStyles and LineWeights.

General Procedure
To create a linear pattern: 

1 Click the Pattern icon  on the Modify toolbar. 
2 In the dialog box, click Select entities, select the entities to generate the pattern, and 

press <>to complete the selection.
The dialog box disappears until your selection is complete. 

3 Under Pattern type, select Linear. 
4 Under Settings: 

 For Horizontal axis and Vertical axis, type the number of elements. 
 For Spacing between elements on, define spacings between the elements and an 

angle for the pattern. 
Horizontal axis: Specifies the distance between columns. Click the Select column 
offset icon  to identify the offset using two points in the drawing. If the column offset 
is a negative value, columns are added to the left. 
Vertical axis: Specifies the distance between rows. Click the Select row offset icon 

to identify the offset using two points in the drawing. If the row offset is a negative 
value, rows are added downward. 
Pattern angle: Specifies the angle to control how the copies are arranged. Click the 
Select angle icon to specify the angle using the pointer. 

5 Click OK. 

Toolbar Menu Modify / Pattern
Pull-Down Menu Modify>Pattern...
Command Pattern
Alias PAT
Dialog Box Pattern
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To create a circular pattern: 

1 Click the Pattern icon  on the Modify Toolbar. 
2 In the dialog box, click Select entities, select the entities to generate the pattern, and 

press<>to complete the selection.
The dialog box disappears until your selection is complete. 

3 Under Pattern type, select Circular. 
4 Under Settings, set as follows: 

Base pattern on 
Angle between if required. Angle between is the included angle between the base 
points of the pattern entities and the center of the pattern. Type a positive value or click 
Pick Angle between items. 
Fill angle if required. Type a positive or negative value or click Pick Angle To Fill. The 
default for the angle to fill is 360 a full circle pattern. A value of zero is not allowed. The 
pattern is drawn counterclockwise for positive angles and clockwise for negative angles. 

Total number if required. The number of items includes the original entity. 

5 Under Element base point, set the following: 
Use last entity selected: Uses the base point from the last item you selected. 
X and Y: Type values or click Pick Base Point. 

6 Under Axis point, for X and Y, type values for the center point of the pattern or click 
Pick Center Point. 

7 Select Orient elements about axis to rotate the entities as they are patterned, 
otherwise they maintain the alignment of the source entity. 

8 Click OK. 

･ For a rectangular pattern, a negative distance between columns will create a 
pattern in a negative direction (right to left).  A negative distance between 
rows will produce a pattern in the negative Y direction (below one another).

･ For a circular pattern, a negative angle will create a pattern in a counter-
clockwise direction.

･ For a rectangular pattern, one row or one column will make a pattern in one 
direction only.

･ The InsertBlockN command will insert blocks in rows and columns.  
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Command Exercise - Rectangular Pattern
Estimated time to completion: 5 minutes

Drawing Name: pattern1.dwg

Scope:

Create a 3 x 2 Rectangular Pattern of the entity using a spacing of 1.5.
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Command Exercise - Circular Pattern.
Estimated time to completion: 5 minutes

Drawing Name: pattern2.dwg

Scope:

Make a Circular Pattern of the hex head as indicated on the drawing. The number of 
items is 8 (total).
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Stretch

Command Access

Command Overview
Learning how to use the Stretch command is tricky at first. Always use a crossing 
window or crossing polygon to select the entities to be stretched. The endpoints or 
vertices of the entities selected will be stretched, or moved to a new location, while the 
endpoints of vertices outside of the selection window will remain anchored. Once the 
entities are selected, press <> and pick a base point, then with Ortho On, drag the 
entities to the desired destination.

General Procedure

1 Click the Stretch icon  on the Modify toolbar.
2 Select the entities by using a crossing window (right to left), or a crossing polygon.  

Frame the object so that the endpoints to be moved are completely within the selection 
box.

3 Pick a base point.
4 Select the second point of displacement, or drag the cursor in the desired direction (with 

Ortho On), and type in the distance.

Toolbar Menu Modify / Stretch
Pull-Down Menu Modify>Stretch
Command Stretch
Alias S
Dialog Box

･ Circles cannot be stretched with this command, but can be stretched using 
grips.

･ Entities that are completely within the selection window will be moved.
･ If a crossing window is not used, only the entities completely within the 
window will be moved, not stretched.

･ Blocks cannot be stretched.
･ When selecting the second point of displacement, use the direct distance 
method with Ortho On.  Drag the cursor in the desired direction and type the 
distance.

･ When selecting points (base point or second point of displacement), picking 
points with or without EntitySnap, Relative Coordinates or Polar Coordinates 
are all acceptable methods.  However, the direct distance with Ortho On 
works the best.
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Command Exercise - Stretch
Estimated time to completion: 5 minutes

Drawing Name: stretch 1.dwg

Scope:

Use the crossing window to select the entities to Stretch.

･ Notice that the line segments that are fully constrained in the crossing 
selection window are moved.  The lines that are crossed are stretched.
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Change Length

Command Access

Command Overview
Use the Change Length command to find the current length on an entity or to increase 
or decrease the length of the selected entity. Type the capitalized letter(s) to initiate the 
command line options.

General Procedure
1 Invoke the Change Length command by selecting Modify>Change Length from the 

pull-down menu.
2 Type the letter of the command line option and type the desired length as requested.

 Select the entity towards the end to be lengthened or shortened.

Toolbar Menu
Pull-Down Menu Modify>Change Length
Command EditLength
Alias EDLEN
Dialog Box

･ The Change Length command is the only way to dynamically stretch a line 
without changing the angle of the line.

･ It is not possible to edit the length of a closed object.
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Command Exercise - Change Length
Estimated time to completion: 5 minutes

Drawing Name: length1.dwg

Scope:

Use the Dynamic, Increment, Percent and Total options to edit the length of the line 
and arc.
Use the following sequence to complete this exercise:

1 Click Modify>Change Length from the pull-down menu.
2 Pick the line with the LMB. (Note the active length is displayed in the command 

window.)
3 Pick the arc with the LMB. (Note the Active length and included angle are displayed in 

the command window.)
4 Right-click in the graphics window and select increment
5 Enter a value of 2 and press <>.
6 Pick each end of the line.  Notice how it increases by 50 mm each time.
7 Press <> to exit the command.
8 Type U and <> to Undo the last edit.
9 Invoke the Edit Length command again.
10 Right-click in the drawing window and select Percent.
11 Type 50 and <>.
12 Pick the line with the LMB.  Notice how the length of the line is 50 percent of the 

original each time.
13 Select the arc with the LMB.  Notice how the length of the arc changes by 50 percent 

each time you select it.
14 Press <> to exit the command.
15 Type U and <> to Undo the last edit.
16 Invoke the Edit Length command again.
17 Right-click in the drawing window and select Total.
18 Type 7 and press <>.
19 Pick the line.  Notice how the length of the line changes.
20 Pick the line again.  Notice how the line does not change this time.
21 Pick the arc.  Notice how the length of the arc changes.
22 Pick the arc again.  Notice how the length of the arc does not change.
23 Press <> to exit the command.
24 Type U and <> to Undo the last edit.
25 Invoke the Edit Length command again.
26 Right-click in the graphics window and select Dynamic.
27 Pick the line with the LMB and move the cursor. 
28 Press the LMB to continue.
29 Pick the arc with the LMB and move the cursor.
30 Press the LMB to continue.
31 Press <> to exit the command.
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Split

Command Access

Command Overview
Split a line, circle, arc or polyline by selecting two points on that entity. This will leave a 
gap, or opening, between the two points selected.

General Procedure
Simple Split:

1 Click the Split icon  on the Modify toolbar, (Select the entity at the first split point.)
2 Select the second split point.

To Split an entity at an intersection:

1 Select the Split icon  on the Modify Toolbar
2 Select the entity to split.
3 Type F for First split point.
4 Use the Intersection EntitySnap and pick an intersection.
5 For the second split point, pick another position on the line.

Toolbar Menu Modify / Split
Pull-Down Menu Modify>Split 
Command Split
Alias BR
Dialog Box

･ Circles will split in a counterclockwise direction unless the Drawing Units 
Angle option is set to clockwise.
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Command Exercise - Split
Estimated time to completion: 5 minutes

Drawing Name: split1.dwg

Scope:

Split the lines as indicated.

･ The location where you select the entity is the first split point.  You can use 
EntitySnaps when selecting points.  You may also use relative coordinates to 
break a specific distance.  Example: @1<0 will take a one-unit segment out of a 
horizontal line relative to the last point picked.
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Fillet

Command Access

Command Overview
Radius corners with the Fillet command. Clean up corners with a Fillet radius set to 0.

General Procedure

1 Click the Fillet icon  on the Modify toolbar.
2 To change the default radius, type R and <>.
3 Type the desired radius and press <>.
4 Select the first entity, and then select the second entity.

Toolbar Menu Modify / Fillet
Pull-Down Menu Modify>Fillet
Command Fillet
Alias F
Dialog Box

･ It is not necessary to set the radius to fillet parallel lines.
･ Fillet will not work if the lines or arcs are separate polylines, or at the arc 
intersections of polylines.  However, Fillet will work if the first line selected is 
a polyline and the second line or arc selected is not a polyline.  The second 
entity will be filleted and be joined to the polyline.
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Command Exercise - Fillet
Estimated time to completion: 5 minutes

Drawing Name: fillet1.dwg

Scope:

Use the Fillet command with a radius of 0 to clean up the corners of the lines as 
indicated. Remember to change the fillet radius first.

･ Select the lines towards the end that you want to fillet.  Remember to repeat 
the command with the RMB.
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Command Exercise - Fillet
Estimated time to completion: 5 minutes

Drawing Name: fillet2.dwg

Scope:

Fillet the corners of the object with a filler radius of 0.5.

･ Notice you cannot select all of the segments in one step.  You must repeat the 
fFllet command for each corner, unless the entity is a polyline and the Fillet 
command is used with the polyline option.  Try it on a rectangle.
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Chamfer

Command Access

Command Overview
Chamfer adjacent lines. Set the Chamfer Distance or Chamfer Angle. Select the 
adjacent lines to chamfer or select the polyline.

General Procedure

1 Click the Chamfer icon  on the Modify toolbar.
2 Type D for the Distance option (and <>). 
3 Type the first chamfer distance (and <>), then the second chamfer distance (and <>).
4 Select the first entity, then the second entity.

Toolbar Menu Modify / Chamfer
Pull-Down Menu Modify>Chamfer
Command Chamfer
Alias CHA
Dialog Box

Chamfer will not work if the lines are separate polylines
Chamfer will work if the first line selected is a polyline, but the secondlLine is 
not. The second entity will chamfer and be joined to the first polyline.

Chamfer with a distance of 0 will clean up corners.

･ Chamfer will not work if the lines are separate polylines.
･ Chamfer will work if the first line selected is a polyline, but the second line is 
not. The second entity will chamfer and be joined to the first polyline.

･ Chamfer with a distance of 0 will clean up corners.
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Command Exercise - Chamfer
Estimated time to completion: 5 minutes

Drawing Name: cham1.dwg

Scope: 

Chamfer the corners of the entities as indicated in the drawing.
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EntityGrips

Command Access

Command Overview
EntityGrips (EGrips) are selectable handles (displayed as small squares) at the end 
points, center, vertices, insertion points and other geometric points of entities.
The location of EntityGrips depends on the entity. For example, a circle displays an 
EntityGrip at the center and four EntityGrips on the circumference. 
EntityGrips are not accessible on drawing entities on locked Layers.
You use EntityGrips to drag defining points of entities to new positions (stretching), or to 
move or copy entire entities.

General Procedure
To use EntityGrips: 

1 With the command line blank, click the drawing entities you want to modify.
2 Stretch the entity by moving the activated EGrip to another location and click on the 

drawing.
For EGrip edit mode, you can make these settings: 
Base point: Specifies a base point other than the highlighted base EGrip. 
Copy: Leaves the specified entity at its current location as you modify a copy. 
Undo: Cancels the previous EGrip editing action as long as one or more EGrips are 
highlighted. 
Exit: Terminates EGrip editing. Highlighted modification EGrips disappear, but selection 
EGrips still display. 

3 To clear EGrips from the specified entity or set of entities, press Esc. 

To stretch multiple entities using EntityGrips: 
1 Hold down Shift and click several EGrips to highlight them. 
2 Release Shift. 
3 Specify one EGrip as the base grip. 
4 Move the base grip to another location and click on the drawing. 

Toolbar Menu
Pull-Down Menu
Command Select entity with command line blank
Alias
Dialog Box
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To set EntityGrip preferences: 
1 Click Tools>Options (or type Options). 
2 In the Options dialog box, click User Preferences. 
3 Expand Drafting Options>Entity Selection. 
4 Expand EGrips Options to do the follwing: 

 Enable EntityGrips (EGrips) 
 Enable EGrips in Blocks 
 Enable EGrip tips 
 Set the EGrip display limit (the maximum number of entities displayed with EGrips) 

5 Expand EGrips Colors to set colors for these items: 
 Active EGrips 
 Inactive EGrips 
 Mouseover EGrips (the color of the EGrip when the pointer moves over an EGrip) 

6 Expand EGrips Size to set the display size of EntityGrips. 
7 Click OK. 

･When an entity has been selected and the Egrips are highlighted, press Esc to 
exit Egrips.

･ Pressing the Shift key while picking a selected entity will deselect that entity, 
but keep the Egrips active.

･ Active Egrips can be used as snap or base points.
･ Pressing <> with no Egrips selected will recycle the previous command.
･ Stretch is the default group option.
･ Use a quadrant grip to make a circle larger or smaller.
･ Use Egrips to adjust Dimensions and the Width of a Note.
･ A selected Egrip will appear solid in color (the default color is red).  Only one 
Egrip may be selected at a time.
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Command Exercise - Egrips
Estimated time to completion: 5 minutes

Drawing Name: egrip1.dwg

Scope:

Edit entities as indicated using Egrips (command line must be blank).  Stretch and Copy 
the circles.  Move and Copy the lines.
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Command Exercise - Egrips
Estimated time to completion: 5 minutes

Drawing Name: egrip2.dwg

Scope:

Use Egrips to stretch the polyline vertices to the nearest points.
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Egrip Settings

Command Access

Command Overview
Egrips must be enabled in order to work. Use the Entity Selection to control Egrip 
settings. The default setting when starting a new drawing is that Egrips are already 
enabled. When Enable Egrips in Blocks is selected, all of the relevant EGrips within a 
selected block will be, rather than a single insertion point. Unselected and selected EGrip 
colors can be changed by picking a new color from the drop-down list. The EGrip size 
may also be selected by sliding the box to the left or right to make it smaller or larger.

General Procedure
1 Click Tools>Options>User Preferences>Drafting Options>Entity Selection
2 Choose the desired setting to be changed (EGrip options, EGrip color or EGrip size).

Toolbar Menu
Pull-Down Menu Options>User Preferences>Drafting Options>Entity Selection
Command
Alias
Dialog Box Options

･ EGrips must be enabled to format note paragraphs and adjust dimensions.
･Using EGrips should be relatively easy once the individual Modify commands 
have been learned.
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Section 7 Review Questions
1 Identify the following icons by writing the name of the command and the toolbar where 

it can be found.

2 In what pull-down menu can you access the EGrips dialog (for enabling or disabling 
EGrips)?

3 In what pull-down menu can you access the Point Format dialog to change the Point 
Format?

4
a. What does the Clean command do?

b. In what pull-down menu can you access the Clean command?

c. What can you type to invoke the Clean command?

Icon Command Toolbar

a.

b.

c.

d.

e.

f.

g.

h

i
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Section 8
View Commands

Estimated Class Time: 1 hour

Objectives
This section will cover the different ways to view drawings. Learn to Pan and Zoom in 
real time, and use other zoom options. Views can be named and saved, then restored. 
The drawing window can be sectioned into multiple viewports.
 Dynamic Pan
Pan the drawing with the motion of the cursor in real time.
 Dynamic Zoom
Zoom the drawing with the up and down motion of the cursor in real time.
 Zoom Window
Make a zoom window around an area to view up close.
 Zoom Options
Additional zoom options are located in the fly-out on the Standard Toolbar.
 Rebuild
Regenerate the drawing to smooth out circles and arcs.
 Named Views
Name and Save the drawing views and make them current when needed.
 Multiple Viewports
Display different views of the drawing in multiple viewports.
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Dynamic Pan

Command Access

Command Overview
With the Dynamic Pan command, pick a point in the drawing window, press the LMB 
and drag the drawing view in real time.  Right-click (RMB) to access the Shortcut menu 
and select Exit, or one of the other options. The Esc key will also exit the Dynamic Pan 
command.

General Procedure

1 Click the Dynamic Pan icon  on the Standard Toolbar.
2 Pick a point in the drawing window (LMB), press and drag to pan the view.
3 Right-click (RMB) to access the Shortcut menu and click Exit.

Toolbar Menu Standard / Dynamic Pan
Pull-Down Menu View>Pan>Dynamic Pan
Command Pan
Alias P
Dialog Box

･ The Shortcut menus for Dynamic Pan and Dynamic Zoom are identical.
･ When dragging the cursor in Dynamic Pan, the mouse can be picked up and 
relocated in the drawing window, if the cursor reaches the edge of the 
drawing window.
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Dynamic Zoom

Command Access

Command Overview
With the Dynamic Zoom command, pick a point in the drawing window. Drag the 
mouse up or down to zoom in or out. Right-click (RMB) to access the Shortcut menu and 
select Exit or one of the other options. The Esc key will also exit the Dynamic Zoom 
command.

General Procedure

1 Click the Dynamic Zoom icon  on the Standard Toolbar.
2 Pick a point in the drawing window (LMB), press and drag up to zoom in and down to 

zoom out.
3 Right-click (RMB) to access the Shortcut menu and select Exit or one of the other 

options.

Toolbar Menu Standard / Dynamic Zoom
Pull-Down Menu View>Zoom>Dynamic
Command
Alias
Dialog Box

･ Remember to drag up to zoom in and down to zoom out.
･When you drag the cursorin Dynamic Zoom, the mouse can be picked up and 
relocated in the drawing window if the cursor reaches the top or bottom of 
the drawing window.
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Zoom Window

Command Access

Command Overview
Use the Zoom Window command to view a selected area of the drawing.

General Procedure
1 Click View>Zoom from the pull-down menu.
2 Pick the first corner of the view window, then drag the mouse and pick the opposite 

corner.

Toolbar Menu Zoom / Zoom Window
Pull-Down Menu View>Zoom>Window
Command Zoom
Alias Z
Dialog Box

･ When the Zoom Window command is invoked, the opposite corner of the 
window must be made or press Esc to cancel the Zoom command.

･When invoking the Zoom Window command, the Window option is a default. 
Just begin the first corner of the zoom window.

･ Zoom commands can be used while in the middle of other commands.
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Zoom Previous

Command Access

Command Overview
The Zoom Previous command displays the previous view.

General Procedure

1 Click the Zoom Previous icon  on the Standard Toolbar.  

Toolbar Menu Standard / Zoom Previous
Pull-Down Menu View>Zoom>Previous
Command
Alias
Dialog Box

･ Zoom Previous can be accessed from the Zoom command by typing P and 
pressing <>.
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Zoom Options

Command Access

Command Overview
Other Zoom options are available within the Zoom command. These can be accessed 
from the fly-out button on the View pull-down menu. These options are also available by 
typing the capitalized letter of the desired option after invoking the Zoom command.

General Procedure
1 Click the Zoom command options from the View pull-down menu.
2 If typing Z, press <>, then type the capitalized letter of the desired option and press 

<>.

Toolbar Menu Zoom
Pull-Down Menu View>Zoom>Options
Command Zoom
Alias Z
Dialog Box

･ The most important Zoom options are Window, Bounds and Fit.
･ Zoom Bounds or Fit occasionally to be sure bits of the drawing have not 
gotten thrown out into space. 
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Command Exercise ­ Dynamic Zoom and Pan
Estimated time to completion: 10 minutes;

Drawing Name: pan1.dwg

Scope:

Zoom and Pan the drawing dynamically. Use the RMB to switch between some basic 
zoom modes.
Follow these steps for this exercise:

1 Click the Dynamic Zoom  icon on the Standard Toolbar.
2 Pick a point in the middle of the drawing window.  Hold the LMB down and drag the 

mouse up and down.  Notice how you zoom in as you move the mouse up, and zoom out 
as you move the mouse down.

3 Hold the LMB down and drag the cursor to the top of the screen.  Let go of the LMB and 
move the cursor to the middle of the screen.  Hold the LMB down and drag the mouse to 
the top of the screen.  This allows you to continue zooming in.  Repeat the process but 
zoom out by dragging the mouse down instead.

4 Press the <> or Esc key to end the command.

5 Click the Dynamic Pan icon  on the Standard Toolbar.
6 Select a location in the middle of the screen and hold down the LMB and drag your 

mouse up, down, right and left.  Notice how the drawing pans as you move the mouse.  
Let go of the LMB and reposition the mouse and repeat the steps above to continue 
panning in one direction.

7 Press the RMB and select Zoom from the Shortcut menu.  Zoom in and out by holding 
the LMB down and dragging the mouse up and down.

8 Press the RMB and switch back to Pan.  Pan through the drawing.
9 Press the RMB and switch to Zoom Window from the Shortcut menu.  You will create a 

window with your mouse that will represent the area to zoom in on.  Position your 
mouse to create a rectangular window.  Hold your LMB down and drag the mouse 
diagonally to create a window.  Release the LMB to finish the command and zoom in on 
the drawing.  Notice that this method is a drag and release, and works differently 
fromthen the regular Zoom Window command.

･ The Microsoft IntelliMouse offers many user-friendly viewing options that 
are automatically invoked by using the wheel on the IntelliMouse.  

･ It is recommendedthat you use a Microsoft IntelliMouse when using 
DraftSight.
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Rebuild

Command Access

Command Overview

The Rebuild command is used to smooth out circles or arcs in the drawing.  Rebuild All 
is used when there are multiple viewports in the drawing. Refresh recalculates the 
mathematics of the drawing and although it takes longer, it is a more thorough 
command.

General Procedure
1 Select Rebuild from the View pull-down menu.

Toolbar Menu
Pull-Down Menu View>Rebuild
Command Rebuild
Alias RE
Dialog Box

･ Sometimes Rebuild will happen automatically, as with certain Zoom 
commands.

･Rebuild can be use frequently.  It recalculates the mathematics of the drawing 
and displays the objects with greater accuracy.
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Command Exercise ­ Zoom and Rebuild
Estimated time to completions: 10 minutes

Drawing Name:  zoom1.dwg

Scope:

Zoom this drawing out several times, then use the Zoom Window option and pick just 
inside the corners of the red rectangle.  Rebuild to see the arcs and circles smooth out.
Follow these steps for this exercise:

1 Click the Dynamic Zoom icon  on the Standard toolbar.
2 Press the LMB in the middle of the drawing and drag down to zoom out the drawing.
3 Press <> to end the command.
4 Click View>Rebuild from the pull-down menu.
5 Click View>Zoom>Window from the Pull-down menu. 
6 Create a window with your mouse that will represent the area to be zoomed in on.  

Position your cursor inside a corner of the red box and click (LMB).  Move the mouse 
diagonally to another corner of the box and click (LMB) again.  Notice how the arcs and 
circles are represented by small straight segments.

7 Click View>Rebuild from the pull-down menu.

･ From the View>Zoom pull-down menu, experiment with the different Zoom 
options available.  Which method of viewing your drawing is the easiest?

･ You can invoke the Zoom Window command directly by typing Z<> and 
specifying the opposite corners of the zoom window (the Window option is 
the default).  You can also access the command from the 
View>Zoom>Window Pull-down menu.
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Named Views

Command Access

Command Overview
Views can be saved and restored with the Named Views command. This will save the 
time it takes to zoom out and in to a frequently selected view. This tutorial will focus on 
the New option of the Views dialog box.   New views can be named as the current view 
display or defined by a new view (specify later). Named views from the list can be 
selected and set as the current view.

General Procedure
1 Click View>Named Views from the pull-down menu. 
2 Click New. 
3 In the View dialog box: 

In Name: Type a View Name. 

In Class: Type a New Class Name or select a class. Or, you can leave Class set to <None>. 

Under Boundaries: set options: 
 As displayed: Uses the boundaries of the current display. 
 Specify later: Allows you to define a windowed area of the current view. Click 

Specify later and define a rectangular area in the graphics area, then press . 
4 Click OK twice.
5 Named Views can now be selected from the list and Set as current.
6 To delete a named view, select it, then click Delete.

Toolbar Menu
Pull-Down Menu View>Named Views...
Command Views
Alias V
Dialog Box Views

･ Named views are saved with the drawing file.
･ Certain characters are not allowed for the view name.
･ Remember to select As displayed or Specify later for the new named view.
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Command Exercise - Named View
Estimated time to completion: 5 minutes

Drawing Name: nview1.dwg

Scope:

Zoom the specified area. With the Named Views command, name the view VIEW 1 and 
save it. Zoom Fit, and then restore the named view.
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Multiple ViewTiles

Command Access

Command Overview
The Model View of the drawing can be divided into Multiple ViewTiles. Each ViewTile 
can display a different part of the drawing, however, only one ViewTile may be active. 
ViewTile configurations, including the views within ViewTile, can be selected to be 
current later in the drawing.

General Procedure
To create one, two or three ViewTiles:

1 Click View>View Tiles from the pull-down menu and select the desired number of 
viewports (select 1, 2, 3 or 4).

2 Follow the command line prompts. For 3 viewports, Right is the default location for the 
largest viewport.

To create ViewTiles using the View Tiles dialog box:
1 Click View>View Tiles>View Tiles Manager from the pull-down menu.
2 Select Type: New.
3 Select the desired ViewTile configuration from the list.
4 Click OK.

To use Multiple ViewTiles:
1 Click in a ViewTile to make it active.
2 Begin constructing geometry in the ViewTile. 
3 To draw between ViewTiles, click on one ViewTile and pick a point, then click in another 

ViewTile to continue to draw the entity.

Toolbar Menu View Tiles>ViewTiles
Pull-Down Menu View>View Tiles>Options
Command ViewTiles
Alias VPORTS
Dialog Box View Tiles
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To save a ViewTile configuration:
1 Click View>View Tiles>View Tile Manager from the Pull-down menu.
2 Select Type: New.
3 Input the ViewTile Name in the save box.
4 Click the Save button.
5 This name will appear in the list when the Named View button is selected.

･ An active ViewTile is the one with the dark border around it.  The cursor 
crosshairs will also be visible in the active ViewTile.

･ Named ViewTile configurations will be saved with the drawing.
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Command Exercise - Multiple ViewTiles
Estimated time to completion: 10 minutes

Drawing Name: vtile1.dwg

Scope:

Create four ViewTiles. Restore a named view in each ViewTile.  Save the ViewTile 
configuration as V1.  Join two adjacent views and save this as V2.  Change to a single 
ViewTile.  Restore a saved ViewTile configuration.
Follow these steps for this exercise:

1 Click View>View Tile>4 Tiles from the pull-down menu.
2 Notice how the drawing window is divided into fourViewPorts.  The same view is 

displayed in all four ViewPorts.  We will now restore different Named Views in each 
ViewPort.

3 Move your cursor to the upper left ViewPort and activate it by clicking inside it (LMB).
4 Click View>Named Views from the pull-down menu.
5 In the Views dialog box, double-click on Block to set it current for the ViewPort.
6 Click OK.
7 Repeat the process for the other ViewPorts by selecting other named views for each.
8 Once you have created the layout, save the configuration. 
9 Select View>View Tiles>View Tile Manager from the pull-down menu.
10 Click on New, and input V1 into the Save box.
11 Click Save.
12 Join the two ViewPorts on the right side of the drawing window.
13 Select View>View Tiles>Join from the pull-down menu.
14 Click the Dominant Tiled View and press <>.
15 Click the ViewTile to Join and press <>. 
16 Save this layout as V2.
17 Switch to a single ViewTile by selecting View>View Tiles>Single View Tile from the 

pull-down menu.

･ Use your RMB to activate a pop-up dialog box that will allow you to delete or 
rename your ViewTile configurations in the View Tiles dialog box.
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Section 8 Exercise - Viewing Drawings
Estimated time to completion: 15 minutes

Drawing Name: section 8 mcad.dwg

Scope:

Use the commands you have learned in this section to view the drawing. Determine 
which viewing commands are easier for you to use. Locate information on the drawing 
and fill out the table below. Follow the instructions on the drawing for creating a named 
view and ViewTile layout.

Note 1:

Note 2:

Note 3:

Note 4:
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Note 5:

Note 6:

Note 7:

･ Choose a Zoom command you feel comfortable with.  Zoom Window and 
Zoom Previous are very common commands.
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Section 8 Exercise - View Commands
Estimated time to completion: 15 minutes

Drawing Name: section 8 aec.dwg.

Scope:

Using the commands learned in this section, Zoom and Pan around the drawing. 
Examine the named views in the drawing and create Named Views for the Herb Garden, 
Overflowing Pot Water Feature and the Lawn. View the drawing with multiple 
ViewTiles.

･ Use different Zoom options to become familiar with all of them.
･ Zoom in on the Herb Garden and create a named view of it.  Do the same for 
the Overflowing Pot Water Feature and the Lawn.

･ Use the ViewTiles command to bring up multiple ViewTiles and show a 
different room in each ViewTile.
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Section 8 Review Questions
1 Identify the following icons by writing the command and the toolbars where they can be 

found.

2 What is the difference between Zoom Fit and Zoom Bounds?

3 What is the difference between Rebuild and Refresh?

4 How do you make a ViewTile active?  How can you tell that a ViewTile is active?

5 How many ViewTiles can be active at the same time?
___ 1
___ 2
___ 3
___ As many as the user decides

6 When restoring ViewTile configuration, does DraftSight Refresh the drawing? Try it.

Icon Command Toolbar

a.

b.

c.

d.

e.

f.
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Section 9
Text and Dimensions

Estimated Class Time: 3 hours

Objectives
This section will cover how to use Text and Dimensions. Learn to type Text in either 
single or multiple lines, edit Text and check your spelling errors. Create text Styles 
choosing from a variety of fonts. Dimensioning a drawing is easy. If placed correctly, the 
dimensions will be as accurate as the drawing. Learn to create Dimension Styles to suit 
the drawing specifications. Dimension in either English, metric or both. Edit selected 
dimensions or make changes to the Dimension Style for global update.
 Simple Note
Type a single line of text for Simple Notes.
 Note
Use the multiline text editor to create paragraphs of text or sentences that can be 
stretched into wider or narrower paragraphs using Grips.
 Text Style
Create several Text Styles for specific text requirements.
 Edit Text
Use the Edit Text command to change the content of Simple Note or Notes. Use the 
Properties command to change other features of the text in the drawing.
 Find and Replace
Use the Find and Replace to search and change text in the drawing.
 Spell Check
Use the Spell command to check for spelling errors.
 Dimensions
Place dimensions using a variety of Dimension standards.
 Dimension Style
Create Dimension Styles based on DraftSight's standard style.
 Edit Dimension Location
Use EGrips to edit the placement of dimensions.
 Edit Dimension Properties
Edit dimensions globally with the dimension style or individually with the properties 
command.
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Simple Note

Command Access

Command Overview
With the SimpleNote command, you can create Text lines of any position, justification, 
orientation, height and TextStyle using the Text dialog box.

General Procedure

1 Click the SimpleNote icon  on the Draw toolbar.
2 In the Text dialog box, type the lines of text you want to add to your drawing. 
3 Under Insertion point, type coordinate values for X, Y and Z, or click Select in 

graphics area to specify the location after closing the dialog box. 
4 Under Insertion orientation, set the position and alignment of the text lines in relation 

to the insertion point. 
5 Under Options, set these: 

 Font 
 Angle of insertion 
 Height (text size) 

6 Click OK.

Toolbar Menu Draw / SimpleNote
Pull-Down Menu Draw>Text>SimpleNote
Command SimpleNote
Alias SNOTE
Dialog Box

･ Remember to use the <> key on the keyboard.
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Command Exercise ­ Simple Note
Estimated time to completion: 5 minutes

Drawing Name: text1.dwg

Scope:

Create two lines of text as indicated using the SimpleNote command.
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Command Exercise – Simple Note
Estimated time to completion: 5 minutes

Drawing Name: text2.dwg

Scope:

Recreate the SimpleNote Text. Use different methods of justifying the text. 
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Note

Command Access

Command Overview
Create paragraphs of text with the Note command. Define the area where the note 
should appear in the drawing, by picking opposite corners of the text box in the graphics 
window. Type your note in the Edit Note dialog box. Note text can be moved, rotated, 
scaled, copied or changed after it has been placed in the drawing. Use the EGrips to 
adjust the paragraph width and height. When you type in the text editor, the spacebar 
will create a space, and the <> key will act as a carriage return and bring the cursor to 
the next line. The cursor may be placed between letters by clicking once (LMB). A 
double click will select the entire word and a triple click will select the entire paragraph. 
The <> button on the mouse (RMB), when placed within the text editor dialog box, will 
invoke a shortcut menu with options to cut, copy and paste selected text. To resize the 
text editor, select a corner of the window with the LMB and drag. Begin the Note 
command, specify the first corner, then the opposite corner of the window. Type the text 
in the text editor, use the available options, then select OK to place the text in the 
drawing. The EditText command will open the same dialog box with the selected text for 
editing.

General Procedure

1 Click the Note icon  on the Draw toolbar.
2 Specify the text area by picking the first corner, then the opposite corner in the graphics 

window.
3 Type the text in the text editor dialog box.
4 Click OK to exit.

Toolbar Menu Draw / Note
Pull-Down Menu Draw>Text>Note
Command Note
Alias N
Dialog Box

･ In the Note text editor, single click (LMB) to insert words or letters.  Double-
click to highlight the entire word.  Triple-click to highlight the entire 
paragraph.

･ Pressing the <> button on the mouse (RMB), with the cursor in the text box, 
will bring up the cursor menu with windows edit options.

･ Type text using the spacebar (and not <>) to allow sentences to wrap.
･ After exiting the Note text dialog box, use EGrips to adjust the width and 
height of the note.

･ Documents to be imported into the test editor should be saved in text (.txt) or 
Rich Text Format (.rtf ).
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Command Exercise ­ Note
Estimated time to completion: 5 minutes

Drawing Name: notetext1.dwg

Scope:

Use the Note command to create the text as indicated.
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Command Exercise ­ Note
Estimated time to completion: 5 minutes

Drawing Name: notetext2.dwg

Scope:

Use the Note command to create the text as indicated.
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Text Style

Command Access

Command Overview
In addition to the Standard Text Style, other styles can be created. Text will be typed in 
the current text style, and may be changed from one style to another. Applying a 
different font to a text style will globally change the font of any text in the drawing that 
has been typed in that style. DraftSight supports most Windows fonts, including True-
Type fonts. Text Styles may be deleted or cleaned only if there is no text in the drawing 
referencing that style, or it is not the current style.

General Procedure
Making changes to the Standard Text Style:

1 Click Format>Text Style... from the pull-down menu.
2 Select a different Font from the drop-down list.
3 Select Apply, and then Close the dialog box.

Toolbar Menu Text / Text Style
Pull-Down Menu Format>Text Style
Command TextStyle
Alias STYLE
Dialog Box Options>Drafting Styles>Text

･ Use this dialog box to make a Text Style current.
･ Changes applied to a Text Style will globally affect any text in the drawing 
referencing that style.

･ Avoid having an excessive number of Text Styles.  Some common text styles 
might be made for notes, dimensions and the title block.

･ Refer to the following text height chart for large-format drawings.  For 
instance, if the drawing area is 12 x 9, a text height of .2 might be good.  
However, if the drawing area is 120 x 90, a text height of 2 would be more 
appropriate.
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Text Height Chart

This chart is for drawings using Architectural or Fractional Units. The text sizes are based on what 

would typically be the plotted scale.

Drawing Scale Scale Factor Plotted Scale Text Size in Drawing

1/16 inch = 1 foot 192 1/16 inch 12 inch

3/32 inch 18 inch

1/8 inch 24 inch

3/16 inch 36 inch

1/4 inch 48 inch

1/8 inch = 1 foot 96 1/16 inch 6 inch

3/32 inch 9 inch

1/8 inch 12 inch

3/16 inch 18 inch

1/4 inch 24 inch

3/16 inch = 1 foot 64 1/16 inch 4 inch

3/32 inch 6 inch

1/8 inch 8 inch

3/16 inch 12 inch

1/4 inch 16 inch

1/4 inch = 1 foot 48 1/16 inch 3 inch

3/32 inch 4.5 inch

1/8 inch 6 inch

3/16 inch 9 inch

1/4 inch 12 inch

3/8 inch = 1 foot 32 1/16 inch 2 inch

3/32 inch 3 inch
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3/8 inch = 1 foot 1/8 inch 4 inch

3/16 inch 6 inch

1/4 inch 8 inch

1/2 inch = 1 foot 24 1/16 inch 1.5 inch

3/32 inch 2.25 inch

1/8 inch 3 inch

3/16 inch 4.5 inch

1/4 inch 6 inch

3/4 inch = 1 foot 16 1/16 inch 1 inch

3/32 inch 1.5 inch

1/8 inch 2 inch

3/16 inch 3 inch

1/4 inch 4 inch

1 inch = 1 foot 12 1/16 inch 0.75 inch

3/32 inch 1.125 inch

1/8 inch 1.5 inch

3/16 inch 2.25 inch

1/4 inch 3 inch

1.5 inch = 1 foot 192 1/16 inch 0.5 inch

3/32 inch 0.75 inch

1/8 inch 1 inch

3/16 inch 1.5 inch

1/4 inch 2 inch

1 inch = 20 feet 240 1/16 inch 15 inch

3/32 inch 22.5 inch

Drawing Scale Scale Factor Plotted Scale Text Size in Drawing
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1 inch = 20 feet 1/8 inch 20 inch

3/16 inch 45 inch

1/4 inch 60 inch

1 inch = 30 feet 240 1/16 inch 22.5 inch

3/32 inch 33.75 inch

1/8 inch 45 inch

3/16 inch 67.5 inch

1/4 inch 90 inch

1 inch = 40 feet 480 1/16 inch 30 inch

3/32 inch 45 inch

1/8 inch 60 inch

3/16 inch 90 inch

1/4 inch 120 inch

1 inch = 50 feet 600 1/16 inch 37.5 inch

3/32 inch 56.25 inch

1/8 inch 75 inch

3/16 inch 112.5 inch

1/4 inch 150 inch

1 inch = 60 feet 720 1/16 inch 45 inch

3/32 inch 67.5 inch

1/8 inch 90 inch

3/16 inch 135 inch

1/4 inch 180 inch

Drawing Scale Scale Factor Plotted Scale Text Size in Drawing
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Command Exercise ­ Text Styles
Estimated time to completion: 5 minutes

Drawing Name: None (start from scratch)

Scope:

Create a TextStyle called TEXT1 and apply a text height of 0.4 and the font called Arial 
to that Style. Type the text as indicated in the new style.
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Command Exercise ­ Text Styles
Estimated time to completion: 5 minutes

Drawing Name: style1.dwg

Scope:

Use the Clean command to delete the text style TEXT 1, or delete it from the dialog box.
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Edit Annotation

Command Access

Command Overview
Use the EditAnnotation command to change the contents of the text in the drawing. For 
SimpleNote, this will display the Edit SimpleNote dialog box. Text may also be edited 
using the Properties command. This contains additional options to change text 
properties.

General Procedure
1 Click Modify>Entity>Annotation from the pull-down menu.
2 Select the text to edit.
3 Make corrections to the text by typing over the highlighted text, or place the cursor 

between letters or words and type.
4 Select OK to exit.

Toolbar Menu
Pull-Down Menu Modify>Entity>Annotation
Command EditAnnotation
Alias EDITTEXT
Dialog Box Edit Note

･ The EditAnnotation command works with Dimension, Note and Simple Note 
text.
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Command Exercise ­ Edit Text
Estimated time to completion: 5 minutes

Drawing Name: etext1.dwg

Scope:

Edit the SimpleNote and the Note text using the EditAnnotation command. Edit the 
text on the right to be like the text on the left.
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Command Exercise ­ Edit Text
Estimated time to completion: 5 minutes

Drawing Name: etext2.dwg

Scope:

Edit the SimpleNote and the Note text using the Properties command. 
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Command Exercise ­ Edit Text
Estimated time to completion: 5 minutes

Drawing Name: etext3.dwg

Scope:

Using EGrips, move and stretch the note text into the box.
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Command Exercise ­ Edit Text
Estimated time to completion: 5 minutes

Drawing Name: etext4.dwg

Scope:

Using the Properties command, change the Style of the text to TEXT2.
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Find and Replace

Command Access

Command Overview
The Find and Replace command provides text search with the options to perform a 
global search or to search selected text. Type the text string to find, and type the 
replacement text.

General Procedure
To find and replace text: 

1 Type Find at the command prompt.
The Find and Replace dialog box opens. 

2 In Find what, type the Text to find. 
3 In Search in, specify where to find the Text. You can browse these locations: 

 On the Active Sheet/Area 
 In the Entire drawing 
 In a specified Selection set (click Select in graphics area  to specify the entities to 

form a selection set) 
4 In Replace with, type the Text to replace the search string. Leave Replace with empty 

if you want to find Text but not replace it. 
5 Click Options to specify the entity types to include in the search and set search options. 

The Find and Replace Options dialog box opens. 
6 In Search for text in, select or clear BlockAttribute values, Dimensions, Notes and 

SimpleNotes, Hyperlink addresses, Hyperlink text and Tables. 
7 Specify whether to Match case and Find whole words only. 
8 In Search Results: 

 Click Find, then Find next, to search for the specified text. In the context area a text 
block or text line displays the corresponding content of the found text.

 Click Replace to replace all appearances of the found text.
 Click Replace All to replace all found text locations .
 Click Zoom to zoom to the current text location in the graphics area.

9 Click Close. 

Toolbar Menu
Pull-Down Menu
Command Find
Alias
Dialog Box Find and Replace
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Spell Check

Command Access

Command Overview
Check for spelling errors. Select one line of text or all of the text in the drawing. Add 
words to the custom dictionary.

General Procedure 
1 Type SpellCheck at the command prompt. 
2 In the graphics area, select the text entities to check and press Enter. 
3 The Spell Check dialog box appears if the software finds a spelling mistake: 

 Under Current word, the dialog box displays the word in doubt. 
 Under Context, the dialog box displays the text line or portion of the text line. 
 Under Suggestions, corrections are proposed. 

4 Possible actions: 
 Ignore the suggestion for the current appearance of the word in doubt. 
 Ignore All the suggestions for all appearances of the word in doubt. 
 Change the current word to the word you select in Suggestions. 
 Change All appearances of the misspelled words to the word you select in 

Suggestions. 
 Add the word in doubt to the dictionary. 
 Look Up a word to find synonyms. 
 Change Dictionary to specify another language for spell checking. 

5 Click Close. 

Toolbar Menu
Pull-Down Menu
Command SpellCheck
Alias SPELL
Dialog Box Spell Check

･Building a custom dictionary is useful when abbreviations are used frequently 
in the drawing.
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Command Exercise ­ Spell Check
Estimated time to completion: 5 minutes

Drawing Name: spell1.dwg

Scope:

Correct the spelling in the text provided.
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Dimensions

Command Access

Command Overview
Learn how to Dimension a drawing using the dimension variables. Dimensions will be as 
accurate as the drawing, provided the entities are chosen properly. To open the 
Dimension Toolbar, place the cursor icon over any icon that is in the graphics window 
and click the right mouse button (RMB). Select Toolbars... from the pop-up menu. Place 
a checkmark before Dimension, and click OK. This section will cover individual 
dimension commands, how to select the entity to dimension and pick the dimension 
location. The easiest way to adjust the dimension locations after they have been picked 
is to use the EGrips. Some Dimension commands, such as Ordinate Dimensions and 
Tolerance, will not be covered in this tutorial. Dimension Style and Edit Dimension 
commands and options will be covered in the next section.

Toolbar Menu
Pull-Down Menu Dimension>Option
Command
Alias
Dialog Box

Dimension Command Icon Overview

Linear Dimension This option is for horizontal or vertical dimensions. Use 
EntitySnaps to select the first and second extension line 
origin or press <enter> to select the entity. Drag the cursor 
and pick to place the dimension.

Aligned Dimension This option will align a dimension with an angled line. Use 
EntitySnaps to select the first and second extension line 
origin or press <Enter> to select the entity. Drag the cursor 
and pick to place the dimension.

Baseline Dimension This option builds a baseline dimension from the first 
extension line of a linear, aligned or angular dimension. 
Begin with the linear, aligned or angular dimension first, 
using EntitySnaps to select the origin points. Next invoke 
the Baseline Dimension command and select the next 
extension line origin. Continue, then press <Enter> to exit 
the command.
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Continue Dimension This option creates continuous dimensions from the second 
extension line of a linear, aligned or angular dimension. 
Begin with the linear, aligned or angular dimension first, 
using EntitySnaps to select the origin points. Next invoke 
the Continue Dimension command and select the next 
extension line origin. Continue, then press <Enter> to exit 
the command.

Ordinate Dimension The OrdinateDimension command creates ordinate point 
dimensions. The command displays an X or Y coordinate 
with a leader line to create X-datum or Y-datum 
dimensioning. The value of the X or Y coordinate is defined 
by the point you specify, called the feature location.

Center Mark Select a circle or arc to place a center mark in the drawing. 
Center Mark styles can be modified in the Dimension Styles 
dialog box.

Diameter Dimension Select a circle or arc for the diameter dimension. Drag the 
cursor and pick to place the dimension.

Radius Dimension Select a circle or arc for the radius dimension. Drag the 
cursor and pick to place the dimension.

Angular Dimension This option will place an angular dimension between two 
selected lines. Select two angular lines and pick to place the 
dimension.

Arc Length Dimension The ArcLengthDimension command creates an arc length 
dimension. It measures the distance along an arc or arc 
segment of a polyline. To differentiate arc length 
dimensions from linear or angular dimensions, an arc 
symbol is displayed with the dimension text. The arc symbol 
is displayed before or above the dimension text depending 
on the current dimension style.

Jogged The JoggedDimension command creates jogged radius 
dimensions for circles and arcs. Jogged dimension lines are 
typically used when a sheet is too small to display the true 
center point of radial dimensions. The command lets you 
specify another origin point for the dimension line. This 
point is called the center position override. The command 
measures the radius of the specified circle or arc and 
displays the dimension text with a preceding radius symbol.

Dimension Command Icon Overview
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General Procedure
For Linear Dimensions:

1 Select the Linear Dimension icon  on the Dimension toolbar
2 Use appropriate ESnaps to select the dimension's extension line origin points.  Drag the 

cursor and pick the location for the dimension. Note: To dimension a single line 
segment, press <>, and then select the line.

For Radius, Diameter or Center Mark commands:
1 Click the desired command.
2 Pick the circle or arc to dimension (on its circumference). Drag the cursor and pick the 

dimension location.  Note: Using Center Mark will simply place a center mark at the 
center of the arc.

Leader Use the Leader command to draw leader lines that connect 
annotations to a drawing entity. Leaders are useful when 
the dimension text or annotation does not fit next to the 
corresponding entity. You can optionally place single or 
multiple lines of text, a geometric tolerance, a block 
reference or a copy of another leader at the end point of the 
leader line. Draw leaders as straight line segments or spline 
curves. By default, the start point of a leader is an 
arrowhead you can customize.

Tolerance Use the Tolerance command to create and place datum 
indicators and basic dimension notations in the drawing.

Dimension Edit Use the EditDimension command to change the position, 
angle and value of dimension text. You can also change the 
orientation of the extension lines of dimensions.

Dimension Text Edit Use the EditDimensionText command to move or rotate 
dimension text for a single dimension. Use the 
EditDimension command to edit multiple dimensions.

Dimension Rebuild Use the RebuildDimension command to apply the active 
dimension style to specified dimensions. Note that the 
active DimensionStyle permanently overrides the 
DimensionStyle previously applied to the specified 
dimensions.

Dimension Style Use the DimensionStyle command to create and modify 
DimensionStyles. DimensionStyles control the way 
dimensions look.

Dimension Command Icon Overview
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For Baseline or Continue Dimension:
1 Begin by placing a Linear, Aligned or Angular Dimension, using ESnap to select the 

origin points.

2 Click the Baseline  or Continue Dimension  icon on the Dimension toolbar.  Using 
ESnaps, pick the next dimension's extension line origin.  When finished, press <> to 
exit the command.

･ Use ESnap when selecting dimension extension line origin points.
･ Do not explode dimensions.  Associativity to the entity will be lost and the 
dimension will be broken into as many as 10 separate entities.

･ Adjust dimension locations after they have been placed using EGrips.
･ Begin the Baseline and Continue dimensions by placing a linear, aligned or 
angular dimension first.
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Command Exercise ­ Dimensions
Estimated time to completion: 5 minutes

Drawing Name: dim1.dwg

Scope:

Dimension the object as indicated using Linear and Aligned Dimensions.
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Command Exercise ­ Dimensions
Estimated time to completion: 5 minutes

Drawing Name: dim2.dwg

Scope:

Dimension the object as indicated using Baseline and Continue Dimension styles.
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Command Exercise ­ Dimensions
Estimated time to completion: 5 minutes

Drawing Name: dim3.dwg

Scope:

Dimension the object as indicated using Angular, Radius, Diameter Dimensions and 
Center Mark.
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Command Exercise ­ Dimensions
Estimated time to completion: 5 minutes

Drawing Name: dim4.dwg

Scope:

Use the Leader command, first with the Straight and MText setting, Then use the 
Spline and Copy settings.
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Dimension Style

Command Access

Command Overview
The Standard Dimension Style is sufficient for most beginners. However, it may be 
necessary to make minor changes to the Standard Dimension Style or create additional 
Dimension Styles. The Dimension Style Manager dialog box lists and previews selected 
dimension styles. Select Modify to access the Modify Dimension Style options. 
Changes made to the Dimension Styles will globally affect the dimensions in the drawing 
that reference the style being modified, unless the change was made to an individual 
dimension. Only common modifications to dimension styles will be discussed in the 
tutorial.

Toolbar Menu Dimension / Dimension Style
Pull-Down Menu Format>Dimension Style...
Command DimensionStyle
Alias DIMSTYLE
Dialog Box Options>Drafting Styles>Dimension

Drafting Styles Dialog Overview

Style List the name of the current Dimension Style.

New...
Invokes a New Dimension Style dialog box where a new style name 
can be typed, starting with or based on a selected Dimension Style, 
for all or selected dimensions (linear, angular, radial,. etc.).

Rename Renames the selected Dimension Style.

Set Overrides

You can temporarily change settings of the active DimensionStyle. 
These changes do not modify the DimensionStyle settings. The 
overriding settings can be applied as long as no other 
DimensionStyle is set as active.

Differences Compares selected Dimension Styles and displays the differences.

Delete Deletes the selected Dimension Style.

Activate Makes selected Dimension Style current.
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Dimension Style 
Properties Overview

Angular Dimension

Angular dimension settings:
 Format: Sets the primary angular units format 

(Decimal Degrees, Deg/Min/Sec, Grads, or Radians). 
 Precision: Sets the number of decimal places. 
 Zeroes display: Lets you suppress leading and 

trailing zeroes in angular dimensions. 
 Arc length symbols: Lets you set the display of a 

symbol for arc length dimensions: Before dimension 
text, Above dimension text or None.

Arrows

Start arrow: Specifies the Dimension's starting arrow head. 
End arrow: Specifies the Dimension's ending arrow head. 
Leader arrow: Sets the Dimension's leader arrow style. 
Size: Sets the arrow head size.

Dual Dimensions

These options control the use of a second, alternative 
dimensioning method. This mode allows dual dimensioning in 
metric and imperial values.
Show dual dimensions: Determines whether to use alternate 
units in Dimensions.

Dual dimension settings:
 Format: Sets the alternate unit format. 
 Precision: Sets the number of decimal places. 
 Multiplier for converting units: Sets a multiplier 

for converting units. 
 Round to the nearest: Lets you specify a value for 

rounding. 
 Prefix and Suffix: Lets you specify a prefix and 

suffix for the dimension value. 

Zeroes display:
 Hide leading zeroes and Hide trailing zeroes: Lets 

you suppress leading and trailing zeroes. 
 Hide if 0' and Hide if 0": If you set Format to 

Architectural, Architectural Stacked or 
Engineering, you can also specify whether to hide 
zero feet and zero inches. 

Insertion.:
 After primary units and Below primary units: 

Specifies whether alternate units are placed after or 
below the primary dimension value. 
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Linear Dimension

Format: Sets the primary linear units format. 
Precision: Sets the number of decimal places. 
Fractional display: Sets the stack display of fractional units. 
Decimal separator: Sets the decimal separator for dimensions 
whose unit format is set to Decimal. 
Round to the nearest: Lets you specify a value for rounding. 
Prefix and Suffix: Lets you type a character string to appear 
before or after the dimension text. For example, the suffix field 
can display the unit of measurement. 
Measurement scale: 

 Scale factor: Enlarges or reduces the size of all 
dimension entities (except the Dimension value 
itself) and allows Dimension entities to be scaled to 
suit the drawing's aspect ratio. 

Zeroes display: 
 Follow sheet dimensions: Applies the measurement 

scale factor to dimensions created on sheets only. 
 Hide leading zeroes and Hide trailing zeroes: Lets 

you suppress leading and trailing zeroes in decimal 
linear dimensions. 

 Hide if 0' and Hide if 0": If you set Format to 
Architectural or Engineering, you can also specify 
whether to hide zero feet (Hide if 0') and zero inches 
(Hide if 0"). 

Dimension Style 
Properties Overview



DraftSight Text and Dimensions

Dimension Style 233

Fit

Fit options determine how to arrange Dimensions if there is not 
enough space for text and arrows between the extension lines.

Geometry:
When space is limited, move selected entity outside of 
extension lines. When there is not enough room to place text 
and arrows inside the extension lines, the first entity to move 
outside the extension lines is one of the following: 

 Automatic: Either text or arrows (best fit) 
 Arrows 
 Text 
 Text and arrows 
 Keep text between extension lines 
 Hide arrows: Suppresses arrows if they do not fit 

inside the extension lines. 

Dimension text: When dimension text is not in the default 
position, move it. When Dimension text is not in the default 
position, you can place it: 

 Above the dimension line with leader 
 Above the dimension line without leader 
 Next to the dimension line 

Dimension scale:
 Scale factor: Specifies the overall scale for 

DimensionStyle settings. The scale factor influences 
size, distance and spacing, including text and arrow 
head sizes. 

 Scale dimensions according to sheet: Sets a scale 
factor based on the ratio between the current 
Viewport and the drawing sheet. 

Additional options:
 Dimension lines between extension lines: Forces 

dimension lines to remain between the extension 
lines, even if the arrow heads are generated outside 
the dimension. 

 Specify text placement: Lets you position 
dimension text manually; horizontal justification 
settings are ignored. 

Dimension Style 
Properties Overview
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Line

Dimension line settings:
 Style: Sets the dimension line LineStyle. 
 Weight: Sets the dimension line LineWeight. 
 Color: Sets the dimension line LineColor. 
 Offset: Sets the offset distance of dimension lines 

when baseline dimensioning is applied using the 
Baseline Dimension command. 

 Distance past start arrow: Sets a distance to extend 
the dimension line beyond the extension line when 
you apply certain arrow heads such as tick or 
architectural. 

 Hide: 
 Dimension line 1: Determines whether the first 

dimension line and arrow head between the first 
extension line and the Dimension text is displayed. 

 Dimension line 2: Has the same effect as dimension 
line 1 for the second extension line and dimension 
text. 

Extension line settings: Extension lines are the lines that 
extend the dimension outside the perimeter of the measured 
entity, assuming that dimensioning is to take place outside of 
these perimeter constraints. 

 Styles: Sets the LineStyle for Extension line 1 and 
Extension line 2. 

 Weight: Sets the extension line LineWeight. 
 Color: Sets the extension line LineColor. 
 Offset: Sets the offset distance between the entity 

and the point where extension lines begin. 
 Distance past dimension lines: Sets the distance 

the extension lines should run past the dimension 
lines. 

 Hide: Hides the first and/or second extension line. 
 Fixed length: Specifies whether extension lines 

should have a preset length. Set a value in Length. 

Dimension Style 
Properties Overview
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Radial/Diameter 
Dimension

Center mark display:
 None 
 As mark
 As centerline: Defines the display of marks that 

indicate a circle's center point and defines whether 
or not dashes or strokes should be added to center 
marks. 

 Size: Lets you specify the size of center marks for 
center, diameter and radius dimensions. 

Radius dimension jog: 
 Angle: Determines the angle of the transverse 

segment of the dimension line in a jogged radius 
dimension. 

Text

Text settings: 
 Style: Sets the dimension TextStyle. 
 Color: Sets the dimension TextColor. 
 Fill: Sets the dimension text background color. 
 Height: Sets the dimension text height. 
 Fractional scale: Sets a scale factor for the text 

height of tolerance values relative to the general 
dimension text height. 

 Frame dimension text: Draws a frame around 
dimension text. 

Text position:
 Horizontal and Vertical: Sets the horizontal and 

vertical positions of the dimension text. 
 Offset from dimension lines: Sets the distance that 

text is offset from the dimension lines. 

Text alignment: You can align the dimension text with the 
following options: 

 Use ISO standard 
 Align horizontally 
 Align with dimension lines 

Dimension Style 
Properties Overview
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Tolerance

Tolerance settings:
 Calculation: Sets the format for tolerance creation: 
 Basic: Displays the additional dimension 

measurement and deviation in a single value with a 
box around it. 

 Deviation: Appends separate plus and minus values 
of deviation to the dimension measurement. 

 Limits: Displays a maximum and a minimum value, 
one on top of the other. 

 None: Does not generate a tolerance value. 
 Symmetrical: Appends a plus/minus tolerance value 

to the dimension measurement which indicates the 
positive and negative deviation in a single value. 

 Precision: Sets the number of decimal places. 
 Maximum value and Minimum value: Sets values 

for the positive or negative tolerances. 
 Scale: Sets the tolerance scale. 
 Vertical text justification: Sets the tolerance text 

justification. 
 Zeroes display
 Hide leading zeroes and Hide trailing zeroes: Lets 

you suppress leading and trailing zeroes in decimal 
tolerance dimensions. If you set the Format for 
Linear Dimension to Architectural or Engineering, 
you can also specify whether to hide zero feet (Hide 
if 0') and zero inches (Hide if 0"). 

Dual Dimension

Precision: Sets the number of decimal places for alternate 
dimensions in geometric tolerances. 

 Zeroes display
 Hide leading zeroes and Hide trailing zeroes: Lets 

you suppress leading and trailing zeroes in decimal 
alternate dimensions. If you set the Format for 
Linear Dimension to Architectural or Engineering, 
you can also specify whether to hide zero feet (Hide 
if 0') and zero inches (Hide if 0"). 

Dimension Style 
Properties Overview
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General Procedure
To create a new Dimension Style:

1 Click Format>Dimension Style... from the pull-down menu.
2 Select a Dimension Style to start with from the drop-down list. 
3 Click the New button, then type the New Style Name, or accept the default name.
4 Click Continue to access the Modify Dimension Style dialog box.

To modify a Dimension Style:
1 Click Format>Dimension Style... from the pull-down menu.
2 Click the Dimension Style, and then select the Modify button.
3 Click the appropriate tab in the Modify Dimension Style dialog box.
4 Click OK to close and continue.

To delete a Dimension Style:
1 Click Format>Dimension Style... from the pull-down menu.
2 Click the Dimension Style from the list, then right-click (RMB) to access the Shortcut 

menu.
3 Click Delete.  The dimension style will not be deleted if it is current, or if there are any 

dimensions in the drawing using that dimension style.

･ The Clean command can also be used to delete unreferenced Dimension 
Styles.

･ The Standard Dimension Style will be adequate for most beginners.
･ When creating a new Dimension Style, base the new style on Standard, and 
apply changes to it, leaving Standard alone, unless only minor changes are 
needed.

･ Make global modifications to dimensions in the drawing by changing the 
Dimension Style.  Existing dimensions should automatically update.  If for 
some reason they do not update, select the Dimension Rebuild command 
from the Dimension toolbar or from the Dimension pull-down menu.



Text and Dimensions DraftSight

238 Dimension Style

Command Exercise ­ Dimension Styles
Estimated time to completion: 5 minutes

Drawing Name: dimstyle1.dwg

Scope:

Dimension the object on the left using the standard dimension style. Create a new 
dimension style and call it TEST based on the standard dimension style with an overall 
scale (geometry) of 2 (remember to set it to current). Dimension the object on the right 
using this dimension style.ss
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Edit Dimension Location

Command Access

Command Overview
The placement of dimension lines and text can be adjusted using EGrips. With the 
command line blank, select the dimension. Select a Grip box at either the arrow or the 
dimension text. Drag the cursor and then pick the new location. The location of the 
dimension text can be moved closer to one of the extension lines by using the same 
method. This is also a good way to move the extension line origin points, should they be 
incorrectly selected.

General Procedure
To move the dimension line:

1 With the command line blank, click the dimension.
2 Click either the text or arrowhead grip.  The default EGrip mode will be Stretch.
3 Stretch the dimension line and pick a new location.  
4 Press Esc two times to cancel the EGrip selection.

To move the dimension text:
1 With the command line blank, click the dimension.
2 Click the dimension text.  The default EGrip mode will be Stretch.
3 Drag the dimension toward one extension line or the other, or to a new location.
4 Press Esc two times to cancel the EGrip selection.

To move a dimension origin point:
1 Zoom into the area where the dimension origin point should meet the object 

(intersection, endpoint, etc.). 
2 With the command line blank, click the dimension.
3 Click the dimension origin point.  The default EGrip mode will be Stretch.
4 Use ESnap to drag the origin point to the correct location on the object.
5 Press Esc two times to cancel the EGrip selection.

Toolbar Menu
Pull-Down Menu
Command With the command line blank, select the dimension.
Alias
Dialog Box

･ Remember to press the Esc key two times to cancel the grip selection.  
Pressing <> will repeat the last command.
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Edit Dimension Text

Command Access

Command Overview
DraftSight dimensions are associated with the entity being dimensioned, therefore, if the 
dimension text appears to be incorrect, it's either because the dimension line origin 
points were incorrectly selected, or the drawing is incorrect. Check first to see that the 
origin points are at the correct location. If this seems to be correct, then go back and 
correct the drawing. The Edit Text command (EditAnnotation) should be used to add 
annotation to a dimension and not to delete or overwrite existing dimension text. 

General Procedure
1 Click Modify>Entity>Annotation from the pull-down menu.
2 Click the dimension text to edit.
3 In the Edit Annotation dialog, make the necessary changes.
4 Click OK.

Toolbar Menu
Pull-Down Menu Modify>Entity>Annotation
Command EditAnnotation
Alias EDITTEXT
Dialog Box Edit Annotation

･ When you maintain the associativity between the dimension and the entity 
being dimensioned, changes made to the entity will automatically update the 
dimension text.
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Edit Dimension Properties

Command Access

Command Overview
When changing dimension properties, decide whether this change should apply globally 
to the dimension style, or to a single dimension.
For instance, if the precision of the primary units of a dimension style are set to four 
decimal places, and the user wants the precision of radial dimensions to always be two 
places, then a subset style for Radius Dimensions needs to be created from the original 
dimension style. Use the Dimension Style dialog box to make the desired changes, and 
all of the radial dimensions in the drawing will automatically be updated to reflect the 
change.
If you want to change only a selected dimension in the drawing, use the Properties 
command. Changes made to individual dimensions will usually not update globally if a 
change is later made to that Dimension Style.

General Procedure
To change the dimension style properties:

1 Click Format>Dimension Style... from the pull-down menu.
2 In the Dimension Style Manager box, select the dimension style to change, then click 

Activate.
3 Select the options to change, and then click the Save to Active Styles button.
4 Select OK to exit.

To make changes to a specific feature of an existing dimension:
1 Click Format>Dimension Style... from the pull-down menu.
2 In the Style drop-down, choose the name of the dimension style to change.
3 Select the options to change.
4 Click Apply, and then OK.

To make changes to an individual dimension:
1 Click Tools>Properties from the pull-down menu.
2 With an empty command line, click the dimension to change.
3 In the Properties Manager, choose the options to change.
4 Press the Esc key to exit.

Toolbar Menu Dimension / Dimension Style
Pull-Down Menu Format>Dimension Style
Command DimensionStyle
Alias DIMSTYLE
Dialog Box Options>Drafting Styles>Dimension
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Command Exercise ­ Edit Dimensions
Estimated time to completion: 5 minutes

Drawing Name: dimedit1.dwg

Scope:

Use the Properties Manager to modify the dimensions as indicated.
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Command Exercise ­ Edit Dimensions
Estimated time to completion: 5 minutes

Drawing Name: dimedit2.dwg

Scope:

Use the Properties Manager to edit the dimensions. 
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Command Exercise ­ Edit Dimensions
Estimated time to completion: 5 minutes

Drawing Name: dimedit3.dwg

Scope:

Use EGrips to adjust the dimensions as indicated.
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Command Exercise ­ Edit Dimensions
Estimated time to completion: 5 minutes

Drawing Name: dimedit4.dwg

Scope:

Use the Stretch command to modify the part. Notice the dimensions will change 
automatically.
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Section 9 Review Questions
1 Identify the following icons by writing the command and the toolbars where they can be 

found:

2 How can you initiate the Note command?

3 What happens when you Explode a dimension?

4 How can you modify a dimension?

Icon Command Toolbar

a.

b.

c.

d.

e.

f.

g.

h

i

j

k

l
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5 In what pull-down menu can you find the Text Style command?

6 In what pull-down menu can you find the Dimension Style command? 
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Section 10
Drawing Output and Layout

Estimated Class Time: 2.5 hours

Objectives
This section will cover how to create a drawing Layout from a Model and how to print a 
drawing.  The general idea is to create the drawing in the Model Tab and print the 
drawing from the Sheet Tab.  Drawing may also be printed from the Model Tab.  There 
are advantages and disadvantages to using the Model or Sheet tab to print a drawing.
 Drawing Layout
Create a drawing layout from the Model Tab.
 Drawing Layout ViewPorts
Insert a Title Block in the Sheet Tab and create drawing views.
 Print Command
Print drawings from either the Model Tab or the Sheet Tab.

Option Model Tab Sheet Tab
Drawing Views In the Model Tab, only one view 

of the drawing may be printed 
at a time.

In the Sheet Tab, it is possible to print 
multiple views of the same drawing.  
These views can show different parts 
of the drawing, and views can be 
zoomed at different scales.

Plot Scale In Model Tab, the drawing must 
be printed to scale.  It is 
therefore important that the 
drawing boundary and title 
block reflect the drawing scale.  
Text, dimension styles and 
LineTypeScale must also reflect 
the print scale.

Drawing views placed in the Sheet Tab 
must be zoomed to scale (nX/nXP). 
Dimension notes and the title block 
are placed in the Sheet at a scale of 1.  
The Sheet is printed at a scale of 1.

Drawing Revisions In the Model Tab, the drawing 
must be revised in each instance 
where the image is copied in the 
drawing (for instance, if a detail 
was shown at a scale of 1:1 and 
1:10).

In the Sheet Tab, each viewport is a 
window to the model.  Therefore if a 
change is made to the drawing in the 
Model Tab, the changes will 
automatically be reflected in the Sheet 
Tab viewports.
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Drawing Layout

Command Access

Command Overview
You can create a new Sheet or rename, copy, save or delete existing Sheets.  To create a 
finished drawing, two different working spaces are provided: Model and Sheet.  A Sheet 
is a page that allows you to set up a printout or plot of your drawing.  You can create up 
to 255 Sheets of your drawing on individual tabs.  The names of the Sheet tabs must be 
unique.  When you use the Sheet command, you have options to manage Sheet tabs.  
Several of these options are also available by right-clicking a Sheet tab.

General Procedure
To create a new Sheet: 

1 Click File>Sheet>New Sheet (or type Sheet and specify the New option). 
2 Type a Name for the Sheet. 

To create a New Sheet based on a Sheet in another file: 
1 Click File>Sheet>Sheet from Template (or type Sheet and specify the Template 

option). 
2 In the Select template from file dialog box, select a *.dwt, *.dwg, or *.dxf file, then click 

Open. 
3 In the Sheet List dialog box, select a Sheet name and click OK.

The sheet and all entities from the specified file are inserted in the drawing. 

To copy a Sheet: 
1 Type Sheet at the command prompt. 
2 Specify the Copy option. 
3 Type the Name of the Sheet to copy. 
4 Type a Name for the Sheet. 

To rename a Sheet: 
1 Type Sheet. 
2 Specify the Rename option. 
3 Type the Name of the Sheet to rename. 
4 Type a Name for the Sheet. 

Toolbar Menu Sheets  / New Sheet and Sheets / Sheet from Template
Pull-Down Menu File>Sheet>New Sheet and Sheet>Sheet from Template...
Command Sheet
Alias Layout
Dialog Box Specify template from file
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To save a Sheet as a drawing template file: 
1 Type Sheet. 
2 Specify the Save As option. 
3 Type the Name of the Sheet to save as a template.

The template file is saved without Block definition information and unused drawing 
properties such as Layers and LineStyles. 
To activate a Sheet: 

1 Type Sheet.
2 Specify the Activate option.
3 Type the Name of the Sheet to activate.

To delete a Sheet: 
1 Type Sheet.
2 Specify the Delete option.
3 Type the Name of the Sheet to delete.

To list all active Sheets: 
1 Type Sheet.
2 Specify the ? option.

The active Sheets are listed in the command window.

･ You can turn On and Off the display of the Model and Sheet tabs. Click 
Tools>Options. Click Drawing Settings, expand Display, and select or clear 
Show Model and Sheet tabs. 
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Command Exercise - Creating a Drawing Layout
Estimated time to completion: 5 minutes

Drawing Name: layout1.dwg

Scope:

Create a drawing layout.  Use a single viewport.  Zoom into the floating viewport 2:1 
(2XP).
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Command Exercise - Creating a Drawing Layout
Estimated time to completion: 5 minutes

Drawing Name: layout2.dwg

Scope:

Make the floating viewport window frame invisible.  Use the Properties command to set 
the viewport frame on the VP layer.  Freeze the VP layer.  Fill in the information in the 
title block as follows (replace existing text):
Your Name, Today's Date, Title - 5 x 8 MOLD ASSEMBLY, Part No. D-1234
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View Tiles

Command Access

Command Overview
You can divide the drawing window into multiple views. Each view can contain a unique 
view of the drawing. This lets you view different areas of the drawing, whether they are 
plan views in different detailing grades, or the model from different viewpoints in 3D 
space. 
You can work in only one view at a time, the current view. 
Tiled views do not overlap on the workspace like drawing windows can. It is just as if 
you divided the drawing window into two, three or four rectangular areas. You can 
arrange these areas in several combinations.
A group of tiled views is called a ViewTile configuration.
You can define, save and restore ViewTile configurations using the View Tiles dialog 
box.

General Procedure
To define a ViewTile configuration: 

1 Click View>View Tiles>View Tiles Manager (or type ViewTiles). 
2 Under Type, select New. 
3 Under Default configurations, select a ViewTile configuration you want to use or 

store under a name. 

Active Model Configuration lets you use the configuration as it was when you opened 
the dialog box. 

4 Under Orientation, select: 
 2D: Initiates all ViewTiles of the configuration you define with the current view. 
 3D: Lets you define standard orthographic or isometric 3D views in Replace view 

with for each ViewTile. 
5 Under Apply to, select: 

 Active View Tile: Applies the ViewTile configuration to the current view. You can 
further subdivide standard ViewTile configurations. 

 Display: Applies the ViewTile configuration to the entire drawing.

Toolbar Menu View Tiles
Pull-Down Menu View>View Tiles (Choose Option)
Command ViewTiles
Alias VTILES
Dialog Box View Tiles
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To save a ViewTile configuration under a name: 
1 Click View>View Tiles>View Tiles Manager (or type ViewTiles). 
2 Under Type, select New. 
3 Under Name, type the Name of the ViewTile configuration to save. 
4 Under Default configurations, select a default configuration. 
5 If you want different 3D views represented in the views: 

 Under Orientation, select 3D. 
 Under Replace view with, select an orthographic or isometric view to display in the 

specified view. 
6 Click Save.

To restore a named ViewTile configuration: 
1 Click View>View Tiles>View Tiles Manager (or type ViewTiles). 
2 Under Type, select Named. 
3 Under Named configurations, select a name. 
4 Click OK. 

To delete a named ViewTile configuration: 
1 Click View>View Tiles>View Tiles Manager (or type ViewTiles). 
2 Under Type, select Named. 
3 Under Named configurations, right-click a name and click Delete. 
4 Click OK. 

To join views of a ViewTile configuration: 
1 Type -Viewport.
2 Specify the Join option.

 Two adjacent ViewTiles combine into one ViewTile. The resulting ViewTile inherits 
the view of the dominant ViewTile. 
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Command Exercise - Creating ViewTiles in the Sheet Tab
Estimated time to completion: 5 minutes

Drawing Name: 2vtiles.dwg

Scope:

In the Sheet tab, create two ViewTiles inside the border of the drawing.  In the left-hand 
ViewPort, Zoom the drawing so all views are present.  In right-hand ViewPort, Zoom into 
the right-side view only.
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Working with Viewports on Sheets

Command Access

Command Overview
The Viewport command creates and controls multiple tiled views on Sheets, called 
Viewports. Viewports on Sheets are different than ViewTiles in model workspace which 
are created using the ViewTiles command.
You can create, erase, move, copy, scale and stretch Viewports on Sheets.

To activate a Sheet: 
1 Click a Sheet tab (if the Model tab is active). 

To create a rectangular Viewport: 
1 Type Viewport at the command prompt. 
2 Click in the graphics area to set the first and second Viewport corner. 

To create two, three or four Viewports: 
1 Type Viewport. 
2 Specify the 2, 3 or 4 option depending on how many viewports you want to add to the 

current Sheet. 
3 Specify an option for the arrangement (Horizontal or Vertical, for example).

2 Viewports: 

3 Viewports: 

4 Viewports: 
4 Click in the graphics area or type a value to set the corners of the viewport, or specify 

the Fit option. 

Toolbar Menu
Pull-Down Menu
Command Viewport
Alias MV
Dialog Box

･ You cannot use the Viewport command in the Model tab.
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To create a Viewport that fills the Sheet to the edges of the printable area: 
1 Type Viewport. 
2 Specify the Fit option.

When the printable area is turned off, the Viewport fits the entire Sheet. 
To convert a closed PolyLine, Circle, Ellipse, closed Spline or Region into a Viewport: 

1 Type Viewport. 
2 Specify the Entity option. 
3 In the graphics area, select the entity to convert into a Viewport. 

To create a Viewport with a polygonal boundary: 
The Polygonal option lets you draw an irregular shape that defines the boundary of a 
Viewport.

1 Type Viewport. 
2 Specify the Polygonal option. 
3 Click in the graphics area to set the first point that defines the boundary. 
4 Define the rest of the boundary: 

 Click in the graphics area to specify additional points.
- or - 
 Specify the Arc option. Follow the prompts to create arc segments for the Viewport 

boundary. The options for creating arc segments are similar to those of the PolyLine 
command.

- or - 
 Specify the Length option. Follow the prompts to create a line segment of a specified 

length at the same angle as the previous segment. This option is useful to append a 
straight segment of a specified length tangent to a previous arc segment.

- or - 
 Specify the Close option to close the boundary.
- or - 
 Specify the Undo option to undo the most recent segment during the creation of the 

Viewport boundary.

To turn on Viewports: 
1 Type Viewport. 
2 Specify the On option. 
3 In the graphics area, select the Viewports to turn on.

The model displays in the selected Viewports. 
To turn off Viewports: 

1 Type Viewport. 
2 Specify the Off option. 
3 In the graphics area, select the Viewports to turn off.

The model does not display in the selected Viewports. 
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To set Viewport print options: 
1 Type Viewport. 
2 Specify the Shaded view option. 
3 Specify an option: 

 Current display: Prints the Viewport as it is displayed on-screen. 
 Hidden: Prints the Viewport with hidden lines removed. 
 Rendered: Prints the Viewport rendered. 
 Wireframe: Prints the Viewport as wireframe. 

4 In the graphics area, select the Viewports to which the settings should apply. 

To lock or unlock a Viewport: 
The Lock option prevents changes to the zoom scale factor when you work in locked 
Viewports in model workspace.

1 Type Viewport. 
2 Specify the Lock option. 
3 Specify On to lock or Off to unlock. 
4 In the graphics area, select the Viewports to which the settings should apply. 

To restore Viewport configurations saved using the Viewport command: 
1 Type Viewport. 
2 Specify the Restore option. 
3 Type the Name of the Viewport configuration to restore.

- or - 
 Specify the ? option to list Viewport configurations.
- or - 
 Specify the Active model configuration option. 
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Print 

Command Access

Command Overview
You can print the drawing to a printer, plotter or file.

General Procedure
To print or plot a drawing:

Toolbar Menu Standard
Pull-Down Menu File>Print
Command Print
Alias PLOT
Dialog Box Print

Print Option Overview Settings

Page Layout Options

Quick Print Prints exactly what is on 
screen with the system 
default printer, default paper 
size, Fit to paper size selected, 
and Print range set to Current 
view.

Default Printer
Default Paper Size
Scale: fit to paper

Use previous settings Repeats printing with the 
same settings you used for 
the previous printout.

Same as previous print

Manual Setup Lets you determine the 
current print settings.

Choose Printer
Choose Paper
Choose Scale
Choose Print Range

Printer/plotter In Name, select an output 
device. Printers and plotters 
available on your system are 
listed. PDF, JPG, PNG and SVG 
are also listed. These built-in 
plotters print to file in the 
specified format.

Click Properties to set up the 
printer or plotter as needed in 
the dialog box provided by 
the printer's driver. 

Choose Printer
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Paper size Select a size from the list of 
international standardized 
paper size formats and 
printer-specific paper 
formats.

Choose Paper size

Print scale Clear Fit to paper size to 
apply specific scaling.

Select or define a Scale.
In Scale, select User-defined, 
then determine the ratio 
between paper units (in 
Millimeters or Inches) to 
drawing units.

Select or clear Scale 
LineWeight to print scale. 

Choose appropriate scale

Print Range

All geometry Prints the range that is 
determined by the bounding 
box of all visible entities.

Drawing boundary Prints the range that is 
determined by the drawing 
boundaries.

Named view Prints the selected user-
defined view.

Specific Click Specify Window to 
select two opposite points for 
the print boundaries in the 
graphics area.

Current view Prints the drawing that is 
visible on screen.

Additional Options

Hide geometry on sheet Specifies whether the 
geometry of the model shown 
in Viewports is printed with 
hidden lines removed. The 
option is available only from a 
Sheet tab.

Print Option Overview Settings
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Print in background The output is processed in the 
background so you can 
continue working in the 
drawing.

Print sheet last Specifies what to print first: 
the geometry of the model in 
Viewports or the geometry of 
the Sheet in the graphics area. 
The option is available only 
from a Sheet tab.

Use assigned LineWeight Prints entities in the 
LineWeights assigned in the 
Layers. This option is 
available only if Use assigned 
print styles is cleared.

Use assigned print styles Determines whether 
PrintStyles applied to Layers 
and entities are printed. This 
implies that assigned 
LineWeights are also printed.

Shaded Views

Print style The shade mode you want to 
apply when printing.

Print quality Quality level when printing. 
The available options depend 
on the selected printer.

DPI Sets the number of dots per 
inch printed depending on the 
Print quality setting.

Print style table Select a PrintStyle. Click New to create a new 
PrintStyle.

Click Edit to modify the 
selected PrintStyle

Orientation Select Portrait or Landscape 
format.

Select Print inverse to reverse 
the output direction.

Print Option Overview Settings
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Command Exercise - Printing a Drawing
Estimated time to completion: 5 minutes

Drawing Name: print1.dwg

Scope: 

Activate Layout1 tab.  Delete the current ViewPort and create a new one that is 22 x 17.  
Fit the drawing into the ViewPort using Zoom .5xp, and center the drawing.  Print to a 
local printer at a scale of .5 on an 8.5 x 11 sheet of paper.
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Section 10 Review Questions
1 True or false: You should create your drawing in the Model tab, but you can print your 

drawing from either the Model tab or the Sheet tab.

2 From what pull-down menu can you find the ViewTiles command?

3 What command does this icon represent  and on which toolbar is it located?

4 What toolbar contains the commands for creating View Tiles?

5 What is "Print Area" and how does it relate to paper size?

6 True or false: When you print from the Sheet Tab, your print scale must be 1:1.
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